Crear segmentos de línea densificados
En el panel Crear entidades, la opción Densificar líneas está disponible con plantillas de entidades que crean entidades de línea. Crear un segmento de línea densificado inserta vértices adicionales a intervalos pares que se especifican en el panel de herramientas como distancia de muestra. Los arcos y curvas no se densifican.
Nota:
Este ajuste no está disponible en escenas 3D con esta versión de ArcGIS AllSource.
Crear segmentos de línea densificados en 2D
Un uso habitual de la creación de segmentos de línea densificados en 2D es insertar vértices para el ajuste automático de los enlaces "de-a" al transformar entidades.
Si el mapa actual no contiene ninguna capa de entidades de línea, agréguela.
En la pestaña Ver, haga clic en Panel Catálogo
y expanda Bases de datos
.Expanda la base de datos predeterminada o la base de datos que contiene sus datos.
Para crear una clase de entidad de línea, haga clic con el botón derecho en la base de datos, haga clic en Nuevo y en Clase de entidad.
Arrastre la clase de entidad al mapa.
Se genera automáticamente una plantilla de entidad con una configuración predeterminada para la nueva capa.
En la pestaña Editar, defina sus preferencias de alineación y muestre el panel Crear entidades.
En el grupo Alineación, habilite sus preferencias de alineación.
Sugerencia:
Puede pulsar y mantener pulsada la Barra espaciadora para desactivar temporalmente la alineación cuando esboza una entidad.
En el grupo Entidades, haga clic en Crear
.
En el panel Crear entidades, elija una plantilla de entidad y defina sus valores de atributo.
Haga clic en una plantilla de entidad de línea.
Haga clic en el botón Plantilla activa
.Haga clic en Atributos
y escriba los valores que desee aplicar a la nueva entidad.
Configura la plantilla para crear líneas densificadas.
Haga clic en Línea
.Active la casilla de verificación Densificar líneas.
Nota:
Este ajuste desactiva las herramientas de segmentos de arco de la barra de herramientas de construcción. Puede desactivar este ajuste en cualquier momento mientras crea la entidad de línea para habilitar las herramientas y crear segmentos que no estén densificados.
En el cuadro de texto Distancia de muestra, escriba la distancia que desee entre cada vértice.
Haga clic en el mapa, mueva el puntero y vuelva a hacer clic en el mapa.
Fíjese en los vértices adicionales que se generan automáticamente entre los dos puntos en los que ha hecho clic en el mapa.
En la barra de herramientas de edición, haga clic en Finalizar
o pulse la tecla F2.
Crear segmentos de línea densificados en 3D
Un uso habitual a la hora de crear segmentos de línea densificados en 3D es colocarlos sobre una superficie de elevación. Puede establecer un valor z constante o activar el modo de elevación para obtener los valores z a partir de la superficie de elevación activa mientras dibuja una línea sobre el mapa.
Para conocer los pasos para agregar una superficie de elevación, consulte Superficies de elevación.
Si el mapa actual no contiene una capa de elementos lineales 3D con eje Z habilitado, agréguela.
En la pestaña Ver, haga clic en Panel Catálogo
y expanda Bases de datos
.Expanda la base de datos predeterminada o la base de datos que contiene sus datos.
Para crear una clase de entidad de línea, haga clic con el botón derecho en la base de datos, haga clic en Nuevo y en Clase de entidad.
Arrastre la clase de entidad al mapa.
Se genera automáticamente una plantilla de entidad con una configuración predeterminada para la nueva capa.
En la pestaña Editar, defina sus preferencias de alineación y muestre el panel Crear entidades.
En el grupo Alineación, habilite sus preferencias de alineación.
Sugerencia:
Puede pulsar y mantener pulsada la Barra espaciadora para desactivar temporalmente la alineación cuando esboza una entidad.
En el grupo Entidades, haga clic en Crear
.
En el panel Crear entidades, elija una plantilla de entidad y defina sus valores de atributo.
Haga clic en una plantilla de entidad de línea.
Haga clic en el botón Plantilla activa
.Haga clic en Atributos
y escriba los valores que desee aplicar a la nueva entidad.
Configura la plantilla para crear líneas densificadas.
Haga clic en Línea
.Active la casilla de verificación Densificar líneas.
Nota:
Este ajuste desactiva las herramientas de segmentos de arco de la barra de herramientas de construcción. Puede desactivar este ajuste en cualquier momento mientras crea la entidad de línea para habilitar las herramientas y crear segmentos que no estén densificados.
En el cuadro de texto Distancia de muestra, escriba la distancia que desee entre cada vértice.
En la pestaña Editar, en el grupo Elevación, haga clic en la flecha desplegable Modo
y active uno de los siguientes modos de valor z:Modo constante
: los valores Z se introducen en el cuadro de texto y se aplican a todos los vértices hasta que se modifique el valor.Modo Superficie
: los valores Z de la superficie se obtienen a partir de la superficie de elevación activa cuando se hace clic en el mapa y la línea se superpone a la superficie.
Haga clic en el mapa, mueva el puntero y vuelva a hacer clic en el mapa.
Fíjese en los vértices adicionales que se generan automáticamente entre los dos puntos en los que ha hecho clic en el mapa.
En la barra de herramientas de edición, haga clic en Finalizar
o pulse la tecla F2.