Skip to main content

Créer des segments de ligne densifiés

Dans la fenêtre Create Features (Créer des entités), le paramètre Densify Lines (Densifier des lignes) est disponible avec des modèles d’entité qui créent des entités linéaires. La création d’un segment de ligne densifié insère des sommets supplémentaires à intervalles réguliers spécifiés dans le panneau des outils comme une distance d’exemple. Les arcs et courbes ne sont pas densifiés.

Remarque :

Ce paramètre n’est pas disponible dans les scènes 3D avec cette version d’ArcGIS AllSource.

Créer des segments de ligne densifiés en 2D

Lors de la création de segments de ligne densifiés en 2D une utilisation courante consiste à insérer des sommets pour la capture de liens origine/destination lors de la transformation d’entités.

  1. Si la carte actuelle ne contient aucune couche d’entités linéaires, ajoutez-en une.

    1. Sous l’onglet View (Vue), cliquez sur Catalog Pane (Fenêtre Catalogue)  et développez Databases (Bases de données) .

    2. Développez la base de données par défaut ou la base de données qui contient vos données.

      Pour créer une classe d’entités, cliquez avec le bouton droit de la souris sur la base de données, sélectionnez New (Nouveau), puis cliquez sur Feature Class (Classe d’entités).

    3. Faites glisser la classe d’entités sur la carte.

      Un modèle d’entités assorti des paramètres par défaut est généré automatiquement pour la nouvelle couche.

  2. Dans l’onglet Edit (Modifier), définissez vos préférences de capture et affichez la fenêtre Create Features (Créer des entités).

    1. Dans le groupe Snapping (Capture), définissez vos préférences de capture.

      Conseil :

      Maintenez la barre d’espacement enfoncée pour désactiver temporairement la capture lorsque vous construisez une entité.

    2. Dans le groupe Features (Entités), cliquez sur Create (Créer) .

  3. Dans la fenêtre Create Features (Créer des entités), sélectionnez un modèle d’entité et définissez vos valeurs attributaires.

    1. Cliquez sur un modèle d’entités linéaires.

    2. Cliquez sur le bouton du modèle actif .

    3. Cliquez sur Attributes (Attributs) et saisissez les valeurs à appliquer à la nouvelle entité.

  4. Configurez le modèle pour créer des lignes densifiées.

    1. Cliquez sur Line (Ligne) .

    2. Cochez la case Densify Lines (Densifier les lignes).

      Remarque :

      Ce paramètre désactive les outils des segments d’arc dans la barre d’outils de construction. Vous pouvez désactiver ce paramètre à tout moment lorsque vous créez l’entité linéaire pour activer les outils et créer des segments non densifiés.

    3. Dans la zone de texte Sample Distance (Distance d’exemple), saisissez la distance que vous souhaitez entre chaque segment.

  5. Cliquez sur la carte, déplacez le pointeur et cliquez à nouveau sur la carte.

    Notez les sommets supplémentaires automatiquement générés entre les deux points sur lesquels vous avez cliqué sur la carte.

  6. Dans la barre d’outils de mise à jour, cliquez sur Finish (Terminer) ou appuyez sur la touche F2.

    Barre d’outils Construction

Créer des segments de ligne densifiés en 3D

Lors de la création de segments de ligne densifiés en 3D une utilisation courante consiste à les draper sur une surface d’élévation. Vous pouvez définir une valeur z constante ou définir le mode d’altitude pour déduire les valeurs z de la surface d’élévation active lorsque vous construisez une ligne sur une carte.

Pour savoir comment ajouter une surface d’élévation à une carte, reportez-vous à la rubrique Surfaces d’élévation.

  1. Si la carte actuelle ne contient aucune couche d’entités surfaciques 3D acceptant les valeurs z, ajoutez-en une.

    1. Sous l’onglet View (Vue), cliquez sur Catalog Pane (Fenêtre Catalogue)  et développez Databases (Bases de données) .

    2. Développez la base de données par défaut ou la base de données qui contient vos données.

      Pour créer une classe d’entités, cliquez avec le bouton droit de la souris sur la base de données, sélectionnez New (Nouveau), puis cliquez sur Feature Class (Classe d’entités).

    3. Faites glisser la classe d’entités sur la carte.

      Un modèle d’entités assorti des paramètres par défaut est généré automatiquement pour la nouvelle couche.

  2. Dans l’onglet Edit (Modifier), définissez vos préférences de capture et affichez la fenêtre Create Features (Créer des entités).

    1. Dans le groupe Snapping (Capture), définissez vos préférences de capture.

      Conseil :

      Maintenez la barre d’espacement enfoncée pour désactiver temporairement la capture lorsque vous construisez une entité.

    2. Dans le groupe Features (Entités), cliquez sur Create (Créer) .

  3. Dans la fenêtre Create Features (Créer des entités), sélectionnez un modèle d’entité et définissez vos valeurs attributaires.

    1. Cliquez sur un modèle d’entités linéaires.

    2. Cliquez sur le bouton du modèle actif .

    3. Cliquez sur Attributes (Attributs) et saisissez les valeurs à appliquer à la nouvelle entité.

  4. Configurez le modèle pour créer des lignes densifiées.

    1. Cliquez sur Line (Ligne) .

    2. Cochez la case Densify Lines (Densifier les lignes).

      Remarque :

      Ce paramètre désactive les outils des segments d’arc dans la barre d’outils de construction. Vous pouvez désactiver ce paramètre à tout moment lorsque vous créez l’entité linéaire pour activer les outils et créer des segments non densifiés.

    3. Dans la zone de texte Sample Distance (Distance d’exemple), saisissez la distance que vous souhaitez entre chaque segment.

  5. Dans l’onglet Edit (Mettre à jour), dans le groupe Elevation (Élévation), cliquez sur la flèche de liste déroulante Mode et activez l’un des modes des valeurs z suivants :

    • Mode Constant (Constante) Constant (Constante) : les valeurs z sont saisies dans la zone de texte et appliquées à tous les sommets jusqu’à ce que vous modifiez la valeur.

    • Mode Surface Surface : les valeurs z découlent de la surface d’élévation active lorsque vous cliquez sur la carte et la ligne est drapée sur la surface.

  6. Cliquez sur la carte, déplacez le pointeur et cliquez à nouveau sur la carte.

    Notez les sommets supplémentaires automatiquement générés entre les deux points sur lesquels vous avez cliqué sur la carte.

  7. Dans la barre d’outils de mise à jour, cliquez sur Finish (Terminer) ou appuyez sur la touche F2.

    Barre d’outils Construction