Skip to main content

密度化したラインのセグメントの作成

フィーチャの作成 ウィンドウの ラインの頂点挿入 設定は、ライン フィーチャを作成するフィーチャ テンプレートで使用できます。 密度化したライン セグメントを作成すると、ツール ウィンドウでサンプル距離として指定した一定間隔で追加の頂点が挿入されます。 円弧と曲線は密度化されません。

注意:

この設定は、このリリースの ArcGIS AllSource の 3D シーンでは使用できません。

2D 密度化したライン セグメントの作成

2D 密度化したライン セグメントの一般的な用途として、フィーチャを変換する際の始点-終点リンクにスナップ用の頂点を挿入する操作があります。

  1. 現在のマップにライン フィーチャ レイヤーが含まれていない場合は、レイヤーを追加します。

    1. 表示 タブで、カタログ ウィンドウ をクリックし、データベース を展開します。

    2. デフォルトのデータベースまたはデータを含むデータベースを展開します。

      ライン フィーチャクラスを作成するには、該当するデータベースを右クリックし、新規 をクリックしてから フィーチャクラス をクリックします。

    3. そのフィーチャクラスをマップ上にドラッグします。

      デフォルト設定を含むフィーチャ テンプレートが新しいレイヤー用に自動的に生成されます。

  2. 編集 タブでスナップ設定を指定し、フィーチャ作成 ウィンドウを表示します。

    1. スナップ グループでスナップ設定を有効にします。

      ヒント:

      フィーチャをスケッチする際にスナップを一時的にオフにするには、スペースバーを押したままにします。

    2. フィーチャ グループの 作成 をクリックします。

  3. フィーチャ作成 ウィンドウで、フィーチャ テンプレートを選択して、属性値を設定します。

    1. ライン フィーチャ テンプレートをクリックします。

    2. アクティブなテンプレート ボタンをクリックします。

    3. 属性 をクリックして、新しいフィーチャに適用する値を入力します。

  4. 密度化したラインを作成するようにテンプレートを設定します。

    1. ライン をクリックします。

    2. ラインの頂点挿入 チェックボックスをオンにします。

      注意:

      この設定では、作図ツールバーの円弧セグメント ツールが無効になります。 ライン フィーチャの作成中にこの設定をいつでもオフにして、ツールを有効にし、密度化されていないセグメントを作成できます。

    3. サンプル距離 テキスト ボックスに、各頂点間の距離を入力します。

  5. マップをクリックし、ポインターを移動して、もう一度マップをクリックします。

    マップ上でクリックした 2 点の間に自動的に生成される追加の頂点を確認します。

  6. 編集ツールバーで 完了 をクリックするか、F2 キーを押します。

    作図ツールバー

3D 密度化したライン セグメントの作成

3D 密度化したライン セグメントの一般的な用途として、標高サーフェス上へのドレープがあります。 マップ上でラインをスケッチする際に、一定の Z 値を設定するか、アクティブな標高サーフェスから Z 値を取得するよう標高モードを設定できます。

マップに標高サーフェスを追加する手順については、標高サーフェスをご参照ください。

  1. 現在のマップに Z 値対応の 3D ライン フィーチャ レイヤーが含まれていない場合は、レイヤーを追加します。

    1. 表示 タブで、カタログ ウィンドウ をクリックし、データベース を展開します。

    2. デフォルトのデータベースまたはデータを含むデータベースを展開します。

      ライン フィーチャクラスを作成するには、該当するデータベースを右クリックし、新規 をクリックしてから フィーチャクラス をクリックします。

    3. そのフィーチャクラスをマップ上にドラッグします。

      デフォルト設定を含むフィーチャ テンプレートが新しいレイヤー用に自動的に生成されます。

  2. 編集 タブでスナップ設定を指定し、フィーチャ作成 ウィンドウを表示します。

    1. スナップ グループでスナップ設定を有効にします。

      ヒント:

      フィーチャをスケッチする際にスナップを一時的にオフにするには、スペースバーを押したままにします。

    2. フィーチャ グループの 作成 をクリックします。

  3. フィーチャ作成 ウィンドウで、フィーチャ テンプレートを選択して、属性値を設定します。

    1. ライン フィーチャ テンプレートをクリックします。

    2. アクティブなテンプレート ボタンをクリックします。

    3. 属性 をクリックして、新しいフィーチャに適用する値を入力します。

  4. 密度化したラインを作成するようにテンプレートを設定します。

    1. ライン をクリックします。

    2. ラインの頂点挿入 チェックボックスをオンにします。

      注意:

      この設定では、作図ツールバーの円弧セグメント ツールが無効になります。 ライン フィーチャの作成中にこの設定をいつでもオフにして、ツールを有効にし、密度化されていないセグメントを作成できます。

    3. サンプル距離 テキスト ボックスに、各頂点間の距離を入力します。

  5. 編集 タブの 標高 グループで、モード ドロップダウン矢印をクリックして、次のいずれかの Z 値モードを有効にします:

    • 定数 モード定数 - テキスト ボックスに入力した Z 値が、値を変更するまですべての頂点に適用されます。

    • サーフェス モードサーフェス - マップをクリックするとアクティブな標高サーフェスから Z 値が取得され、ラインがサーフェス上にドレープされます。

  6. マップをクリックし、ポインターを移動して、もう一度マップをクリックします。

    マップ上でクリックした 2 点の間に自動的に生成される追加の頂点を確認します。

  7. 編集ツールバーで 完了 をクリックするか、F2 キーを押します。

    作図ツールバー