Skip to main content

GNSS デバイスの位置からフィーチャを作成

フィーチャ作成 ウィンドウで、フィーチャ テンプレートを使用すると、接続された GNSS (全球測位衛星システム) デバイスからストリームされた地理的な位置でフィーチャを作成できます。 これは、GNSS デバイスがプロジェクトに追加され、デバイスの位置が現在のマップで有効な場合に使用できます。

接続された GNSS デバイスからストリームされた位置でポイント フィーチャまたは頂点を作成するには、次の手順を実行します。

  1. GNSS デバイスをプロジェクトに追加します。

    1. 表示 タブの デバイスの位置 グループで、デバイスの位置オプション ダイアログ ボックス ランチャーをクリックします。

    2. オプション ダイアログ ボックスで、デバイスの位置 タブをクリックします。

    3. GNSS デバイス 矢印をクリックして、アクティブな GNSS デバイスを選択し、精度の閾値を設定します。

      デバイスの位置オプション ダイアログ ボックス

    4. 精度の閾値を変更するには、精度の閾値 テキスト ボックスに値を入力して、単位を設定します。

    5. OK をクリックします。

  2. デバイスの位置を有効にして、ナビゲーション設定を調整します。

    青いマーカーはマップ上でデバイスの移動を追跡します。 赤いマーカーは、位置データの精度がプロジェクトの [オプション] 設定でデバイスに設定された精度の閾値を超えていることを示します。

    1. 表示 タブの デバイスの位置 グループで、位置の有効化 をクリックします。

      デバイスの位置 タブと、接続されているデバイスのマップ内の位置マーカーが表示されます。

      注意:

      デバイスの位置 ウィンドウを表示して、デバイスの位置の詳細を表示するには、デバイスの位置 矢印をクリックして、位置の詳細 をクリックします。

    2. デバイスの位置 タブで、表示とナビゲーション設定を調整します。

      接続されたデバイスの現在の位置に画面移動するには、候補の位置に移動 をクリックします。

      デバイスの位置タブ

  3. 現在のマップにデータのフィーチャ レイヤーが含まれていない場合は、そのフィーチャ レイヤーを追加します。

    1. 表示 タブで、カタログ ウィンドウ をクリックし、データベース を展開します。

    2. デフォルトのデータベースまたはデータを含むデータベースを展開します。

      フィーチャクラスを作成するには、該当するデータベースを右クリックし、新規 をクリックしてから フィーチャクラス をクリックします。

    3. そのフィーチャクラスをマップ上にドラッグします。

      デフォルト設定を含むフィーチャ テンプレートが新しいレイヤー用に自動的に生成されます。

  4. フィーチャ作成 ウィンドウを開いて、フィーチャ テンプレートを選択します。

    1. 編集 タブで 作成 をクリックします。

    2. ポイント、ライン、またはポリゴン フィーチャ テンプレートをクリックします。

      マップの下部に作図ツールバーが表示されます。

  5. 作図ツールバーで、デバイスの位置の追加 をクリックするか、Ctrl+G を押して、マーカーが示すデバイスの現在の地理的な位置にポイント フィーチャまたは頂点を作成します。

    複数のポイントまたは頂点を作成する場合は、この手順を繰り返します。 GNSS メタデータ フィールドが存在する場合は、GNSS 位置情報が自動設定されます。

    これらのフィールドをソース フィーチャクラスに追加するには、GPS メタデータ フィールドの追加 ジオプロセシング ツールを使用します。

    • ポイント フィーチャ テンプレートを使用すると、ポイント フィーチャを作成して、各フィーチャを自動的に完成できます。

      ポイント フィーチャのデバイスの位置の追加

    • ライン フィーチャ テンプレートとポリゴン フィーチャ テンプレートを使用すると、頂点を作成できます。 フィーチャを完成させて、別のフィーチャを作成するには、完了 をクリックするか、F2 を押します。

      デバイスの位置での頂点の追加

    注意:

    警告ツール アイコンは、位置データの精度がプロジェクトの オプション 設定でデバイスに設定された精度の閾値を超えていることを示します。

  6. アクティブなフィーチャの作図ツールを終了してツールバーを非表示にするには、Esc を押します。

  7. 編集 タブにある 管理 グループで、編集の保存 をクリックして、編集内容を保存します。