Создание уплотненных сегментов линии
На панели Создать объекты настройка Уплотнить линии доступна для шаблонов объектов, которые создают линейные объекты. Создание уплотненного сегмента линии вставляет дополнительные вершины через равные интервалы, которые указываются на панели инструмента как расстояние выборки. Дуги и кривые не уплотняются.
Примечание:
Эта настройка недоступна в 3D-сценах в данном выпуске ArcGIS AllSource.
Создание уплотненных 2D-сегментов линии
Распространенный случай использования создания 2D-уплотненных сегментов линии — вставка вершин для замыкания связей ИЗ-В при трансформации объектов.
Если текущая карта не содержит слой линейных объектов, добавьте его.
На вкладке Вид щелкните Панель Каталог
и разверните Базы данных
.Разверните базу данных по умолчанию или базу данных, содержащую ваши данные.
Чтобы создать класс линейных объектов, щелкните правой кнопкой мыши базу данных, щелкните Создать и щелкните Класс пространственных объектов.
Перетащите класс объектов на карту.
Для нового слоя будет автоматически сгенерирован шаблон объектов с настройками по умолчанию.
На вкладке Редактирование задайте параметры замыкания и откройте панель Создать объекты.
В группе Замыкание задайте необходимые параметры замыкания.
Подсказка:
Вы можете нажать и удерживать пробел, чтобы временно отключить замыкание при создании скетча пространственного объекта.
В группе Объекты щёлкните Создать
.
В панели Создать объекты выберите шаблон объекта и задайте значения атрибутов.
Щелкните шаблон линейного объекта.
Щелкните кнопку активного шаблона
.Щелкните Атрибуты
и введите значения, которые вы хотите применить к новому пространственному объекту.
Настройте шаблон для создания уплотненных линий.
Щелкните Линия
.Поставьте отметку возле опции Уплотнить линии.
Примечание:
Эта настройка отключает инструменты сегмента дуги на панели инструментов построения. Вы можете отключить эту настройку в любое время, пока создаете линейный объект, чтобы включить инструменты и создать неуплотненные сегменты.
В поле Расстояние разбиения введите расстояние между каждой вершиной.
Щелкните на карте, переместите курсор и снова щелкните на карте.
Обратите внимание на дополнительные вершины, которые автоматически генерируются между двумя точками, которые вы щелкнули на карте.
На панели инструментов редактирования щелкните Готово
или нажмите клавишу F2.
Создание уплотненных 3D-сегментов линии
Распространенный случай использования создания 3D-уплотненных сегментов линии — их размещение на поверхности высот. Вы можете задать константу z-значения или установить режим высот для получения z-значений из активной поверхности высот при рисовании скетча линии на карте.
Подробнее о шагах для добавления поверхности высот на карту см. Поверхности высот.
Если текущая карта не содержит слой линейных 3D-объектов с включенной z-координатой, добавьте его.
На вкладке Вид щелкните Панель Каталог
и разверните Базы данных
.Разверните базу данных по умолчанию или базу данных, содержащую ваши данные.
Чтобы создать класс линейных объектов, щелкните правой кнопкой мыши базу данных, щелкните Создать и щелкните Класс пространственных объектов.
Перетащите класс объектов на карту.
Для нового слоя будет автоматически сгенерирован шаблон объектов с настройками по умолчанию.
На вкладке Редактирование задайте параметры замыкания и откройте панель Создать объекты.
В группе Замыкание задайте необходимые параметры замыкания.
Подсказка:
Вы можете нажать и удерживать пробел, чтобы временно отключить замыкание при создании скетча пространственного объекта.
В группе Объекты щёлкните Создать
.
В панели Создать объекты выберите шаблон объекта и задайте значения атрибутов.
Щелкните шаблон линейного объекта.
Щелкните кнопку активного шаблона
.Щелкните Атрибуты
и введите значения, которые вы хотите применить к новому пространственному объекту.
Настройте шаблон для создания уплотненных линий.
Щелкните Линия
.Поставьте отметку возле опции Уплотнить линии.
Примечание:
Эта настройка отключает инструменты сегмента дуги на панели инструментов построения. Вы можете отключить эту настройку в любое время, пока создаете линейный объект, чтобы включить инструменты и создать неуплотненные сегменты.
В поле Расстояние разбиения введите расстояние между каждой вершиной.
На вкладке Редактирование, в группе Высота, щелкните стрелку ниспадающего меню Режим
и включите один из следующих режимов z-значений:Константа режим
—z-значения вводятся в текстовое окно и применяются ко всем вершинам, пока вы не измените значение.Поверхность режим
—z-значения извлекаются из активной поверхности высот, когда вы щелкаете карту, и линия размещается на поверхности.
Щелкните на карте, переместите курсор и снова щелкните на карте.
Обратите внимание на дополнительные вершины, которые автоматически создаются между двумя точками, по которым вы щелкнули на карте.
На панели инструментов редактирования щелкните Готово
или нажмите клавишу F2.