Skip to main content

创建增密线段

在创建要素窗格中,增密线设置可用于创建线要素的要素模板。 创建增密线段会在工具窗格中指定为采样距离的均匀间隔处插入额外的折点。 圆弧和曲线不会被增密。

注:

在此版本的 ArcGIS AllSource 中,此设置在 3D 场景中不可用。

创建 2D 增密线段

创建 2D 增密线段的一个常见用途是在变换要素时插入用于捕捉从-到链接的折点。

  1. 如果当前地图不包含线要素图层,请添加该线要素图层。

    1. 在视图选项卡中,单击目录窗格 ,然后展开数据库 。

    2. 展开默认数据库或包含数据的数据库。

      要创建线要素类,请右键单击数据库,然后依次单击新建和要素类。

    3. 将要素类拖动到地图上。

      将为新图层自动生成具有默认设置的要素模板。

  2. 在编辑选项卡中,设置捕捉首选项,然后显示创建要素窗格。

    1. 在捕捉组中,启用您的捕捉首选项。

      提示:

      在草绘要素时,可以按住空格键暂时关闭捕捉。

    2. 在要素组中,单击创建 。

  3. 在创建要素窗格中,选择一个要素模板并设置属性值。

    1. 单击一个线要素模板。

    2. 单击活动模板按钮 。

    3. 单击属性 并输入要应用于新要素的值。

  4. 配置模板以创建增密线。

    1. 单击线 。

    2. 选中增密线复选框。

      注:

      此设置会禁用构造工具栏上的弧段工具。 在创建线要素时,您可以随时关闭此设置以启用这些工具并创建未增密的线段。

    3. 在采样距离文本框中,输入每个折点之间的距离。

  5. 单击地图,移动指针,然后再次单击地图。

    请注意在您在地图上单击的两个点之间自动生成的额外折点。

  6. 在编辑工具栏中,单击完成 或按下 F2 键。

    构造工具栏

创建 3D 增密线段

创建 3D 增密线段的一个常见用途是将它们覆盖在高程表面上。 您可以设置一个恒定的 z 值,或者在地图中草绘线时,将高程模式设置为从活动高程表面获取 z 值。

有关向地图添加高程表面的步骤,请参阅高程表面。

  1. 如果当前地图不包含启用了 Z 值的 3D 线要素图层,请添加该图层。

    1. 在视图选项卡中,单击目录窗格 ,然后展开数据库 。

    2. 展开默认数据库或包含数据的数据库。

      要创建线要素类,请右键单击数据库,然后依次单击新建和要素类。

    3. 将要素类拖动到地图上。

      将为新图层自动生成具有默认设置的要素模板。

  2. 在编辑选项卡中,设置捕捉首选项,然后显示创建要素窗格。

    1. 在捕捉组中,启用您的捕捉首选项。

      提示:

      在草绘要素时,可以按住空格键暂时关闭捕捉。

    2. 在要素组中,单击创建 。

  3. 在创建要素窗格中,选择一个要素模板并设置属性值。

    1. 单击一个线要素模板。

    2. 单击活动模板按钮 。

    3. 单击属性 并输入要应用于新要素的值。

  4. 配置模板以创建增密线。

    1. 单击线 。

    2. 选中增密线复选框。

      注:

      此设置会禁用构造工具栏上的弧段工具。 在创建线要素时,您可以随时关闭此设置以启用这些工具并创建未增密的线段。

    3. 在采样距离文本框中,输入每个折点之间的距离。

  5. 在编辑选项卡上,在高程组中,单击模式下拉箭头 ,并启用以下 z 值模式之一:

    • 常量模式 常量 - 在文本框中输入 Z 值,并将其应用于所有折点,直到您更改该值为止。

    • 表面模式 表面 - 当您单击地图并将线覆盖在表面上时,Z 值将从活动高程表面获取。

  6. 单击地图,移动指针,然后再次单击地图。

    请注意在您在地图上单击的两个点之间自动生成的额外折点。

  7. 在编辑工具栏中,单击完成 或按下 F2 键。

    构造工具栏