Skip to main content

通过追踪其他要素来创建线段

在创建要素窗格中,追踪工具 可在启用捕捉功能的图层上,沿着其他要素的几何图形创建连续的线段。 当您创建线段时,该工具适用于线和面要素模板,也适用于构造工具栏。

创建启用 z 值的折线和面要素时,将基于当前 z 坐标高程设置为折点分配 z 值。 有关指定 z 值的步骤,请参阅为 3D 要素指定高程。

追踪

  1. 在目录窗格中,执行以下操作之一以将图层添加至您的地图:

    • 展开数据库 ,展开包含数据的数据库并将要素类拖拽至地图。

    • 右键单击默认数据库,然后创建一个新的折线或面要素类。

    拖动或创建要素类会将图层添加到当前地图,并创建一个具有默认设置的要素模板。

  2. 对于您不想追踪的要素,按图层关闭捕捉功能。 这可以显著提高绘制性能。

    1. 在视图选项卡的窗口组中,单击内容 。

    2. 单击按捕捉列出 。

    3. 取消选中图层名称旁边的复选框以禁用捕捉,或者右键单击并选择设置此图层为唯一可捕捉图层 。

  3. 在编辑选项卡的捕捉组中,启用您的捕捉首选项。

    提示:

    在草绘要素时,您可以按住空格键暂时关闭捕捉功能。

  4. 在编辑选项卡的要素组中,单击创建 。

    创建要素窗格随即显示。

  5. 在窗格中,单击一个折线要素模板。

    构造工具条显示在地图的底部。

    构造工具栏

  6. 在工具选项板旁边,单击活动模板按钮 。

    将在窗格中显示模板的工具选项板和要素属性表。

  7. 在属性表中,键入要应用到新要素的值。

    • 对于组模板,单击模板图标以显示其属性表。
  8. 单击追踪 。

  9. 单击要追踪的要素并创建第一个折点。

    创建第一个折点后,当您拖动指针时,会沿该要素出现一条虚线。

    提示:

    按 T 键可显示您正在追踪的要素的折点。

  10. 将指针沿要追踪的一个或多个要素拖动。

    • 在创建面时若要临时关闭捕捉功能,请按空格键。
  11. 要完成追踪,请单击地图。

  12. 要完成要素,请单击鼠标右键,然后单击完成 ,或按 F2 键。

键盘快捷键

键盘快捷键

操作

注释

O

查看选项。

打开选项对话框。

Tab

设置负偏移。

转换偏移的一侧并追踪边的另一侧。

Ctrl + 拖动

追踪所选要素。

仅追踪所选要素。 如果追踪所选要素已打开,则可以追踪所选要素及未选要素。

用于追踪线段构造工具的键盘快捷键

偏移追踪

使用偏移追踪选项可在指定的偏移距离处创建线段。 例如,您可以单击水管设施要素模板,设置 7 米的偏移距离,然后沿宗地边界追踪,以创建与宗地边界保持恒定偏移距离平行的水管设施。

  1. 单击追踪 。

  2. 右键单击地图,然后单击追踪选项。

    随即显示追踪选项对话框。

  3. 选中偏移追踪复选框。

    追踪选项

  4. 单击单位下拉箭头,设置格式,然后在文本框中输入偏移距离。

  5. 单击确定。

    保存您的设置并关闭对话框。

  6. 追踪现有的要素。

    提示:

    按 Tab 键将偏移切换至要素的另一侧。

  7. 要完成要素,请单击鼠标右键,然后单击完成 ,或按 F2 键。

角

使用角选项控制拐角的形状。

  1. 单击追踪 。

  2. 右键单击地图,然后单击追踪选项。

    随即显示追踪选项对话框。

  3. 单击以下设置之一:

    • 斜接角

    • 斜面角

    • 圆角

  4. 单击确定。

    保存您的设置并关闭对话框。

  5. 追踪要素。

  6. 要完成要素,请单击鼠标右键,然后单击完成 ,或按 F2 键。

移除自相交环

使用移除自相交环选项,以防止在偏移追踪设置为较大的偏移距离时出现自相交环。

  1. 单击追踪 。

  2. 右键单击地图,然后单击追踪选项。

    随即显示追踪选项对话框。

  3. 选中移除自相交环复选框。

  4. 单击确定。

    保存您的设置并关闭对话框。

  5. 追踪新要素。

  6. 要完成要素,请单击鼠标右键,然后单击完成 ,或按 F2 键。

限制追踪长度

使用限制追踪长度选项,将追踪线段的长度限制为您指定的距离。

  1. 单击追踪 。

  2. 右键单击地图,然后单击追踪选项。

    随即显示追踪选项对话框。

  3. 选中限制追踪长度复选框。

  4. 输入距离并设置单位格式。

  5. 单击确定。

    保存您的设置并关闭对话框。

  6. 追踪要素。

  7. 要完成要素,请单击鼠标右键,然后单击完成 ,或按 F2 键。

仅追踪所选要素

使用仅追踪所选要素选项,将追踪范围限制在您在地图中选定的要素。

  1. 在编辑选项卡上的选择组中,单击选择工具并选择要追踪的要素。

  2. 单击追踪 。

  3. 右键单击地图,然后单击追踪选项。

    随即显示追踪选项对话框。

  4. 选中仅追踪所选要素复选框。

  5. 单击确定。

    保存您的设置并关闭对话框。

  6. 追踪所选要素。

  7. 要完成要素,请单击鼠标右键,然后单击完成 ,或按 F2 键。