在 ArcGIS AllSource 中编辑
编辑地理数据是在地图上创建、修改或删除图层上要素和相关数据的过程。 在保存编辑内容后,每个图层都连接至用于定义和存储要素的数据源;通常为地理数据库要素类、shapefile 或要素服务。
要素可以是 2D 或 3D 要素,用来表示自然界或人工环境中的真实物理对象或数据点。 开发人员可以使用 ArcGIS Pro SDK 扩展 ArcGIS AllSource 编辑体验。 有关详细信息,请访问 ArcGIS Pro SDK 网站。
本主题汇总了您可以使用 ArcGIS AllSource 开箱即用编辑工具执行的操作。 有关功能区数据选项卡、编辑选项卡、编辑窗格、快捷菜单和工具栏中的工具的概述,请参阅编辑快速浏览。
有关使用特定工具的步骤,请浏览用于编辑的内容列表,或使用关键字或短语搜索帮助。
编辑工作流
编辑工具支持从常规制图应用到情报共同体的各种工作流,包括国防、企业安全和犯罪分析。 您可以编辑来自地理数据库的数据、要素服务、GeoPackage、SQLite 数据库中的数据、shapefile 以及来自移动设备上的 Collector 应用程序的数据。
您可以执行的编辑类型包括以下工作流:
创建或修改 2D 和 3D 要素。
编辑要素属性和相关记录,并添加或移除文件附件
从头开始创建 3D 要素或导入 3D 模型。
拉伸 2D 要素并将其符号化为 3D 要素。
修整、替换或编辑要素几何,同时保留现有属性。
有关其他可编辑数据类型的详细信息,请参阅支持的数据类型和项目。
编辑模式
ArcGIS AllSource 使用编辑模式来控制编辑界面。 在编辑模式中,可以创建和编辑表、要素图层和属性。 编辑模式基于上下文,利用 Mapview 工具栏和构造工具栏展示选定图层的可用工具。 在地图选项卡上单击编辑,即可激活编辑模式并显示编辑选项卡。

编辑模式与编辑会话不同。 ArcGIS AllSource 会在您修改现有数据或创建数据时自动启动编辑会话。 您可以编辑任何被授予查看和编辑权限的数据源。 保存或放弃编辑内容会自动停止编辑会话。 任何后续编辑操作都会恢复编辑会话,直到您再次保存或放弃编辑内容。 关闭编辑模式后,仍预期能够编辑数据。
即使关闭了编辑选项卡,也仍可添加、删除、修改和更新要素和属性。 通过图层关闭编辑功能,可以指明哪些图层可被编辑。 这些设置适用于活动地图或场景,不要更改在数据源中授予的权限。 有关详细信息,请参阅指定可编辑的图层。
地图和场景
您可以在地图和/或场景中查看和编辑 2D 和 3D 数据。 工作时,您可以在地图和场景之间进行切换,并将二者链接起来,以便在活动视图中平移和缩放时,可以在同一范围中心以相同的范围比例同步显示二者。
您可以将场景配置为局部或全局视图,具体取决于工作所需的显示或分析类型。 当您需要最小化距离、方向、比例或面积测量的畸变程度时,使用具有投影坐标系的局部场景将是最佳选择。
有关详细信息,请参阅配置场景以进行 3D 编辑。
目录窗格
工程包含数据、布局、工具箱以及完成工程所需的其他资源的连接。 您可以创建具有特定数据的工程并在线共享,或将其保存为特定编辑方案的模板并在组织内共享。
您可以在目录窗格
中查看和管理工程资源。 可以添加和移除本地和在线数据的连接,并创建要素类、地图、场景和其他工程项目。 该窗格包含用于访问门户内容和创建收藏夹列表的选项卡。
有关详细信息,请参阅使用目录窗格。
2D 和 3D 要素
要素模板可以创建 2D 或 3D 要素,具体取决于它们引用的图层。 创建 2D 或 3D 要素的步骤基本相同,唯一的不同之处就是为 3D 要素指定 z 值 三维要素将使用其几何来存储 z 值。
虽然二维要素无法储存 z 值,但是它们可以从表中的属性字段或 3D 场景高程表面获取 z 值。 在某些情况下,使用属性字段将高程值添加到现有 2D 要素或拉伸 2D 要素可能更为简单。
有关详细信息,请参阅 2D 和 3D 要素简介。
版本化数据
当您对已注册为版本化的数据进行编辑时,您所修改的是其他用户也可编辑的相同数据的孤立版本。 将在系统表中跟踪您的编辑内容,并在您保存更改时进行协调和发布。
可选设置用于定义在您保存编辑内容时冲突的定义和协调方式。 您可以显示冲突管理器窗格并交互检查冲突或隐藏冲突,然后自动协调冲突。
有关详细信息,请参阅设置版本化选项。