使用地理位置数据
创建工程并进入主屏幕后,即可开始处理影像。 如果您在进行处理之前,需要更新有关图像的信息,请使用 飞行数据 选项卡。
可以查看或编辑 地理位置 组中的以下信息:
更改图像 GPS 数据的源。
调整图像的高度。
导出 GPS 数据。
目前,支持来自无人机元数据的偏航角、仰俯角和滚动角,或来自外部地理位置文件的 Omega、Phi、Kappa。 此数据存在时,可选中工程处理选项中的 使用图像方向 复选框,方法是转至 主页 选项卡,然后单击 选项 > 调整图像 > 使用图像方向 。 这可让处理引擎跳过方向步骤并使用提供的图像方向数据来计算图像方向,从而提高处理速度。 此方向数据将写入工程中的不同文件: \Project\Data\images.json 。
设置 GPS 源
GPS 源在工程创建过程中设置,但可以从 飞行数据 选项卡中对其进行更新。 Drone2Map 用于为工程中的所选图像设置 GPS 源。 要更新基本图像 GPS 源信息,请完成以下步骤:
选择一个或多个图像。
单击 飞行数据 选项卡上的 GPS 源
。在 设置 GPS 源 窗口中,使用 GPS 信息 部分中的下拉菜单来指定要修改的信息。
可以将 GPS 高度参考 更改为高于或低于海平面。 GPS 纬度参考 和 GPS 经度参考 也可使用所需主方向进行修改。
单击 确定 以更新 GPS 信息。
单击 重置为 EXIF 按钮可将图像的 GPS 信息重置回创建工程时的原始导入状态。
导入 GPS 信息
如果您之前已导出 GPS 信息或希望完全更改现有图像信息,请使用 导入 选项卡为工程图像导入新的 GPS 信息。 要为图像导入新的 GPS 信息,请完成以下步骤:
单击 飞行数据 选项卡上的 GPS 源
。在 设置 GPS 源 窗口中,单击 导入 选项卡。
单击 浏览 按钮以打开 浏览至 GPS 文件 窗口。
选择包含 TXT、CSV 或 MRK 格式的 GPS 信息的文本文件。
单击 确定 。
靠近该窗口顶部的 地理定位图像 值将从 0 进行更改。 GPS 字段信息 部分将使用所导入文件中的相应字段进行自动填充。
单击 确定 以更新 GPS 信息。
调整图像高度
Drone2Map 将从图像 EXIF 数据或外部文件中读取图像高度信息。 可以在图像表中查看高度信息。 如果您对图像高度值的准确性不确定,则可能需要使用在任务计划期间设置的飞行高度来更新您的高度。 为此,Drone2Map 将查询用户定义的高程源以建立每个图像中心的地面高程,并添加您输入的飞行高度值以建立新的高度值。 要调整图像高度,请完成以下步骤:
在 飞行数据 选项卡上,单击 选择
。通过选择图像中心点来指示您想要调整的图像。
在 飞行数据 选项卡,然后单击 图像高度
。从 调整使用 下拉列表中选择高程源类型。 如果您有本地 DEM 数据集或 常量高程 ,请选择 地面高程表面 、 高程服务 、 数字高程模型 。
如果无人机在地面元数据上方采集高度,则 使用元数据 复选框将处于选中状态,并且将使用无人机中的数据。
如果 使用元数据 复选框不可用,请输入飞行高度作为地面上方的高度以及单位。
如果已在多个轨道或者不同高度处的通道上采集飞行并且该飞行没有相对高度元数据,则在 飞行高度 参数中输入值时,请使用该飞行的第一张图像的飞行高度。
如果选择 地面高程表面 ,请输入飞行高度和单位。
如果选择 高程表面 ,请输入飞行高度和单位。 请保留默认服务,或者取消选中该复选框并输入您自己的高程服务。
如果选择 数字高程模型 ,请输入飞行高度和单位。 请浏览至本地高程文件(
.tif、.jpg、.jpeg、.jpe、.jfif或.png)并将其打开。如果选择 常亮高程 模型,请输入飞行高度和单位。 然后输入起飞高程和单位。
单击 确定 。
随即显示一条消息,指示高度将设置为源自高程源中的高程与输入高度的和。 单击 确定 继续。
导出 GPS
要以 TXT、CSV 或 MRK 格式导出所有图像信息,请完成以下步骤:
选择图像。
单击 导出 GPS 。
在本地文件系统中选择用于保存该文件的位置。
单击 保存 。
注:
如果在图像 EXIF 数据中存储的 GPS 数据出现问题,则可以使用 导出 工具将图像信息保存到文件,编辑该数据,然后使用 GPS 源 工具将图像信息添加回 Drone2Map。