Lernprogramm: Suchen von Features
In diesem Lernprogramm erfahren Sie, wie Features im Bereich Suchen mithilfe der für die Suche konfigurierten Layer gesucht werden.
Abrufen der Daten
Die Daten für dieses Lernprogramm können online heruntergeladen werden.
Wechseln Sie zur Daten-Download-Seite.
Klicken Sie auf die Schaltfläche Herunterladen, um die Datei lokal zu speichern.
Entzippen Sie die heruntergeladene Datei.
Suchen eines Features mithilfe eines Layers, der aus einer lokalen Feature-Class erstellt wurde
In dieser Übung verwenden Sie die geokodierte Feature-Class, die erstellt wurde, als Sie die Adressentabelle im Lernprogramm: Adressentabelle geokodieren geokodiert haben, und konfigurieren sie für die Suche. Wenn Sie dieses Lernprogramm nicht abgeschlossen haben, sollten Sie dies nachholen, bevor Sie den Vorgang fortsetzen.
ArcGIS Pro starten
Melden Sie sich ggf. bei ArcGIS Online an.
Ein neues Projekt erstellen. Klicken Sie auf der Startseite auf die Vorlage Katalog.
Klicken Sie auf der Registerkarte Einfügen auf Neue Karte
.Es wird eine Grundkarte angezeigt.
Klicken Sie auf der Registerkarte Karte in der Gruppe Layer auf das Dropdown-Menü Daten hinzufügen und anschließend auf Durchsuchen
.Klicken Sie auf die Geodatabase
Evansville.gdbim Ordner GeocodingSample, und doppelklicken Sie auf die Feature-ClassEvansvillePlaces, um sie der Karte hinzuzufügen.Die Feature-Class wird in einen Layer umgewandelt und als Punkte auf der Karte angezeigt. Sie können auch sehen, dass der Layer im Bereich Inhalt aufgelistet ist.
Klicken Sie auf der Registerkarte Karte in der Gruppe Abfrage auf die Schaltfläche Suchen, um den Bereich Suchen zu öffnen.
Daraufhin wird der Bereich Suchen geöffnet.
Klicken Sie im Bereich Suchen auf der Registerkarte Suchen auf die Schaltfläche Optionen
und dann auf Provider-Einstellungen, um die aktive Ansicht des Bereichs zu ändern.Die Ansicht "Provider-Einstellungen" des Bereichs Suchen wird nun angezeigt, und Sie können eine Liste der verfügbaren Provider sehen.
Hinweis:
Diese Liste enthält alle Locators, die automatisch über Ihre Portalverbindung hinzugefügt wurden, sowie alle Locators, die Sie Ihrem Projekt lokal oder über eine Serververbindung hinzugefügt haben. In der Ansicht "Provider-Einstellungen" können Sie Änderungen an diesen Locators vornehmen:
Ziehen Sie die Locators in eine beliebige Reihenfolge.
Aktivieren oder deaktivieren Sie Locators.
Ändern Sie die Eigenschaften des Locators.
Entfernen Sie Locators aus dem Projekt.
Da sich dieses Lernprogramm mit der Suche von Features in Layern befasst, können Sie die Locators ignorieren.
Fügen Sie den Layer aus der Karte dem Bereich Suchen hinzu, indem Sie auf die Schaltfläche Für Suche konfigurieren
klicken.
Wichtig
Layer, die der Karte hinzugefügt wurden, werden nicht automatisch im Bereich Suchen angezeigt. Sie müssen sie zunächst für die Suche konfigurieren.
Das Dialogfeld Layer oder Tabelle auswählen wird angezeigt, in dem alle Layer bzw. Tabellen aufgeführt werden, die aktuell im Bereich Inhalt verfügbar sind.
Wählen Sie den Layer aus der Liste, die im Dialogfeld Layer oder Tabelle auswählen angezeigt wird, und klicken Sie auf OK.
Im Bereich Suchen wird nun die Ansicht Für Suche konfigurieren für den ausgewählten Layer angezeigt.

Um das Feld
NAMEfür die Suche zu konfigurieren, verwenden Sie das mit dem FeldNAMEverknüpfte Dropdown-Menü, und wählen Sie Enthält aus, sodass Sie eine ungefähre Suche durchführen können.Tipp:
Alternativ können Sie Gleich auswählen, wodurch das Feld
NAMEfür eine genaue Suche konfiguriert wird. Diese Option kann jedoch die zurückgegebenen Ergebnisse einschränken, da die Groß-/Kleinschreibung bei der Eingabe berücksichtigt werden muss und die Eingabe genau mit dem gesuchten Feldwert übereinstimmen muss. Es empfiehlt sich, Gleich beim Suchen nach einem Feldwert zu verwenden, der immer genau ist, z. B. eine lange ID-Nummer mit Zahlen und Buchstaben.Wenn der ausgewählte Layer bzw. die ausgewählte Tabelle Felder enthält, die indiziert wurden, um die Such-Performance zu verbessern, werden diese Felder automatisch für die Suche konfiguriert, und der Suchmodus wird auf Gleich festgelegt.
Um Ihre Suchkonfiguration zu speichern, klicken Sie in der oberen linken Ecke des Bereichs auf den Pfeil Speichern und zu Provider-Einstellungen zurückkehren
.Im Bereich Suchen wird nun die Ansicht "Provider-Einstellungen" wieder eingeblendet und der neu konfigurierte Layer in der Liste der Provider angezeigt. Sie können die Reihenfolge der Such-Provider in der Liste ändern, wodurch die Reihenfolge der durchgeführten Suchvorgänge und die Reihenfolge, in der Ergebnisse im Bereich Suchen zurückgegeben und angezeigt werden, bestimmt wird.

Deaktivieren Sie alle Such-Provider, die in der Ansicht "Provider-Einstellungen" des Bereichs Suchen aufgelistet sind, mit Ausnahme des gerade hinzugefügten Layers
EvansvillePlaces.Es ist nicht erforderlich, andere Provider für Geokodierung zu deaktivieren, damit die Suche funktioniert. Zum Zweck dieses Lernprogramms ist es jedoch hilfreich, nur die Ergebnisse anzuzeigen, die von Interesse sind. Außerdem wird die Performance optimiert, wenn weniger Provider für Geokodierung durchsucht werden.
Hinweis:
Aktivieren Sie nach Abschluss des Lernprogramms die regelmäßig von Ihnen verwendeten Provider in der Ansicht "Provider-Einstellungen" des Bereichs Suchen erneut.
Klicken Sie in der oberen linken Ecke des Bereichs auf die Schaltfläche Zurück zum Bereich "Suchen"
, um zur Registerkarte Suchen zurückzukehren. Geben Sie in das Suchfeld museum ein, und drücken Sie die Eingabetaste.Vier Ergebnisse werden unter dem Namen des gerade konfigurierten Layers im Listenformat angezeigt sowie als Punkte auf der Karte. Sie werden als Treffer aufgeführt, da der Wert im Feld
NAMEdas Wort museum enthält.Doppelklicken Sie in der Liste auf ein Ergebnis.
Die Kartenansicht wird auf die Position des Elements vergrößert.
Tipp:
Sie können auch mit der rechten Maustaste auf den Kandidaten in der Liste klicken und rechts neben dem ausgewählten Element die Option Zoomen auf
oder Schwenken auf
auswählen, um zu der Position des Ergebnisses auf der Karte zu zoomen oder zu schwenken.Klicken Sie im Menü
auf Auf alle zoomen
, um auf alle zugeordneten Ergebnisse in der Karte zu zoomen.Klicken Sie im Menü
auf Detaillierte Ansicht
, um die Details jedes Abgleichergebnisses anzuzeigen.Klicken Sie mit der rechten Maustaste auf einen Kandidaten aus der Liste und dann auf Details anzeigen, um ausführliche Informationen zum Feature-Ergebnis anzuzeigen.
Der Bereich Pop-up wird angezeigt. Sie können mehrere Aktionen ausführen, z. B. das Feature auswählen.
Suchen eines Features mithilfe eines Layers, der aus einem Online-Feature-Service erstellt wurde
ArcGIS Pro starten
Melden Sie sich ggf. bei ArcGIS Online an.
Erstellen Sie ein neues leeres Projekt. Klicken Sie auf der Startseite auf Ohne Vorlage beginnen.
Klicken Sie auf der Registerkarte Einfügen auf Neue Karte
.Es wird eine Grundkarte angezeigt.
Klicken Sie auf der Registerkarte Karte in der Gruppe Layer auf die Schaltfläche Daten hinzufügen
.Klicken Sie im Dialogfeld Daten hinzufügen auf ArcGIS Online
, geben Sie in das Suchfeld restaurants ein, und drücken Sie die Eingabetaste.Doppelklicken Sie auf Naperville_Restaurants und dann auf Restaurants, um die Daten der Karte hinzuzufügen.
Der Feature-Service wird in einen Layer umgewandelt und als Punkte auf der Karte angezeigt. Der Layer wird auch im Bereich Inhalt aufgeführt.
Klicken Sie auf der Registerkarte Karte in der Gruppe Abfrage auf den Dropdown-Pfeil Suchen und dann auf Layer-Suche.
Daraufhin wird der Bereich Suchen geöffnet.
Klicken Sie im Bereich Suchen auf der Registerkarte Suchen auf die Schaltfläche Optionen
und dann auf Provider-Einstellungen, um die aktive Ansicht des Bereichs zu ändern.Die Ansicht "Provider-Einstellungen" des Bereichs Suchen wird nun angezeigt, und Sie können eine Liste der verfügbaren Provider sehen. Diese Liste enthält alle Locators, die automatisch über Ihre Portalverbindung hinzugefügt wurden, sowie alle Locators, die Sie Ihrem Projekt über eine Serververbindung hinzugefügt haben. Sie können die Locators in eine beliebige Reihenfolge ziehen, Locator-Eigenschaften ändern, Locators aus Ihrem Projekt entfernen und Locators in der Ansicht "Provider-Einstellungen" aktivieren oder deaktivieren. Da sich dieses Lernprogramm mit der Suche von Features in Layern befasst, können Sie die Locators ignorieren.

Hinweis:
Layer, die der Karte hinzugefügt wurden, werden nicht automatisch im Bereich Suchen angezeigt. Sie müssen sie zunächst für die Suche konfigurieren.
Fügen Sie den Layer aus der Karte dem Bereich Suchen hinzu, indem Sie auf die Schaltfläche Layer für Suche konfigurieren
klicken.
Das Dialogfeld Layer oder Tabelle auswählen wird angezeigt, in dem alle Layer und Tabellen aufgeführt werden, die aktuell im Bereich Inhalt verfügbar sind.
Wählen Sie den Layer Restaurants aus, und klicken Sie auf OK.
Der Bereich Suchen zeigt nun die Ansicht Für Suche konfigurieren für den ausgewählten Layer an.

Um das Feld
Cuisinefür die Suche zu konfigurieren, klicken Sie auf das mit dem FeldCuisineverknüpfte Dropdown-Menü, und wählen Sie Enthält aus, sodass Sie eine ungefähre Suche durchführen können.Tipp:
Alternativ können Sie Gleich auswählen, wodurch das Feld
NAMEfür eine genaue Suche konfiguriert wird. Diese Option kann jedoch die zurückgegebenen Ergebnisse einschränken, da die Groß-/Kleinschreibung bei der Eingabe berücksichtigt werden muss und die Eingabe genau mit dem gesuchten Feldwert übereinstimmen muss. Es empfiehlt sich, Gleich beim Suchen nach einem Feldwert zu verwenden, der immer genau ist, z. B. eine lange ID-Nummer mit Zahlen und Buchstaben.Wenn der zu konfigurierende Layer Felder enthält, die indiziert wurden, um die Such-Performance zu verbessern, werden diese Felder automatisch für die Suche konfiguriert, und der Suchmodus wird auf Gleich festgelegt.
Um Ihre Suchkonfiguration zu speichern, klicken Sie in der oberen linken Ecke des Bereichs auf den Pfeil Speichern und zu Provider-Einstellungen zurückkehren
.Sie erhalten keine Meldung mit der Aufforderung, die Felder zu indizieren, die Sie für die Suche nach Online-Feature-Services konfiguriert haben.
Im Bereich Suchen wird nun die Ansicht "Provider-Einstellungen" wieder eingeblendet und der neu konfigurierte Layer in der Liste der Provider angezeigt. Sie können die Reihenfolge der Provider für Geokodierung in der Liste ändern, wodurch sich die Reihenfolge der durchgeführten Suchvorgänge und die Reihenfolge, in der Ergebnisse im Bereich Suchen zurückgegeben und angezeigt werden, ändert.

Deaktivieren Sie alle Such-Provider, die in der Ansicht "Provider-Einstellungen" des Bereichs Suchen aufgelistet sind, mit Ausnahme des gerade hinzugefügten Layers.
Es ist nicht erforderlich, andere Provider für Geokodierung zu deaktivieren, damit die Suche funktioniert. Zum Zweck dieses Lernprogramms ist es jedoch hilfreich, nur die Ergebnisse anzuzeigen, die von Interesse sind. Außerdem wird die Performance optimiert, wenn weniger Provider für Geokodierung durchsucht werden.
Hinweis:
Aktivieren Sie nach Abschluss des Lernprogramms die regelmäßig von Ihnen verwendeten Provider in der Ansicht "Provider-Einstellungen" des Bereichs Suchen erneut.
Klicken Sie in der oberen linken Ecke des Bereichs auf die Schaltfläche Zurück zum Bereich "Suchen"
, um zur Registerkarte Suchen zurückzukehren. Geben Sie in das Suchfeld frog legs ein, und drücken Sie die Eingabetaste.Ein Ergebnis wird unter dem Namen des gerade konfigurierten Layers im Listenformat angezeigt sowie als Punkt auf der Karte. Es wird als Treffer angegeben, da der Wert im Feld Cuisine das Wort frog legs enthält.
Doppelklicken Sie in der Liste auf das Ergebnis.
Die Kartenansicht wird auf die Position des Elements vergrößert.
Tipp:
Sie können auch mit der rechten Maustaste auf den Kandidaten in der Liste klicken und rechts neben dem ausgewählten Element die Option Zoomen auf
oder Schwenken auf
auswählen, um zu der Position des Ergebnisses auf der Karte zu zoomen oder zu schwenken.Klicken Sie im Menü
auf Auf alle zoomen
, um auf alle zugeordneten Ergebnisse in der Karte zu zoomen.Klicken Sie im Menü
auf Detaillierte Ansicht
, um die Details jedes Abgleichergebnisses anzuzeigen.Klicken Sie mit der rechten Maustaste auf einen Kandidaten aus der Liste und dann auf Details anzeigen, um ausführliche Informationen zum Feature-Ergebnis anzuzeigen.
Der Bereich Pop-up wird angezeigt. Sie können mehrere Aktionen ausführen, z. B. das Feature auswählen.