Skip to main content

他のフィーチャをトレースしてセグメントを作成する

フィーチャの作成 ウィンドウの トレース ツールは、スナップをオンにしたレイヤー上で、他のフィーチャのジオメトリーに追従する連続セグメントを作成します。 このツールは、ライン フィーチャ テンプレートとポリゴン フィーチャ テンプレート、およびライン セグメントを作成する際の作図ツールバーで利用できます。

Z 軸対応のポリライン フィーチャまたはポリゴン フィーチャを作成すると、現在の Z 座標標高の設定に基づいて頂点に Z 値が割り当てられます。 Z 値を指定する手順については、3D フィーチャの標高の指定をご参照ください。

トレース

  1. カタログ ウィンドウで次のいずれかを実行して、レイヤーをマップに追加します:

    • データベース を展開し、データが格納されているデータベースを展開して、フィーチャクラスをマップにドラッグします。

    • デフォルトのデータベースを右クリックして、ポリラインまたはポリゴン フィーチャクラスを作成します。

    フィーチャクラスを作成するか、ドラッグすると、現在のマップにレイヤーが追加され、デフォルト設定のフィーチャ テンプレートが作成されます。

  2. トレースしないフィーチャのレイヤー別でスナップをオフにします。 これにより、描画パフォーマンスが大幅に向上する可能性があります。

    1. 表示 タブの ウィンドウ グループで、コンテンツ をクリックします。

    2. スナップ別にリスト をクリックします。

    3. レイヤー名の横にあるチェックボックスをオフにしてスナップを無効にするか、右クリックして このレイヤーのみスナップ可能にする をクリックします。

  3. 編集 タブの スナップ グループで、スナップ設定を有効にします。

    ヒント:

    フィーチャをスケッチする際に、スペース キー を押したままにすることでスナップを一時的にオフにできます。

  4. 編集 タブの フィーチャ グループで、作成 をクリックします。

    フィーチャ作成 ウィンドウが表示されます。

  5. ウィンドウで、ポリライン フィーチャ テンプレートをクリックします。

    マップの下部に作図ツールバーが表示されます。

    作図ツールバー

  6. ツール パレットの横にある アクティブなテンプレート ボタンをクリックします。

    ツール パレットとテンプレートのフィーチャ属性テーブルがウィンドウに表示されます。

  7. 属性テーブルで、新しいフィーチャに適用する値を入力します。

    • グループ テンプレートの場合は、テンプレート アイコンをクリックして属性テーブルを表示します。
  8. トレース をクリックします。

  9. トレースするフィーチャをクリックして、最初の頂点を作成します。

    最初の頂点が作成され、ポインターをドラッグするにつれてフィーチャ上に破線が表示されます。

    ヒント:

    トレースするフィーチャの頂点を表示するには、T キーを押します。

  10. トレースするフィーチャ上でポインターをドラッグします。

    • ポリゴンの作成中にスナップを一時的にオフにするには、スペース キー を押します。
  11. トレースを完了するには、マップをクリックします。

  12. フィーチャを完成させるには、右クリックして 完了 をクリックするか、F2 キーを押します。

キーボード ショートカット

キーボード ショートカット

アクション

コメント

O

オプションを表示します。

オプション ダイアログ ボックスを開きます。

タブ

負のオフセットを設定します。

オフセットの右側と左側を切り替えて、エッジの反対側をトレースします。

Ctrl + ドラッグ

選択したフィーチャをトレースします。

選択したフィーチャのみトレースします。 選択フィーチャのトレース がオンになっている場合は、選択したフィーチャと選択していないフィーチャをトレースできます。

トレース セグメント作図ツール用のキーボード ショートカット

オフセットを使用したトレース

オフセットを使用してトレース オプションを使用して、指定されたオフセットでセグメントを作成します。 たとえば、給水本管フィーチャ テンプレートをクリックし、7 メートルのオフセットを設定して区画境界に沿ってトレースすることで、区画境界に対して一定のオフセットで平行に延びる給水本管を作成できます。

  1. トレース をクリックします。

  2. 地図を右クリックして、トレース オプション をクリックします。

    トレース オプション ダイアログ ボックスが表示されます。

  3. オフセットを使用してトレース チェックボックスをオンにします。

    トレース オプション

  4. 単位 のドロップダウン矢印をクリックし、形式を設定し、テキストボックスにオフセット距離を入力します。

  5. OK をクリックします。

    設定内容が保存され、ダイアログ ボックスが閉じます。

  6. 既存のフィーチャをトレースします。

    ヒント:

    Tab キーを押すと、オフセットがフィーチャの反対側に切り替わります。

  7. フィーチャを完成させるには、右クリックして 完了 をクリックするか、F2 キーを押します。

角

角 オプションを使用して、角の形状を制御します。

  1. トレース をクリックします。

  2. 地図を右クリックして、トレース オプション をクリックします。

    トレース オプション ダイアログ ボックスが表示されます。

  3. 次のいずれかの設定をクリックします:

    • 鋭角

    • 斜角

    • 角丸

  4. OK をクリックします。

    設定内容が保存され、ダイアログ ボックスが閉じます。

  5. フィーチャをトレースします。

  6. フィーチャを完成させるには、右クリックして 完了 をクリックするか、F2 キーを押します。

自己交差ループの除去

自己交差ループの除去 オプションを使用して、オフセットを使用したトレース に大きなオフセット距離が設定されている場合に自己交差ループが発生しないようにします。

  1. トレース をクリックします。

  2. 地図を右クリックして、トレース オプション をクリックします。

    トレース オプション ダイアログ ボックスが表示されます。

  3. 自己交差ループの除去 チェックボックスをオンにします。

  4. OK をクリックします。

    設定内容が保存され、ダイアログ ボックスが閉じます。

  5. 新しいフィーチャをトレースします。

  6. フィーチャを完成させるには、右クリックして 完了 をクリックするか、F2 キーを押します。

トレース長の制限

トレース長の制限 オプションを使用して、トレースされるセグメントの長さを指定した距離に制限します。

  1. トレース をクリックします。

  2. 地図を右クリックして、トレース オプション をクリックします。

    トレース オプション ダイアログ ボックスが表示されます。

  3. トレース長の制限 チェックボックスをオンにします。

  4. 距離を入力して 単位 の形式を設定します。

  5. OK をクリックします。

    設定内容が保存され、ダイアログ ボックスが閉じます。

  6. フィーチャをトレースします。

  7. フィーチャを完成させるには、右クリックして 完了 をクリックするか、F2 キーを押します。

選択フィーチャのみトレース

選択フィーチャのみトレース オプションを使用して、マップで選択したフィーチャのみにトレースを制限します。

  1. 編集 タブの 選択 グループで選択ツールをクリックして、トレースするフィーチャを選択します。

  2. トレース をクリックします。

  3. 地図を右クリックして、トレース オプション をクリックします。

    トレース オプション ダイアログ ボックスが表示されます。

  4. 選択フィーチャのみトレース チェックボックスをオンにします。

  5. OK をクリックします。

    設定内容が保存され、ダイアログ ボックスが閉じます。

  6. 選択したフィーチャをトレースします。

  7. フィーチャを完成させるには、右クリックして 完了 をクリックするか、F2 キーを押します。