Skip to main content

Notebook 编辑器组件

在 notebook 编辑器中创作 notebook,该编辑器可通过 ArcGIS Enterprise 门户打开。 本主题将介绍 notebook 编辑器中的组件和菜单。

打开 notebook

要打开并编辑您拥有的 notebook,请完成以下步骤:

  1. 以拥有创建和编辑 notebook 的权限的用户身份进行登录。

  2. 在组织的导航栏中,单击 Notebooks

    随即打开 Notebooks 主页。

  3. (可选)单击项目上的选项按钮 以执行以下操作之一:

    • 单击预览查看详细信息以查看您拥有的 notebook(在我的 notebook 中)或与您共享的 notebook(在共享的 notebookEsri 示例 notebook 中)。

    • 单击删除以移除您拥有的 notebook 项目(在我的 notebook 中)。

  4. 单击打开

    Notebook 编辑器随即打开。

  5. 如果您拥有该 notebook,请单击保存以保存编辑。

  6. (可选)要将 notebook 的副本保存到工作空间,请执行以下操作之一:

    • 如果您已经拥有该 notebook,请单击下拉菜单 ,然后单击另存为以保存副本。

    • 如果您不是该 notebook 的所有者,请单击另存为

    将 notebook 另存为窗口随即出现。

  7. 添加标题,可以选择更改文件夹标签摘要选项。

  8. 单击保存 notebook

    随即保存该 notebook 并将其添加至我的 notebook

界面基础知识

Notebook 编辑器包含以下基本组件:

  • 导航栏 - 浏览网站、从应用程序启动器打开其他应用程序、查看帮助资源以及登录或登出您的个人资料。 导航栏还会显示 notebook 的标题,并指示该 notebook 是否具有未保存的更改。

  • 顶部功能区 - 执行关于您的 notebook 的各种任务。 此功能区具有以下按钮:

  • Notebook 菜单功能区 - 此功能区上的操作可在 notebook 中直接进行。 您可以添加和删除单元格、更改 notebook 外观、将 notebook 返回到上一个检查点等。 此功能区还将显示 notebook 是否受信任以及正在运行的 Python 版本。

  • 工具栏 - 将这些工具用于 notebook 中的常见任务。

  • 工作空间 - Notebook 内容将显示在此处,您也可以在此处修改内容。

Notebook 菜单功能区

Notebook 菜单功能区中的下拉列表提供了以下操作。

文件

文件菜单中,您可以选择按照以下格式之一下载或导出 notebook:

  • Markdown (.md)

  • Notebook (.ipynb)

  • Python (.py)

  • Reveal.js 幻灯片 (.slides.html)

您也可以从 notebook 项目页面以 .ipynb 格式下载 notebook。

编辑

编辑菜单中提供了以下项目:

  • 撤消

  • 恢复

  • 撤消单元格操作

  • 恢复单元格操作

  • 剪切单元格

  • 复制单元格

  • 将单元格粘贴到下方

  • 将单元格粘贴到上方

  • 粘贴单元格并替换

  • 删除单元格

  • 选择所有单元格

  • 取消选择所有单元格

  • 向上移动单元格

  • 向下移动单元格

  • 编辑 notebook 元数据

  • 拆分单元格

  • 合并所选单元格

  • 合并上方单元格

  • 合并下方单元格

  • 清除单元格输出

  • 清除所有单元格的输出

  • 查找

  • 查找下一个

  • 查找上一个

查看

视图菜单中提供了以下项目:

  • 活动命令选项板

  • 内容列表

  • 调试程序面板

  • 显示行号

  • 折叠已选代码

  • 折叠所选输出

  • 折叠所有代码

  • 折叠所有输出

  • 展开所选代码

  • 展开所选输出

  • 展开所有代码

  • 展开所有输出

  • 并排渲染

运行

运行菜单中提供了以下项目:

  • 运行所选单元格

  • 运行所选单元格并插入至下方

  • 运行所选单元格且不前进

  • 运行所选单元格上方的所有单元格

  • 运行所选单元格及其下方的所有单元格

  • 渲染所有 Markdown 单元格

  • 运行所有单元格

  • 重新启动核并运行所有单元格

  • 单元格类型 - 更改当前选定的单元格的类型。 选项为代码、Markdown 和 Raw。

菜单中提供了以下项目:

  • 中断核

  • 重新启动核

  • 重新启动核并清除所有单元格的输出

  • 重新启动核并运行到所选单元格

  • 重新启动核并运行所有单元格

  • 重新启动核并调试

  • 关闭核

设置

设置菜单中提供了以下项目:

  • 主题

    • 浅色 JupyterLab

    • 深色 JupyterLab

    • 深色 JupyterLab(高对比度)

    • 主题滚动条

    • 增大代码字号

    • 减小代码字号

    • 增大内容字号

    • 减小内容字号

    • 增大 UI 字号

    • 减小 UI 字号

  • 自动关闭括号

帮助

通过此列表可访问键盘快捷方式、用户界面以及与 ArcGIS Notebooks 和关键 Python 模块关联的多个帮助文档的相关信息。

Notebook 工具栏按钮

通过 notebook 工具栏可以快速访问 notebook 菜单功能区中最常用的操作。 可用按钮如下(从左至右):

  • 添加 - 在当前选定的单元格下插入一个单元格。

  • 剪切 - 剪切当前选定的单元格。

  • 复制 - 复制当前选定的单元格。

  • 粘贴 - 将复制的单元格粘贴到当前选定的单元格下方。

  • 运行 - 运行当前选定的单元格。

  • 停止 - 中断核。

  • 重新启动 - 重新启动核。

  • 快进 - 重新启动核并运行所有单元格。

  • 单元格类型 - 选择或更改当前选定的单元格的类型。