Skip to main content

制作图表

可通过具有属性表(包括独立表)的地图图层制作图表。 要使用地图中尚不存在的数据创建图表,请 将图层添加到地图中 ,使其显示在 内容 窗格中。

创建图表

可以从 内容 窗格、 数据 上下文选项卡或属性表创建图表。

开始新建图表

要创建图表,请完成以下步骤:

  1. 在 内容 窗格中选择图层或独立表。

  2. 在图层的上下文 数据 选项卡上单击 可视化 > 创建图表 。

    或者,可以右键单击 内容 窗格中的图层,然后单击 创建图表 。

  3. 从菜单中选择要创建的图表类型。

选择要创建的图表类型后,会出现以下情况:

  • 随即将显示一个图表窗口。 定义图表变量之前,此图表将保留为空。

  • 随即显示 图表属性 窗格,您可以在此窗格中定义图表变量、属性和标题文本。

  • 新图表将添加到 内容 窗格 按绘制顺序列出 选项卡 按绘制顺序列出 中源图层下的 图表 部分中。

    图层图表

可视化字段统计数据

还可以在查看图层的 属性表 或独立表时,右键单击字段名称并选择 可视化统计数据 选项创建图表。 这将自动确定用于可视化选定字段的最佳图表类型并打开完全配置的新图表。

图标窗口

图表在可停靠窗口或视图中显示。 可使用处理地图、布局或属性表的方法移动和停靠“图表”窗口。 在使用其中一个选项时,图表窗口中不会显示数据或值标注。 要在图表中显示数据,必须定义图表变量。

定义图表变量

要在图表中显示数据,按照以下步骤通过选择源图层中的属性字段定义所需的图表变量。

  1. 在 图表属性 窗格的 数据 选项卡上,选择创建图表所需的属性字段。

  2. 根据要创建的图表类型,可根据需要调整其他属性,例如 数值字段 、 聚合 或 变换 。

  3. 在 图表属性 窗格的 常规 选项卡上,可编辑图表和轴标题并提供相应描述。

定义图表变量后,图表窗口将在轴上显示相应的值,并将在图表上绘制数据。

了解有关图表类型的详细信息

配置图表的外观

如果可能的话,图表会自动匹配其图层的颜色。 其中包括未聚合的图表(例如散点图),或使用用于符号化图层的相同属性聚合的图表(例如条形图)。 通过单击 系列 表中的 符号 颜色样本并手动选择颜色,可以在 图表属性 窗格中对图表系列和符号颜色进行自定义。

可以通过格式化文本和符号元素或者应用图表主题来配置图表的外观。 格式属性可以在 图表属性 窗格的 格式 选项卡上进行配置。 可以在 图表 选项卡上选择图表主题。 图表格式化选项包括以下内容:

  • 轴标题、轴标注、描述文本、图例标题、图例文本和引导标注所使用的字体的大小、颜色和样式

  • 格网和轴线的颜色、宽度和线型

  • 图表的背景颜色

了解有关更改图表外观的详细信息