Skip to main content

通过追踪其他要素创建线段

在 创建要素 窗格上, 追踪 工具 追踪 可创建连续的线段,这些线段将遵循已打开捕捉功能的图层上的其他要素的几何。此工具可用于线和面要素模板,在创建线段时,此工具位于构造工具栏上。

创建启用 z 值的折线或面要素时,将基于当前 z 坐标高程设置为折点分配 z 值。有关指定 z 值的步骤,请参阅 为 3D 要素指定高程 。

追踪

  1. 在 目录 窗格中进行以下操作以将图层添加至地图:

    • 展开 数据库 数据库 ,展开包含数据的数据库并将要素类拖拽至地图。

    • 右键单击默认数据库,然后创建新的折线或面要素类。

    拖动或创建要素类可将图层添加到当前地图,并使用默认设置创建要素模板。

  2. 请针对您不想追踪的要素按图层关闭捕捉。这可以大幅提高绘制性能。

    1. 在 视图 选项卡的 窗口 组中,单击 内容 目录 。

    2. 单击 按捕捉列出 按捕捉列出 。

    3. 取消选中图层名称旁边的复选框以禁用捕捉,或单击右键并单击 将此图层设为唯一可捕捉图层 点 。

  3. 在 编辑 选项卡的 捕捉 组中,启用您的捕捉首选项。

    提示:

    在草绘要素时,可以按住 空格键 暂时关闭捕捉。

  4. 在 编辑 选项卡的 要素 组中,单击 创建 创建要素 。

    创建要素 窗格随即显示。

  5. 在窗格中单击折线要素模板。

    构造工具栏显示在地图的底部。

    “构造”工具栏

  6. 单击工具选项板旁边的 活动模板 按钮 前向 。

    模板的工具选项板和要素属性表将出现在窗格内。

  7. 在属性表中,键入要应用到新要素的值。

    • 对于组模板,请单击模板图标以显示其属性表。
  8. 单击 追踪 追踪 。

  9. 单击要追踪的要素并创建第一个折点。

    第一个折点已创建,拖动鼠标指针时虚线出现在要素上。

    提示:

    按下 T 键可显示您正在追踪的要素的折点。

  10. 将指针拖动到待追踪的要素上。

    • 要在创建面时暂时关闭捕捉,请按 空格键 。
  11. 要完成该追踪,请单击地图。

  12. 要完成要素,请右键单击,然后单击 完成 完成 ,或按 F2 键。

键盘快捷键

键盘快捷键

操作

注释

O

查看选项。

打开 选项 对话框。

选项卡

设置负偏移。

转换偏移的一侧并追踪边的另一侧。

Ctrl + 拖动

追踪所选要素。

仅追踪所选要素。 如果 追踪所选要素 已打开,则可以追踪所选要素及未选要素。

用于追踪线段构造工具的键盘快捷键

具有偏移的追踪

使用 具有偏移的追踪 选项以指定偏移创建线段。例如,您可以单击给水干管要素模板,将偏移设置为 7 米,然后沿宗地边界追踪以创建给水干管,给水干管以恒定偏移与宗地边界平行。

  1. 单击 追踪 追踪 。

  2. 右键单击地图,然后单击 追踪选项 。

    随即显示 追踪选项 对话框。

  3. 选中 具有偏移的追踪 复选框。

    追踪选项

  4. 单击 单位 下拉箭头,设置格式,然后在文本框中输入偏移距离。

  5. 单击 确定 。

    保存您的设置并关闭对话框。

  6. 追踪现有的一个或多个要素。

    提示:

    按 Tab 键以将偏移切换到要素的另一侧。

  7. 要完成要素,请右键单击,然后单击 完成 完成 ,或按 F2 键。

拐角

使用 拐角 选项控制拐角的形状。

  1. 单击 追踪 追踪 。

  2. 右键单击地图,然后单击 追踪选项 。

    随即显示 追踪选项 对话框。

  3. 单击以下设置之一:

    • 斜接角

    • 斜面角

    • 圆角

  4. 单击 确定 。

    保存您的设置并关闭对话框。

  5. 追踪要素。

  6. 要完成要素,请右键单击,然后单击 完成 完成 ,或按 F2 键。

移除自相交环

使用 移除自相交环 选项可防止在 具有偏移的追踪 被设置为较大的偏移距离时出现自相交环。

  1. 单击 追踪 追踪 。

  2. 右键单击地图,然后单击 追踪选项 。

    随即显示 追踪选项 对话框。

  3. 选中 移除自相交环 复选框。

  4. 单击 确定 。

    保存您的设置并关闭对话框。

  5. 追踪新要素。

  6. 要完成要素,请右键单击,然后单击 完成 完成 ,或按 F2 键。

限制追踪长度

使用 限制追踪长度 选项将追踪线段的长度限制为您所指定的距离。

  1. 单击 追踪 追踪 。

  2. 右键单击地图,然后单击 追踪选项 。

    随即显示 追踪选项 对话框。

  3. 选中 限制追踪长度 复选框。

  4. 输入距离并设置 单位 格式。

  5. 单击 确定 。

    保存您的设置并关闭对话框。

  6. 追踪要素。

  7. 要完成要素,请右键单击,然后单击 完成 完成 ,或按 F2 键。

仅追踪所选要素

使用 仅追踪所选要素 选项将追踪限制为仅追踪地图中的所选要素。

  1. 在 编辑 选项卡的 选择 组中,单击其中一个选择工具,然后选择要追踪的要素。

  2. 单击 追踪 追踪 。

  3. 右键单击地图,然后单击 追踪选项 。

    随即显示 追踪选项 对话框。

  4. 选中 仅追踪所选要素 复选框。

  5. 单击 确定 。

    保存您的设置并关闭对话框。

  6. 追踪所选要素。

  7. 要完成要素,请右键单击,然后单击 完成 完成 ,或按 F2 键。