Komponenten des Notebook-Editors
Notebooks werden im Notebook-Editor erstellt; dieser wird über die Organisation geöffnet. Dieses Thema bietet eine Einführung in die Komponenten und Menüs des Notebook-Editors.
Öffnen eines Notebook
Führen Sie die folgenden Schritte aus, um Ihre eigenen Notebooks zu öffnen und zu bearbeiten:
Melden Sie sich als Benutzer mit den Berechtigungen zum Erstellen und Bearbeiten von Notebooks an.
Klicken Sie auf der Navigationsleiste Ihrer Organisation auf Notebooks.
Die Startseite von Notebooks wird geöffnet.
Klicken Sie optional auf die Schaltfläche Optionen
für ein Element, und führen Sie eine der folgenden Aktionen aus:Klicken Sie auf Vorschau oder Details anzeigen, um die Notebooks anzuzeigen, die Sie besitzen (in Eigene Notebooks) oder die für Sie freigegeben wurden (in Freigegebene Notebooks oder Beispiel-Notebooks von Esri).
Klicken Sie auf Löschen, um die Notebook-Elemente, die Sie besitzen (in Eigene Notebooks), zu entfernen.
Klicken Sie auf Öffnen.
Der Notebook-Editor wird geöffnet.
Wenn Sie Besitzer des Notebooks sind, klicken Sie auf Speichern, um die Änderungen zu speichern.
Sie können eine Kopie des Notebooks in Ihrem Workspace speichern, indem Sie einen der folgenden Schritte ausführen:
Wenn Sie das Notebook bereits besitzen, klicken Sie auf das Dropdown-Menü
und dann auf Speichern unter, um eine Kopie zu speichern.Wenn Sie nicht im Besitz des Notebooks sind, klicken Sie auf Speichern unter.
Das Fenster Notebook speichern unter... wird geöffnet.
Fügen Sie einen Titel hinzu, und ändern Sie optional die Optionen Ordner, Tags und Zusammenfassung.
Klicken Sie auf Notebook speichern.
Das Notebook wird gespeichert und zu Eigene Notebooks hinzugefügt.
Hauptkomponenten der Bedienoberfläche
Der Notebook-Editor besteht aus folgenden Hauptkomponenten:
Navigationsleiste: Durchsuchen der Website, Öffnen weiterer Apps über den App-Launcher und An- oder Abmelden vom Profil. Zudem enthält die Navigationsleiste den Notebook-Titel und zeigt an, ob ungespeicherte Änderungen vorliegen.
Oberes Menüband: Für die Durchführung verschiedener Aufgaben, die im Zusammenhang mit dem Notebook stehen. Auf diesem Menüband befinden sich die folgenden Schaltflächen:
Hinzufügen: Hinzufügen von Layern und Web-Werkzeugen zum Notebook
Analyse: Zugriff auf Analysewerkzeuge zur Verwendung im Notebook
Codeausschnitte: Verwenden von Python-Codeausschnitten im Notebook.
Dateien: Durchsuchen von Dateien im ArcGIS-Workspace und Daten aus Beispiel-Notebooks.
Tasks: Erstellen eines oder mehrerer Tasks, um die Notebook-Ausführung zu automatisieren und den Zeitplan des Tasks anzugeben
Parameter: Konfigurieren von Eingabe- und Ausgabeparametern für das Notebook, das als Web-Werkzeug veröffentlicht werden soll. Die für ein Notebook konfigurierten Eingabeparameter sind verfügbar, wenn ein geplanter Task erstellt wird.
Veröffentlichen: Veröffentlichen des Notebooks als Web-Werkzeug
Snapshots: Erstellen eines Snapshot des Notebooks
Freigeben: Freigeben des Notebooks.
Info: Abrufen von Informationen zum Notebook. Sie können die Metadaten des Notebooks (Titel, Tags, Beschreibung, Nutzungsbedingungen und Quellennachweis) bearbeiten. Sie können auch die Runtime für Notebooks und die verfügbaren Bibliotheken anzeigen.
Speichern: Speichern des derzeitigen Notebook-Zustands. Freigegebene Notebooks enthalten stattdessen die Schaltfläche Speichern unter.
Notebook-Menüband: Aktionen für direktes Arbeiten im Notebook. Hier können Sie unter anderem Zellen hinzufügen und löschen, das Aussehen des Notebooks ändern und das Notebook auf einen vorherigen Prüfpunkt zurücksetzen. Zudem enthält das Menüband die Information, ob das Notebook vertrauenswürdig ist, sowie die ausgeführte Python-Version.
Werkzeugleiste: Werkzeuge für die Durchführung allgemeiner Aufgaben im Notebook.
Workspace: Der Inhalt des Notebooks wird hier angezeigt und kann bearbeitet werden.
Notebook-Menüband
Über die Dropdown-Listen auf dem Notebook-Menüband können folgende Aktionen ausgeführt werden.
File
Im Menü File können Sie auswählen, ob Sie das Notebook in einem der folgenden Formate herunterladen oder exportieren möchten:
Markdown (
.md)Notebook (
.ipynb)Python (
.py)Reveal.js-Folien (
.slides.html)
Auf der Elementseite des Notebooks können Sie das Notebook auch im .ipynb-Format herunterladen.
Edit
Die folgenden Elemente sind im Menü Edit verfügbar:
Undo
Redo
Undo Cell Operation
Redo Cell Operation
Cut Cell
Copy Cell
Paste Cell Below
Paste Cell Above
Paste Cell and Replace
Delete Cell
Select All Cells
Deselect All Cells
Move Cell Up
Move Cell Down
Edit Notebook Metadata
Split Cell
Merge Selected Cells
Merge Cell Above
Merge Cell Below
Clear Cell Output
Clear Outputs of All Cells
Find
Find Next
Find Previous
View
Die folgenden Elemente sind im Menü View verfügbar:
Active Command Palette
Table of Contents
Debugger Panel
Show Line Numbers
Collapse Selected Code
Collapse Selected Outputs
Collapse All Code
Collapse All Outputs
Expand Selected Code
Expand Selected Outputs
Expand All Code
Expand All Outputs
Render Side-by-Side
Run
Die folgenden Elemente sind im Menü Run verfügbar:
Run Selected Cell
Run Selected Cell and Insert Below
Run Selected Cell and do not Advance
Run All Above Selected Cell
Run Selected Cell and All Below
Render All Markdown Cells
Run All Cells
Restart Kernel and Run All Cells
Cell Type: Ändert den Typ für die aktuell ausgewählte Zelle. Folgende Optionen stehen zur Verfügung: Code, Markdown und Raw.
Kernel
Die folgenden Elemente sind im Menü Kernel verfügbar:
Interrupt Kernel
Restart Kernel
Restart Kernel and Clear Outputs of All Cells
Restart Kernel and Run up to Selected Cell
Restart Kernel and Run All Cells
Restart Kernel and Debug
Shut Down Kernel
Settings
Die folgenden Elemente sind im Menü Settings verfügbar:
Design
JupyterLab Light
JupyterLab Dark
JupyterLab Dark High Contrast
Theme Scrollbars
Increase Code Font Size
Decrease Code Font Size
Increase Content Font Size
Decrease Content Font Size
Increase UI Font Size
Decrease UI Font Size
Auto Close Brackets
Help
Dieses Menü bietet Zugang zu Informationen über die Tastenkombination, die Bedienoberfläche und verschiedene Hilfedokumente für ArcGIS Notebooks und die wichtigsten Python-Module.
Schaltflächen für die Werkzeugleiste "Notebook"
Über die Notebook-Werkzeugleiste erhalten Sie einen schnellen Zugriff auf die am häufigsten verwendeten Optionen des Notebook-Menübands. Sie enthält die folgenden Schaltflächen (von links nach rechts):
Hinzufügen: Fügt unterhalb der aktuell ausgewählten Zelle eine leere Zelle ein.
Ausschneiden: Schneidet das ausgewählte Element aus.
Kopieren: Kopiert die aktuell ausgewählte Zelle.
Einfügen: Fügt die kopierten Zellen unterhalb der derzeit ausgewählten Zelle ein.
Ausführen: Führt die aktuell ausgewählte Zelle aus.
Stopp: Hält den Kernel an.
Neustart: Startet den Kernel neu.
Schneller Vorlauf: Startet den Kernel neu und führt alle Zellen aus.
Zelltyp: Ändert den Typ für die aktuell ausgewählte Zelle.