編集の概要
ArcGIS AllSource では、リボン、編集ツールバー、およびウィンドウ内から編集ツールを使用できます。 一部のツールではショートカット メニューにコマンドが表示され、さまざまな編集タスクを実行できます。
以下のセクションでは、編集ユーザー インターフェイスについて概説します。 特定のツールを使用する手順については、目次を参照するか、ヘルプでキーワードまたはフレーズを検索してください。
データ タブ
データ タブには、データの追加、インポート、操作に関連するグループとツールが含まれています。 データ タブの 追加 グループには、フィーチャを作成するためのツールがあります。

グループの追加
追加 グループには以下で説明するツールが含まれており、これらのツールを使用して、データや接続をマップに追加することができます。
データの追加
このツールは、ローカル コンピューター、ポータル、またはプロジェクトへのパスからデータを追加するときに使用します。
新しいフィーチャ レイヤー
フィーチャ レイヤーは、建物、都市、道路、地形など、類似した地理フィーチャをグループ化したものです。 ポイント、マルチポイント、ライン、ポリゴン (エリア) などのフィーチャがあります。 フィーチャ レイヤーは、ベースマップの上部でデータを表示するのに最も適しています。 フィーチャ レイヤーをマップに追加するには、追加 グループの 新しいフィーチャ レイヤー をクリックし、ジオメトリーを選択します。
接続
このツールは、データにアクセスするためにデータベース、サーバー、クラウド ストアへの接続を作成するときに使用します。
レイヤー テンプレート
レイヤー テンプレートのギャラリーにアクセスして、新しい編集可能なレイヤーをアクティブなマップに追加します。 レイヤー テンプレートは、スキーマのみのレイヤー パッケージです。これは、レイヤーのシンボルやその他の表示プロパティと、基のデータセットのスキーマを定義します。 新しいフィーチャをレイヤーに追加すると、それらのフィーチャは新しいデータセットに格納されます。 テンプレートからアクティブなマップまたはシーンにレイヤーを追加するには、追加 グループで、レイヤー テンプレート ギャラリー内のレイヤー テンプレートのいずれかをクリックします。
新しいグラフィックス レイヤー
グラフィックス レイヤーは、グラフィックス エレメント (ジオメトリック シェープ、ライン、ポイント、テキスト、および画像) のコンテナーです。 マップまたはレイアウト上に、特定のエリアをハイライト表示する、または場所にラベルを付けるシンプルな表記を含めることができます。 グラフィックスを使用すると、フィーチャを作成せずにマップを視覚化できます。 たとえば、四角形とテキスト エレメントをグラフィックス レイヤーに追加して、対象地域とその付近のアクセス ポイントをハイライト表示することができます。 グラフィックスをプロジェクトに追加するには、新規グラフィックス レイヤー を使用します。
マップ タブ
マップ タブでは、ナビゲーション、選択、計測、ベースマップの変更により、アクティブなマップを操作します。 編集モードが有効になり、編集 タブが表示されます。 マップ タブの フィーチャ グループで 編集
をクリックすると、編集モードが開始されます。

編集タブ
編集 タブの各グループには、一般的な編集ワークフローを開始および完了するときに使用するツールとコマンドが含まれています。 一部のグループの右下隅にはダイアログ ボックス ランチャーがあり、これを押すと、そのグループに関連するダイアログ ボックスやタスク ウィンドウが開きます。

ヒント:
リボンでボタンを右クリックして、クイック アクセス ツールバーに追加できます。
新しいフィーチャ グループ
新しいポイント レイヤー、新しいライン レイヤー、新しいポリゴン レイヤー、および 新しいマルチポイント レイヤー を使用して、メモリ フィーチャ レイヤーをすばやく作成します。
クリップボード グループ
クリップボード グループにある 切り取り
、コピー
、貼り付け
、および 形式を選択して貼り付け ツールは、フィーチャをクリップボードにコピーして、同じレイヤーまたは別のレイヤーに貼り付けます。
スナップ
スナップ ウィンドウでは、スナップ設定を行います。 また、アクティブなマップの下部のステータス バーにあるポップアップ メニューでも制御できます。

選択グループ
選択 グループでは、アクティブな選択方法の設定、選択ツールの実行、選択内容の解除、および 属性 ウィンドウの表示を行うことができます。 フィーチャの修正 ウィンドウの選択ツールも、このグループで設定したアクティブな選択方法を使用します。 選択 グループの各ツールについて以下で説明します。
属性
属性 ツール
をクリックすると 属性 ウィンドウが開き、フィーチャ属性と関連するレコードの編集、アノテーション プロパティの変更、およびファイル アタッチメントの管理を行うことができます。

アタッチメント タブ
アタッチメントが有効になっているフィーチャを選択すると、アタッチメント タブおよびツールバーが 属性 ウィンドウに表示されます。

フィーチャ グループ
フィーチャ グループでは、フィーチャを作成または修正したり、アクティブなマップまたはシーンで選択したフィーチャを削除したり、スナップ設定を行ったり、ミリタリー シンボルを作成したりする編集タスク ウィンドウを開くことができます。 フィーチャ グループの各ツールについて以下で説明します。
作成
作成 ツール
をクリックすると、フィーチャ テンプレートおよびアクティブなマップ内のレイヤーに関連する作図ツールが含まれている フィーチャ作成 ウィンドウが開きます。

修正
修正 ツール
をクリックすると、フィーチャを修正する編集ツールの完全なコレクションが含まれている フィーチャの修正 ウィンドウが開きます。 すぐにアクセスできるように、マイ ツール タブで、ツールのカスタマイズされたコレクションを作成できます。

ミリタリー オーバーレイ
ミリタリー オーバーレイ ツール
をクリックすると、フィーチャを正確に表現する一連のミリタリー シンボルが用意されている ミリタリー オーバーレイ ウィンドウが開きます。 このウィンドウでは、ベーシック シンボルの検索、属性の修正、完全なミリタリー シンボルのプレビュー、およびお気に入りの保存を行うことができます。 これらのミリタリー シンボルをマップに追加するには、マップをクリックするか座標を入力します。
編集の管理グループ
編集の管理 グループでは、ワークスペース内のレイヤーに対する編集権限を確認したり、プロジェクトやアプリケーションの編集設定を変更したりすることができます。
編集セッションには開始ボタンも停止ボタンもありません。 既存のデータを編集したり、データを作成したりすると、編集セッションが自動的に開始されます。 編集内容を保存または破棄すると、自動的に編集セッションが停止します。 編集の管理 グループの各ツールについて以下で説明します。
編集オプション
編集オプション ダイアログ ボックス ランチャー
では、プロジェクトとアプリケーションの編集設定にアクセスできます。

Mapview ツールバー
Mapview ツールバー は、編集モードで有効な、コンテンツに対応したツールバーです。 現在のマップの上部に開き、コンテンツ で選択したレイヤーに基づく選択、ナビゲーション、および編集ツールで構成されます。

|
エレメント |
説明 |
|---|---|
|
|
Mapview ツールバー は、編集モード で有効になります。 |
|
|
選択ツールとナビゲーション ツールは、編集中すぐに使用できます。 |
|
|
フィーチャ作成ツールは、コンテンツ で選択したレイヤーに基づいて変わります。 |
|
|
フィーチャの修正ツールも、選択したレイヤーに基づいて変わります。 |
|
|
保留中の編集を保存または破棄します。 |
|
|
赤いマップ枠線は、保留中の編集を保存または破棄する準備ができていることを示します。 |
コンテンツ ウィンドウ
コンテンツ ウィンドウでは、レイヤーを書き込み禁止にしたり、レイヤー単位でスナップのオン/オフを切り替えたりすることができます。 コンテンツ ウィンドウの 2 つのタブについて以下で説明します。
編集別にリスト
編集別にリスト タブ
の 編集 の下にあるレイヤー チェックボックスをオンにすると、そのレイヤーの編集が有効になります。 これらの設定はアクティブなマップに適用され、データ ソースに対して付与された権限は変更されません。

スナップ別にリスト
スナップ別にリスト タブ
の スナップ の下にあるレイヤー チェックボックスをオンにすると、そのレイヤーのスナップが有効になります。
