編集設定の構成
マップ、レイヤー、および編集の設定を構成することで編集時の操作性を高めることができます。 コンテンツ ウィンドウで、マップとレイヤーの設定を使用できます。 編集設定はリボンの 編集 タブにあります。
以下の各セクションは、フィーチャを作成または修正するときに使用できるチェックリストとして構成されています。 これらのセクションは、最初から最後まで実行する必要のある包括的な手順ではありません。
ヒント:
すべての編集ウィンドウを 1 回のクリックでリセットするには、表示 タブをクリックし、ウィンドウ グループの ウィンドウのリセット ドロップダウン メニュー
をクリックし、編集用にウィンドウをリセット を選択します。
フィーチャ データの追加
編集するデータが含まれているフィーチャ レイヤーを追加するには、カタログ ウィンドウでフィーチャ レイヤーを検索してドラッグするか、フィーチャ レイヤーを右クリックして 現在のマップに追加
をクリックします。 データが存在しない場合は、フィーチャクラスを作成します。
カタログ ウィンドウからフィーチャ データを追加するには、次の手順に従います。
リボン上の 表示 タブをクリックした後、ウィンドウ グループで カタログ ウィンドウ
をクリックします。コンテンツ ウィンドウが表示されます。
プロジェクト タブをクリックします。
データベース フォルダー
を展開し、データを見つけます。そのフィーチャクラスをアクティブなマップ上にドラッグします。
または、フィーチャクラスを右クリックして 現在のマップに追加
をクリックします。注意:
マップに追加するフィーチャ レイヤーごとに、基本的なフィーチャ テンプレートがデフォルト設定で自動的に生成されます。
座標系の確認
フィーチャを作成または修正する場合、すべての編集は、現在のマップに割り当てられた座標系で行われます。 データ ソースが異なる座標系で格納されている場合、データはマップの座標系に同期的に「リアルタイム投影」されます。
ほとんどの編集処理や座標系変換では、編集内容の整合性と精度は維持されます。 ただし、使用されている座標系によっては、特定の編集処理によって配置や精度に思わぬ誤差が発生することがあります。
最善の結果を得るには、編集対象のレイヤーの座標系に一致する座標系を現在のマップに指定します。
現在のマップに割り当てられた座標系を表示するには、次の手順を実行します。
リボン上の 表示 タブをクリックした後、ウィンドウ グループで コンテンツ
をクリックします。コンテンツ ウィンドウが表示されます。
マップ名を右クリックし、プロパティ をクリックします。
座標系 タブをクリックします。
座標系情報を確認します。
OK をクリックして設定を保存し、ダイアログ ボックスを閉じます。
レイヤーの表示フィールドの設定
編集のためにフィーチャを選択した場合、それらのフィーチャが、表示フィールド レイヤーのプロパティの設定によって、ツール ウィンドウの選択ツリーにリスト表示されます。 デフォルトでは、これはフィーチャ レイヤーでフィールド名に単語 name が含まれている 1 つ目の文字列フィールドに設定されています。 フィールドが Null である場合、FID フィールド値が示されます。
識別しやすくするために、レイヤー プロパティ ダイアログ ボックスで「表示フィールドを変更する」か、カスタムの表示式を記述することができます。 このプロパティ設定は、選択チップ、マップチップ、ポップアップ、公開されたマップ サービス、およびフィーチャ レイヤーを識別する ArcGIS AllSource の他の領域でも使用されます。
選択可能かつ編集可能なソース レイヤーの設定
フィーチャを作成または変更するには、コンテンツ ウィンドウの各タブで、ソース レイヤーを選択可能かつ「編集可能」に設定する必要があります。
これらの設定を有効にするには、次の手順を実行します。
リボン上の 表示 タブをクリックした後、ウィンドウ グループで コンテンツ
をクリックします。コンテンツ ウィンドウが表示されます。
選択状態別にリスト タブ
をクリックし、編集中のレイヤーのレイヤー チェックボックスをオンにします。編集別にリスト タブ
をクリックし、編集中のレイヤーのレイヤー チェックボックスをオンにします。
スナップ エージェントの構成
「スナップ」は、頂点や端点、またはその他の幾何学的要素の近くにポインターを置くときに、ポインターの精度を制御します。 効率的かつ正確な作業に役立つスナップ エージェントの組み合わせを有効化します。 スナップのオン/オフを切り替えて、スナップ エージェントがポインターに適用されるタイミングを制御します。
ヒント:
スペースキーを押して、フィーチャの作成または修正中に、スナップを一時的にオフにすることができます。
スナップをオンにしたりスナップ エージェントを構成したりするには、次の手順を実行します。
ステータス バーの スナップ
をクリックして、スナップのオン/オフを切り替えます。
または、リボンの 編集 タブの スナップ グループで、スナップ
をクリックします。スナップ エージェントを有効化/無効化するには、ステータス バーの スナップ
にポインターを合わせます。
または、リボンの 編集 タブの スナップ グループで、スナップ ドロップダウン メニュー
をクリックします。