ArcGIS AllSource での編集
地理データの編集は、マップ内のレイヤーのフィーチャおよび関連データを作成、変更、または削除するプロセスです。 編集内容を保存すると、各レイヤーは、フィーチャを定義、格納するデータ ソースに接続されます。データ ソースは通常、ジオデータベース フィーチャクラス、シェープファイル、またはフィーチャ サービスです。
フィーチャは、2D または 3D で、自然界または構築された環境内の、実際の物理的オブジェクトまたはデータ ポイントを表すことができます。 開発者は、ArcGIS Pro SDK を使用して、ArcGIS AllSource 編集環境を拡張できます。 詳細については、「ArcGIS Pro SDK」の Web サイトをご参照ください。
このトピックでは、標準の ArcGIS AllSource 編集ツールを使用して行えることをまとめています。 リボンの データ タブ、編集 タブ、編集ウィンドウ、ショートカット メニュー、およびツールバーにあるツールの概要については、「編集のクイック ツアー」をご参照ください。
特定のツールを使用する手順については、編集に関するコンテンツ ウィンドウを参照するか、キーワードまたは文字列を使用してヘルプを検索してください。
編集ワークフロー
編集ツールは、一般的なマッピング アプリケーションから防衛、企業セキュリティー、犯罪分析などの情報機関まで、さまざまなワークフローをサポートしています。 ジオデータベース、フィーチャ サービス、GeoPackage、SQLite データベースのデータ、シェープファイルのデータ、およびモバイル デバイス上の Collector アプリからのデータを編集することができます。
実行できる編集のタイプには、次のワークフローがあります。
2D および 3D フィーチャの作成または変更。
フィーチャの属性と関連レコードの編集およびファイル アタッチメントを追加または削除します。
3D フィーチャを最初からまたは 3D モデルのインポートから作成します。
2D フィーチャを立ち上げまたは 3D フィーチャとしてシンボル表示します。
既存の属性を維持したままで、フィーチャ ジオメトリーを形状変更、置換、または編集します。
編集可能なその他のデータ タイプの詳細については、「サポートされているデータ タイプおよびデータ アイテム」をご参照ください。
編集モード
ArcGIS AllSource は、編集モードを使用して編集用のインターフェイスをコントロールします。 編集モード中は、テーブル、フィーチャ レイヤー、属性の作成と編集を行うことができます。 編集モードは、コンテキストに基づいており、Mapview ツールバーおよび 作図 ツールバーを使用して、選択したレイヤーに応じて使用できるツールを表示します。 編集モードを有効にするには、マップ タブの 編集 をクリックし、編集 タブを表示します。

編集モードと編集セッションは異なります。 既存のデータを変更したり、データを作成したりすると、ArcGIS AllSource が自動的に編集セッションを開始します。 表示と編集の権限が付与されたデータ ソースであれば、どれでも編集できます。 編集内容を保存または破棄すると、自動的に編集セッションが停止します。 それ以降に編集を行うと編集セッションが再開し、編集内容を保存するか破棄するまで実行されます。 編集モードを終了してもデータを編集できます。
編集 タブが閉じていても、フィーチャおよび属性を追加、削除、変更、更新することができます。 レイヤー別に編集をオフにすることで、編集できるレイヤーを指定できます。 これらの設定は、アクティブなマップまたはシーンに適用され、付与されているデータ ソースに対するアクセス権限を変更しません。 詳細については、「編集可能なレイヤーの指定」をご参照ください。
マップとシーン
マップまたはシーンのいずれかの 2D および 3D データを表示し編集することも、両方のデータを同時に表示し編集することもできます。 操作時にマップとシーンを切り替えて、リンクさせることで、アクティブなビューで画面移動やズームをしたときに、操作中の範囲の中心と縮尺が同じになるように、同期的に表示することができます。
マップ - 2D 平面図でデータを表示します。 詳細については、「マップ」をご参照ください。
シーン - マップを傾け、3D 空間内でデータを表示します。 詳細については、「シーン」をご参照ください。
作業に必要な表示または解析のタイプに応じて、シーンをローカル ビューまたはグローバル ビューとして構成できます。 距離、方向、縮尺、または面積の測定値の歪みを最小にする必要がある場合は、投影座標系を持つローカル シーンを選択するのが最適です。
詳細については、「3D 編集のためのシーンの構成」をご参照ください。
カタログ ウィンドウ
プロジェクトには、データ、レイアウト、ツールボックス、プロジェクトの完了に必要なその他のリソースへの接続が含まれています。 特定のデータを使用してプロジェクトを作成し、オンラインで共有したり、編集シナリオのテンプレートとして保存し、組織内で共有したりできます。
プロジェクトのリソースは、カタログ ウィンドウ
で表示および管理します。 ローカル データおよびオンライン データへの接続の追加および削除、フィーチャクラス、マップ、シーン、その他のプロジェクト アイテムの作成ができます。 このウィンドウには、ポータルのコンテンツにアクセスしたり、お気に入りのリストを作成したりするためのタブがあります。
詳細については、「カタログ ウィンドウの使用」をご参照ください。
2D および 3D フィーチャ
フィーチャ テンプレートは、それらが参照しているレイヤーに応じて、2D フィーチャまたは 3D フィーチャを作成できます。 2D フィーチャまたは 3D フィーチャを作成する手順は基本的に同じですが、3D フィーチャの場合は Z 値を指定する点が異なります。 3 次元フィーチャは、そのジオメトリーに Z 値を格納します。
2 次元フィーチャは Z 値を格納しませんが、2 次元フィーチャの Z 値は、テーブル内の属性フィールドから、または 3D シーン内の標高サーフェスから得ることができます。 場合によっては、属性フィールドを使用して標高値を既存の 2D フィーチャに追加するか、立ち上げた方が簡単であることがあります。
詳細については、「2D および 3D フィーチャの概要」をご参照ください。
バージョン対応登録されたデータ
バージョン対応登録済みのデータを編集すると、他のユーザーが編集している可能性がある同一データの別バージョンを修正することになります。 編集内容は、システム テーブルで追跡され、変更を保存するときにリコンサイルされてポストされます。
オプションの設定を使用して、編集を保存するときに競合がどのように定義され、リコンサイルされるかを指定できます。 競合マネージャー ウィンドウを表示して、競合を対話的に確認したり、これを非表示にして、競合を自動的にリコンサイルしたりすることができます。
詳細については、「バージョニング オプションの設定」をご参照ください。