Skip to main content

ノートブック エディターのコンポーネント

ノートブックは、組織で開かれるノートブック エディターで作成されます。 このトピックでは、ノートブック エディターのコンポーネントとメニューについて説明します。

ノートブックを開く

所有するノートブックを開いて編集するには、次の手順に従います。

  1. ノートブックを作成および編集する権限を持つユーザーとしてサイン インします。

  2. 組織のナビゲーション バーで、ノートブック をクリックします。

    ノートブックのホームページが開きます。

  3. 必要に応じて、アイテムの オプション ボタン をクリックして、次のいずれかを実行します:

    • プレビュー または 詳細の表示 をクリックして、所有しているノートブック (マイ ノートブック) または共有されているノートブック (共有ノートブック または Esri サンプル ノートブック) を表示します。

    • 削除 をクリックして、所有している (マイ ノートブック 内の) ノートブックのアイテムを削除します。

  4. 開く をクリックします。

    ノートブック エディターが開きます。

  5. ノートブックを所有している場合、保存 をクリックして、編集内容を保存します。

  6. 必要に応じ、ノートブックのコピーをワークスペースに保存するには、次のどちらかの手順を実行します。

    • ノートブックをすでに所有している場合、ドロップダウン メニュー をクリックしてから、名前を付けて保存 をクリックして、コピーを保存します。

    • ノートブックを所有していない場合は、名前を付けて保存 をクリックします。

    ノートブックを名前を付けて保存 ウィンドウが表示されます。

  7. タイトルを追加し、必要に応じて、フォルダー、タグ、サマリー オプションを変更します。

  8. ノートブックの保存 をクリックします。

    ノートブックが保存され、マイ ノートブック に追加されます。

インターフェイスの基本

ノートブック エディターには、次の基本コンポーネントがあります。

  • ナビゲーション バー: Web サイトを参照したり、アプリ ランチャーから他のアプリを開いたり、ヘルプ リソースを表示したり、プロファイルにサイン インまたはサイン アウトしたりできます。 ナビゲーション バーには、ノートブックのタイトルや、ノートブックに未保存の変更がないかどうかも表示されます。

  • 上部のリボン: ノートブックに関連するさまざまなタスクを実行します。 このリボンには、次のボタンがあります。

  • ノートブック メニュー リボン: このリボンのアクションは、ノートブックの作業ディレクトリー用です。 ここでは、セルの追加と削除、ノートブックの外観の変更、ノートブックを以前のチェックポイントに戻すなどの操作を行えます。 このリボンには、ノートブックが信頼されているかどうかと、実行されている Python のバージョンも表示されます。

  • ツールバー: ノートブックの一般的なタスクを行うためのツールを使用します。

  • ワークスペース: ノートブックのコンテンツはここに表示されます。また、コンテンツの修正もここで行えます。

ノートブック メニュー リボン

ノートブック メニュー リボンのドロップダウン リストでは、次の操作を行えます。

ファイル

ファイル メニューで、ノートブックをダウンロードまたはエクスポートする形式を次の中から選択できます。

  • Markdown (.md)

  • ノートブック (.ipynb)

  • Python (.py)

  • Reveal.js スライド (.slides.html)

ノートブックのアイテム ページから、.ipynb 形式のノートブックをダウンロードすることもできます。

編集

編集 メニューでは、次の項目が利用できます。

  • 元に戻す

  • やり直し

  • セル操作を元に戻す

  • セル操作のやり直し

  • セルの切り取り

  • セルをコピー

  • セルを下に貼り付け

  • セルを上に貼り付け

  • セルの貼り付けと置換

  • セルの削除

  • すべてのセルを選択

  • すべてのセルを選択解除

  • セルを上に移動

  • セルを下に移動

  • ノートブック メタデータの編集

  • セルの分割

  • 選択したセルのマージ

  • 上のセルとマージ

  • 下のセルとマージ

  • セルの出力をクリア

  • すべてのセルの出力をクリア

  • 検索

  • 次を検索

  • 前を検索

表示

表示 メニューでは、次の項目が利用できます。

  • アクティブなコマンド パレット

  • コンテンツ ウィンドウ

  • デバッガー パネル

  • ライン番号の表示

  • 選択したコードを折りたたむ

  • 選択した出力を折りたたむ

  • すべてのコードを折りたたむ

  • すべての出力を折りたたむ

  • 選択したコードの展開

  • 選択した出力の展開

  • すべてのコードを展開

  • すべての出力を展開

  • 並べてレンダリング

実行

実行 メニューでは、次の項目が利用できます。

  • 選択したセルの実行

  • 選択したセルを実行してセルを下に挿入

  • 選択したセルを実行して先には進まない

  • 選択したセルより上にあるセルをすべて実行

  • 選択したセルと下にあるすべてのセルを実行

  • すべての Markdown セルをレンダリング

  • すべてのセルを実行

  • カーネルを再開してすべてのセルを実行

  • セル タイプ - 選択中のセルのタイプを変更します。 オプションはコード、Markdown、Raw です。

カーネル

カーネル メニューでは、次の項目が利用できます。

  • カーネルの中断

  • カーネルの再開

  • カーネルを再開してすべてのセルの出力をクリア

  • カーネルを再開して選択したセルまで実行

  • カーネルを再開してすべてのセルを実行

  • カーネルを再開してデバッグ

  • カーネルの終了

設定

設定 メニューでは、次の項目が利用できます。

  • テーマ

    • JupyterLab Light

    • JupyterLab Dark

    • JupyterLab Dark High Contrast

    • テーマ スクロールバー

    • コード フォント サイズの拡大

    • コード フォント サイズの縮小

    • コンテンツ フォント サイズの拡大

    • コンテンツ フォント サイズの縮小

    • UI フォント サイズの拡大

    • UI フォント サイズの縮小

  • 括弧を自動的に閉じる

ヘルプ

このリストでは、キーボード ショートカット、ユーザー インターフェイス、ArcGIS Notebooks および主な Python モジュールに関するさまざまなヘルプ ドキュメントにアクセスできます。

ノートブックのツールバーのボタン

ノートブック ツールバーは、ノートブック メニュー リボンで特によく使用される操作へのクイック アクセスを提供しています。 使用できるボタンは次のとおりです (左から右)。

  • 追加 - 選択中のセルの下にセルを挿入します。

  • 切り取り - 選択中のセルを切り取ります。

  • コピー - 選択中のセルをコピーします。

  • 貼り付け - コピーしたセルを、選択中のセルの下に貼り付けます。

  • 実行 - 現在選択中のセルを実行します。

  • 停止 - カーネルを中断します。

  • 再開 - カーネルを再開します。

  • 早送り - カーネルを再開し、すべてのセルを実行します。

  • セル タイプ - 選択中のセルのタイプを選択または変更します。