Skip to main content

创建表模板

表模板 将在 管理模板 窗格 管理模板 中创建。 当您在图层视图中右键单击表时,模板视图工具栏上会显示命令。 此外,对于新添加的表,如果当前工程中没有模板,则 ArcGIS Pro 会自动生成模板。

本主题包含创建表模板、命名模板及添加可选描述性元数据的步骤。 有关配置工具选项板并指定应用于新行的默认属性的步骤,请参阅 配置表模板 。

自动生成模板

如果将表添加到地图,而当前工程中不存在表模板,则 ArcGIS Pro 会自动使用名称、默认设置和标签关键字创建这些模板。 如果表包含 子类型 ,则会为每个子类型值生成一个模板。

要将表添加到地图并自动生成其表模板,请完成以下步骤:

  1. 在功能区的 视图 选项卡上,单击 窗口 组中的 目录窗格 目录窗格 。

    内容 窗格随即显示。

  2. 单击 工程 选项卡。

  3. 展开 数据库 文件夹 数据库 并查找数据。

  4. 将独立表拖动至活动地图。

    或者,右键单击表,然后单击 添加到当前地图 添加至当前地图 。

    提示:

    如果没有为新表自动生成模板,请 删除图层的所有模板 。

为所选表创建模板

要为表创建表模板,请在图层视图中选择表,然后单击模板视图工具栏上的 新建 > 模板 新建模板 。

  1. 在功能区 编辑 选项卡上的 管理编辑内容 组中,单击 管理模板 管理模板 。

    或者,在 创建要素 窗格中,单击 管理模板 管理模板 。

    随即打开 管理模板 窗格。

  2. 单击图层视图中的表。

  3. 在模板视图工具栏上,单击 新建 > 模板 新建模板 。

    将出现 模板属性 对话框。

  4. 在 模板属性 对话框上,单击 常规 侧选项卡。

    在此选项卡上输入的名称和可选的描述性元数据可在 创建要素 和 管理模板 窗格中 搜索 。 搜索词不区分大小写。

  5. 在 名称 字段中输入名称。 此字段为必填字段。

  6. 在以下字段中输入可选的描述性元数据:

    字段名

    描述

    描述

    输入描述或模板的用途。 该字段为可选字段。

    标签

    输入一个或多个可选关键字,在 创建要素 和 管理模板 窗格中,可以使用 排列模板 过滤器 滤波器 通过这些关键字分类或过滤模板。

    • ArcGIS Pro 会为模板类型自动添加标签。

    • 要删除标签,可以单击标签关键字旁的 删除 按钮 删除 。

  7. 单击 确定 保存设置并关闭对话框。

基于所选记录创建模板

要基于 属性 窗格中已选要素的记录创建表模板,请在选择视图中右键单击记录,然后单击 根据记录新建模板 根据要素新建模板 。

  1. 在功能区的 编辑 选项卡中,单击 选择 组中的 属性 属性 。

    随即出现 属性 窗格。

  2. 单击 属性 窗格中的 选择 选择 工具,然后在表中选择包含记录的要素。

  3. 在选择视图中展开要素以显示其相关记录。

  4. 右键单击记录,然后单击 根据记录新建模板 根据要素新建模板 。

    根据记录新建模板