Skip to main content

验证并修复拓扑错误

在 Standard 或 Advanced 许可等级下可用。

错误检查器 错误检查器 用于验证地图中的要素 拓扑 ,并包含一些工具和命令,用于通过表查看器检查、修复和管理结果。 它位于 编辑 选项卡的 管理编辑 组中以及 修改要素 窗格中。

菜单栏将命令分为三个主要工作流组: 源 、 过滤器 和 选择 。 如果选择源拓扑并对其进行验证,则将符号化专用地图图层上的结果并在表查看器中显示结果。

在您验证、修复和管理拓扑错误时,请注意以下事项:

  • 过滤器 命令用于在表查看器中显示特定类型的结果,以更轻松地对其进行管理。

  • 修复 选项卡包含的命令用于标记或清除异常以及针对选定错误应用预定义修复。

  • 选择 组中的 复制 命令用于将选定行复制到剪贴板并且允许您将其粘贴到 Microsoft Excel 等外部应用程序。

在要素服务中发布的地理数据库拓扑 可以在 ArcGIS Pro 中进行编辑,并通过要素服务进行验证和修复。

要验证并修复拓扑错误,请完成以下步骤:

  1. 单击功能区的 编辑 选项卡。 在 管理编辑 组中,单击 错误检查器 错误检查器 。

    错误检查器 表格随即出现。

  2. 在菜单栏的 源 组中,选择源拓扑并对其进行验证。

    错误检查器验证

    1. 单击 源 下拉箭头,然后选择拓扑。

    2. 单击 验证 验证范围 。

      或者,单击 修改要素 窗格中的 验证 工具。

    错误和异常会在表格中显示并在按要素类型分类的地图图层上进行符号化。

  3. 在 过滤器 组中,选择在表视图中显示的规则、错误、异常、规则类型、错误几何和地图范围。

    过滤器设置通过布尔 AND 逻辑搭配使用。 仅在每个过滤器返回一个结果时,这些设置才会共同显示信息。 如果任何过滤器设置未返回结果,则表不会显示任何内容。

    已启用过滤器设置的过滤器将以蓝色高亮显示。

    错误检查器过滤器

    1. 单击 规则 规则 ,选中弹出菜单中要在表格中显示的规则对应的复选框,然后单击 关闭 关闭 。

      要取消选中所有复选框,单击 清除 。

      过滤器

    2. 单击 要素类 规则 ,对于要在表中显示的要素类,选中其弹出菜单上的复选框,然后单击 关闭 关闭 。

      要取消选中所有复选框,单击 清除 。

      要素类

    3. 单击 规则类型 规则 ,选中弹出菜单中要在表格中显示的规则类型对应的复选框,然后单击 关闭 关闭 。

      地理数据库拓扑规则用于定义不同要素类中特定要素几何之间或者要素子类型之间允许的空间关系。

      要取消选中特定几何类型的一组规则的所有复选框,请单击 清除 。

      规则类型

    4. 单击 错误几何 规则 ,选中弹出菜单中要在表格中显示的错误几何类型对应的复选框,然后单击 关闭 关闭 。

      要取消选中所有复选框,单击 清除 。

      错误几何

    5. 单击 异常 规则 ,然后选择 错误 、 错误和异常 或 异常 。

    6. 单击 地图范围 地图范围 。

      要过滤特定感兴趣区,需要使用指针拖动地图,然后单击 地图范围 。

  4. 要选择并高亮显示表视图中的错误,单击 Shape 字段旁的灰色方块。

    • 要选择一系列错误行,在行中向上或向下拖动指针,或按住 Shift 并单击序列中的最后一条记录。

    • 要选择多个错误行,请按 Ctrl 并单击每个记录。

    选定行在表视图中高亮显示,并且 选择 组中的命令处于启用状态。

  5. 要缩放或平移到选定记录,使用 选择 组中的以下命令。

    错误检查器选择

    缩放至所选项 缩放至所选项

    放大地图并在选定行中的错误范围内将地图居中。 或者,按 Ctrl+Shift+等号 。

    平移至所选项 平移至所选项

    围绕选定行中的错误居中地图。 或者,按 Ctrl+Shift+N 。

    切换选择 切换选择

    取消选择所有选定要素,然后选择所有已取消选定的要素。 或者,按 Ctrl+U 。

    清除所选内容 清除已选择

    取消选择所有已选行。 或者,按 Ctrl+U 。 要选择所有行,按 Ctrl+A

    选择要素 要素

    请选择在所选行内造成错误的要素。 或者,按 F 键。

    复制 复制

    将选定行和列标头作为制表符分隔的数据复制到剪贴板。 异常以 True 或 False 的形式复制。

    提示:

    可以将此数据粘贴到 Microsoft Excel 等外部应用程序。

  6. 单击错误查看器中的 预览 选项卡,显示保持地图视图范围不变时生成错误的要素。

  7. 单击 详细信息 选项卡,查看有关要素和错误的信息。

    提示:

    要显示表中的 Length 和 Area 字段,单击菜单栏中的菜单按钮 菜单 ,然后启用 显示形状长度/面积 。

  8. 单击 修复 选项卡,然后使用可用工具修复选定错误,或者标记或清除异常。

    错误检查器错误查看器

    可用于选定错误的修复措施

    本节包含具有适用于特定错误的已定义修复的工具。 如果没有可用的预定义修复程序,请使用标准编辑工具选择并编辑要素。

    标记为异常 标记为异常

    单击此命令从拓扑图层中移除高亮显示的错误,并在对拓扑进行验证后将其忽略。 如果您确定要素需要符合拓扑规则,则可以恢复该错误。

    清除异常 清除异常

    单击此命令恢复高亮显示的错误,然后在拓扑图层上对其进行符号化。

  9. (可选)使用错误查看器下的状态栏中的命令,缩放到地图中的错误并进行修复,或者逐个浏览表中的错误。

    缩放错误 缩放错误

    缩放到地图中的错误。

    修复错误 修复错误

    单击地图中的错误,然后使用弹出窗口菜单中的命令对其进行修复。 可用命令取决于错误。

    弹出菜单

    注:

    还可以在 修改要素 窗格中找到此工具。

    上一错误 上一错误

    如果未在表中选择任何错误,将光标移至上一行。

    下一错误 下一错误

    如果未在表中选择任何错误,将光标移至下一行。

  10. 要确认您的编辑已纠正错误,单击菜单栏中的 验证 验证范围 。

用于错误检查器的键盘快捷键

键盘快捷键

操作

注释

上箭头键 和 下箭头键

移动指针。

在错误表的行间上下移动指针。

Ctrl+等号 (=)

放大地图并使地图以当前行中的错误要素为中心。

这等同于单击工具栏上的 缩放至 缩放至所选项 。

或者,按 Ctrl+Shift+等号 (=)

Ctrl+N

将活动地图平移到选定错误。

这与在工具栏上单击 平移至 平移至所选项 的效果一致。

或者,按 Ctrl+Shift+N

F

选择导致该错误的主要要素。

这等同于单击工具栏上的 选择要素 要素 。

X

将错误标记为异常。

这等同于右键单击当前行,然后单击 标记为异常 标记为异常 。

E

清除异常并将该记录标记为错误。

这等同于右键单击当前行,然后单击 清除异常 清除异常 。

R

显示 规则 下拉菜单并针对拓扑规则启用过滤。

这等同于单击工具栏上的 规则 规则 。

注:

在错误行的快捷菜单上,此快捷方式将显示规则说明。

M

显示当前地图范围内的错误。

这等同于单击工具栏上的 地图范围 地图范围 。

V

识别拓扑错误并在当前地图范围内在图层上对其进行符号化。

这等同于单击工具栏上的 验证 验证范围 。

Ctrl+U

切换所选行。

这等同于单击工具栏上的 切换 切换选择 。

Ctrl+Shift+A

取消选择所有选定行。

这等同于单击工具栏上的 清除 清除已选择 。

Ctrl+Shift+C

将所选行复制到剪贴板。

这等同于单击工具栏上的 复制 复制 。

Ctrl+8

在地图中闪烁错误要素的形状。

这等同于右键单击当前行,然后单击 闪烁 闪烁 。

Ctrl+等号 (=)

放大地图并使地图以错误要素为中心。

这等同于右键单击当前行,然后单击 缩放至 缩放至 。

Ctrl+空格键

选择或取消选择当前行。

这等同于右键单击当前行,然后单击 选择/取消选择 。 取消选择

R

查看此错误所违反规则的说明和示例图形。

这等同于右键单击当前行,然后单击 规则说明 。

注:

在工具栏上,此快捷方式将显示 规则 菜单 规则 。

用于拓扑错误检查器的键盘快捷键

了解有关 拓扑属性 和 常见拓扑任务 的详细信息。