Skip to main content

创建死胡同

在 修改要素 窗格中, 死胡同 工具 死胡同 用于创建与选定线要素(表示道路中心线)对齐的死胡同几何。您需要指定街道宽度、死胡同的半径值以及两条返回曲线的半径值。

您可以选择直线或曲线要素。选择具有 90 度转弯的中心线会创建一个不对称的死胡同。返回(或反向)曲线在指定街道宽度处终止主弧的两端。

死胡同参数

注:

当 地面到格网校正 地面到格网校正 打开时,您输入的方向值将旋转,距离值将根据生成的几何图形进行缩放。

有关详细信息,请参阅 打开或关闭地面到格网校正 。

  1. 如果当前地图不包含线要素图层,则请添加该图层。

    1. 在 视图 选项卡中,单击 目录窗格 目录窗格 ,然后展开 数据库 数据库 。

    2. 展开默认数据库或包含数据的数据库。

      要创建线要素类,请右键单击数据库,然后依次单击 新建 和 要素类 。

    3. 将要素类拖动到地图上。

      将为新图层自动生成具有默认设置的要素模板。

  2. 如果创建的线要素需要将输入值与要素一起存储在 COGO 属性字段中,则请启用线要素的 COGO。

    启用了 COGO 的线要素类将使用 COGO 符号系统进行绘制,并包括用于标注每条线的 COGO 尺寸(如果存在)的标注表达式。

    有关详细信息,请参阅 启用 COGO 。

  3. 如果要在 编辑 选项卡的 高程 组中使用启用了 z 值的要素,请选择将 z 值添加到要素的方式。

    有关在创建启用 z 值的要素时指定 z 值的步骤,请参阅 为 3D 要素指定高程 。

  4. 在 编辑 选项卡中,设置捕捉首选项,然后显示 修改要素 窗格。

    1. 在 捕捉 组中,启用您的捕捉首选项。

      提示:

      要在绘制要素时暂时关闭捕捉,请按住 空格键 。

    2. 在 要素 组中,单击 修改 修改要素 。

  5. 显示工具并打开预览。

    1. 在窗格中,展开 COGO 并单击 死胡同 死胡同 。

    2. 选中 显示预览 。

      死胡同工具

  6. 使用窗格中的工具选择要用作中心线的线要素。

    1. 单击 选择 工具 活动选择 并选择包含要编辑的 m 值的要素。

    2. 如果选择多个要素,请双击要编辑的要素项,或者,右键单击该要素项,然后单击 仅选择此项 取消选择 。

      仅选择此项

    提示:

    如果中心线不存在,则可以使用要素模板进行创建。当您单击 完成 完成 或按 F2 时,该工具会将其用作当前选择。

  7. 要在与所选要素图层不同的图层上创建死胡同,请执行以下操作:

    1. 选中 使用模板 。

    2. 单击下拉箭头,然后选择一个要素模板。

  8. 选择选定线要素上要创建死胡同的末端。

    • 线的起点 - 在第一个折点处创建死胡同。

    • 线的末端 - 在最后一个折点处创建死胡同。

  9. 指定死胡同的宽度和径向参数。

    • 街道宽度 - 主弧两端的终止距离。

    • 半径 - 死胡同的主弧。

    • 返回半径 - 以指定街道宽度来终止主弧两端的返回曲线。

  10. 单击 创建 。