Skip to main content

根据 GNSS 设备位置创建要素

在 创建要素 窗格中,要素模板可在流式传输自所连接的 全球导航卫星系统 (GNSS) 设备 的地理位置创建要素。在 GNSS 设备已添加到工程中且设备位置已在当前地图中打开的情况下,此功能可用。

要在流式传输自所连接 GNSS 设备的位置创建点要素或折点,请完成以下步骤:

  1. 将 GNSS 设备添加到您的工程。

    1. 在 视图 选项卡的 设备位置 组中,单击 设备位置选项 对话框启动器 启动器 。

    2. 单击 设备位置 选项卡。

    3. 单击 GNSS 设备 箭头,然后选择活动 GNSS 设备并设置精度阈值。

      设备位置选项

    4. 要更改精度阈值,请在 精度阈值 文本框中键入值,然后设置单位。

    5. 单击 确定 。

  2. 打开设备位置并设置导航设置。

    蓝色标记将在地图上追踪设备的移动情况。红色标记则表示位置数据的精度超出了您在工程“选项”设置中为设备设置的精度阈值。

    1. 在 视图 选项卡上的 设备位置 组中,单击并打开 启用位置 测量标记 。

      系统随即显示 设备位置 选项卡并在地图中显示所连接设备的位置标记。

      注:

      要显示 设备位置 窗格并 查看设备位置和位置详细信息 ,请单击 设备位置 箭头,然后单击 位置详细信息 位置详细信息 。

    2. 在 设备位置 选项卡上,调整可见性和导航设置。

      要平移到所连接设备的当前位置,请单击 平移至位置 平移至位置 。

      “设备位置”选项卡

  3. 如果当前地图不包含数据的要素图层,请进行添加。

    1. 在 视图 选项卡中,单击 目录窗格 目录窗格 ,然后展开 数据库 数据库 。

    2. 展开默认数据库或包含数据的数据库。

      要创建要素类,请右键单击数据库,然后依次单击 新建 和 要素类 。

    3. 将要素类拖动到地图上。

      将为新图层自动生成具有默认设置的要素模板。

  4. 显示 创建要素 窗格并单击要素模板。

    1. 在 编辑 选项卡上,单击 创建 创建要素 。

    2. 单击点、线或面要素模板。

      构造工具栏显示在地图的底部。

  5. 在构造工具条上,单击 添加设备位置 添加图形 或按 Ctrl+G ,以便在标记所显示的设备当前地理位置处创建点要素或折点。

    重复此步骤以创建多个点或折点。如果存在 GNSS 元数据字段,则系统将使用 GNSS 位置信息对其进行自动填充。

    要将这些字段添加到源要素类,请使用 添加 GPS 元数据字段 地理处理工具。

    • 点要素模板将创建点要素并自动完成每个要素。

      添加点要素设备位置

    • 线和面要素模板将创建折点。要完成要素并创建其他要素,请单击 完成 完成 ,或按 F2 键。

      在设备位置处添加折点

    注:

    警告工具图标 添加设备位置 表示位置数据的精度超出了您在工程“选项”设置中为设备设置的精度阈值。

  6. 要退出活动要素构造工具并隐藏工具条,请按 Esc 键。

  7. 在 编辑 选项卡的 管理 组中,单击 保存编辑内容 保存编辑内容 以保存您的编辑内容。