Skip to main content

创建螺旋曲线

在 创建要素 窗格中,线要素构建工具包括 螺旋曲线 构造方法,用于创建螺旋曲线作为增密折线。创建要素时,可在构造工具栏和快捷菜单中找到该对话框。

螺旋曲线是具有固定起点和半径的曲线,其半径随着其增加或减小而与弧到起点的距离成比例地变化。几何由起始方位角、起始半径、终止半径和弧长或增量角定义。

螺旋曲线通常用于道路和铁路设计中,以将移动的车辆安全地过渡到圆形路径或直线中或从中移出。

注:

当 地面到格网 地面到格网校正 打开时,您输入的方向值将旋转,且半径和弧长值将根据生成的几何进行缩放。

有关详细信息,请参阅 打开或关闭地面到格网 。

  1. 如果当前地图不包含折线要素图层,则请添加该图层。

    1. 在 视图 选项卡中,单击 目录窗格 目录窗格 ,然后展开 数据库 数据库 。

    2. 展开默认数据库或包含数据的数据库。

      要创建面要素类,请右键单击数据库,然后依次单击 新建 和 要素类 。

    3. 将要素类拖动到地图上。

      将为新图层自动生成具有默认设置的要素模板。

  2. 如果创建的线要素需要将输入值与要素一起存储在 COGO 属性字段中,则请启用线要素的 COGO。

    启用了 COGO 的线要素类将使用 COGO 符号系统进行绘制,并包括用于标注每条线的 COGO 尺寸(如果存在)的标注表达式。

    有关详细信息,请参阅 启用 COGO 。

  3. 如果要在 编辑 选项卡的 高程 组中使用启用了 z 值的要素,请选择将 z 值添加到要素的方式。

    有关在创建启用 z 值的要素时指定 z 值的步骤,请参阅 为 3D 要素指定高程 。

  4. 在 编辑 选项卡中,设置捕捉首选项,然后打开 创建要素 窗格。

    1. 在 捕捉 组中,启用您的捕捉首选项。

      提示:

      要在绘制要素时暂时关闭捕捉,请按住 空格键 。

    2. 在 要素 组中,单击 创建 创建要素 。

  5. 在窗格中,选择线要素模板并配置构造工具。

    1. 单击线要素模板,然后单击 活动模板 按钮 前向 。

    2. 单击 两点线 2 点线 。

    3. 选中 继续两点线 以创建相连的两点线要素。

      创建两点连续线要素会将螺旋作为要素创建并更新 COGO 属性。如果不使用两点线构造工具,则会将螺旋创建为线段,且不会更新 COGO 属性。

      连续的两点线要素会在上一个两点线要素的最后一个折点的坐标处自动创建第一个折点。

    构造工具栏显示在地图的底部。

    “构造”工具栏

  6. 单击地图或要在其上开始螺旋曲线的现有线或弧的端点。

  7. 单击右键,然后单击 螺旋曲线 。

    预览将旋转到计算的切线方向,并将显示对话框。

  8. 将起始方位角指定为 切线方向 或 弦方向 。

  9. 使用以下方法之一指定 起始半径 :

    • 如果要从圆弧切点开始,请指定半径值。

    • 如果要从直线切点开始,则请按 删除 以删除半径值并将参数设置为 无穷大 。

  10. 使用以下方法之一指定 终止半径 :

    • 如果以圆弧切点结束,请指定半径值。

    • 如果要以直线切点结束,则请按 删除 以删除半径值并将参数设置为 无穷大 。

    注:

    指定相等的开始和结束半径将创建一个未增密圆弧。

  11. 将螺旋的长度指定为 弧长 或 增量角 。

  12. 要翻转圆弧预览和生成的草图的方向,请单击 左 或 右 。

  13. 单击 增密方式 下拉箭头,并指定要如何对螺旋进行增密。

    • 偏差 - 创建长度可变的线段,这些线段在最大指定距离内偏离真曲线。

    • 角度 - 创建不超过指定角度的线段。线段的长度随着曲率的增加而减小。

    • 长度 - 创建不超过指定长度的线段。

  14. 按 Enter 键关闭对话框并创建螺旋曲线。