Skip to main content

开始编辑

以下各节介绍了一些基本概念和开始编辑所用的基本工作流。 有关使用特定工具的详细步骤,请浏览内容列表或通过输入关键字或短语搜索帮助。

打开工程

打开其中包含要创建或编辑的要素的工程。 如果没有工程,请在默认地理数据库中创建新工程并创建要素类,或者在没有工程模板的情况下开始操作并稍后保存您的工作。

  1. 启动 ArcGIS Pro 并根据需要进行登录。

  2. 在开始页面上,请执行以下操作之一:

    • 要打开现有工程,请单击最近的工程 目录视图 ,或单击 打开其他工程 浏览 并浏览到该工程。

    • 要启动新工程,请单击地图工程模板 打开 。

    • 要启动一个新的无标题工程并稍后对其进行保存,请单击 打开 。

    注:

    当在 门户 连接 门户 上打开工程时,将下载工程包 (.ppkx) 并在 <User Documents>\ArcGIS\OnlineProjects 文件夹中解包。 关闭工程后,解包工程文件 (.aprx) 将出现在最近工程列表中。

打开地图并添加数据

打开包含您要编辑的要素的地图。 如果地图不包含您的图层,请进行添加。 将为新图层自动生成具有默认设置的编辑模板。

  1. 单击功能区中的 视图 选项卡。 在 窗口 组中,单击 目录面板 。 目录窗格

    提示:

    要打开与编辑有关的所有窗格,单击 窗格集 重置窗格 ,然后选择 编辑 。

  2. 在 目录 窗格中,右键单击包含要编辑的要素的地图,然后单击 打开 地图视图 。

    • 如果地图不存在,则在 插入 选项卡的 工程 组中,单击 新建地图 新建地图 。
  3. 如果当前地图不包含要编辑的图层,请进行添加。

    1. 在 目录 窗格 目录窗格 中,单击 数据库 数据库 。

    2. 展开包含数据的数据库,或要在其中创建新要素类的默认数据库。

    3. 将要素类拖动到地图上。

      将为新图层自动生成具有默认设置的编辑模板。

  4. 要创建要素类,请完成以下步骤:

    1. 展开并右键单击数据库,然后依次单击 新建 和 要素类 面要素类 。

    2. 输入要素类名称。

    3. 单击 要素类类型 下拉箭头,然后选择要创建的要素几何。

      创建要素类

    4. 单击 下一步 ,然后为想要为每个要素记录的属性添加 字段 。

    5. 单击 下一步 ,然后选择坐标系。

    6. 单击 完成 。

      新要素类即会自动作为图层添加到地图并且不含任何要素,除非进行创建。

更新元数据

元数据 是关于数据的描述性信息,例如记录时间和方式、参与者、使用限制等。 可在 目录 窗格中进行搜索并且可帮助其他人查找数据以及评估是否适用于其作业。

  1. 在 目录 窗格中,右键单击要素类,然后单击 编辑元数据 编辑 。

  2. 在元数据视图中,在必填字段中输入适当的信息。

  3. 在 元数据 选项卡的 管理元数据 组中,单击 保存 保存编辑内容 。

  4. 在 元数据 视图选项卡中,单击 删除 删除 。

符号化图层

符号化要素图层 可将其配置为使用特定符号绘制要素。 创建新要素类并将其添加到地图中会自动生成默认符号。 对于在图层上创建要素的模板,该符号也会显示在 创建要素 窗格中。

  1. 在 视图 选项卡的 窗口 组中,单击 内容 目录 。

  2. 在 内容 窗格中,单击图层。

  3. 要打开 符号系统 窗格并更改符号系统,右键单击图层,然后单击 符号系统 符号系统 。

    提示:

    也可以在 外观 选项卡上找到该命令。

    符号系统

查看和管理可编辑性

创建或修改数据时,将自动为所选图层引用的工作空间启动编辑会话。 保存或放弃编辑内容时,编辑会话会停止。 后续编辑内容会恢复编辑会话,直到保存或放弃编辑内容为止。

您可以在引用可编辑数据源的任何图层上编辑数据。 可以在 编辑状态 对话框 编辑状态 中查看地图或场景中包含的源数据的权限、警告和版本状态。 此对话框位于功能区 管理编辑内容 组中的 编辑 选项卡上。

有关详细信息,请参阅 查看源数据可编辑性 。

有关为引用可编辑源数据的图层启用或禁用图层可编辑性的步骤,请参阅 启用或禁用图层可编辑性 。

注:

如果 ArcGIS Pro 配置为手动启动和停止编辑会话,请参阅 启用或禁用编辑 。

创建要素

在 创建要素 窗格中, 编辑模板 包含用于创建要素的主要工具。 将要素图层添加到地图中时,将自动创建具有默认设置的编辑模板。 单击模板可显示其工具选项板。

  1. 在 编辑 选项卡中,选择捕捉首选项,然后显示 创建要素 窗格。

    1. 在 捕捉 组中,单击 捕捉 下拉菜单 按捕捉列出 ,然后启用您的捕捉首选项。

    2. 在 要素 组中,单击 创建 创建要素 。

      提示:

      要打开与编辑有关的所有窗格,请在 视图 选项卡上的 窗口 组中,单击 窗格集 重置窗格 ,然后选择 编辑 。

  2. 在 创建要素 窗格 创建要素 中,单击编辑模板。

    注:

    创建不可见要素的模板会显示 警告图标 警告 ,其原因包括比例范围设置不匹配、符号系统属性值缺失、定义查询失败等。

    创建要素

  3. 单击 活动模板 按钮 前向 并输入想要应用至要素的属性值。

    提示:

    要保存模板属性值并在下次重用,请单击菜单按钮 菜单 ,然后单击 属性 属性 。

    活动模板

  4. 单击构造工具,或使用默认工具,然后创建要素。

  5. 要完成要素,请单击鼠标右键,然后单击 完成 完成 ,或按 F2 键。

  6. 在 编辑 选项卡的 管理编辑内容 组中,单击 保存 保存编辑内容 。

修改要素

修改要素 窗格包含修改要素的编辑工具。 大多数工具使用指针来以交互方式编辑要素。 其他工具的操作类似于地理处理工具,需要在单击运行按钮之前设置参数。

大多数工具在工具窗格中包含一个选择工具,其中包含与活动工具配合使用的附加功能。 建议您使用该选择工具,而非功能区选项卡中显示的常规选择工具。

  1. 在 编辑 选项卡的 要素 组中,单击 修改 修改要素 。

  2. 单击工具。

    要查找工具,请展开类别或在 搜索 文本框中键入工具名称。

    “修改要素”窗格

  3. 请按照以下特定工具预定的步骤编辑要素。

    提示:

    为了保持重合和重叠要素之间的拓扑邻接,请在当前地图中打开拓扑编辑并使用可以进行拓扑编辑的编辑工具。 只有可见且可编辑的要素图层才会参与地图拓扑。

    有关详细信息,请参阅 地图拓扑 。

  4. 要完成要素,请单击鼠标右键,然后单击 完成 完成 ,或按 F2 键。

  5. 在 编辑 选项卡的 管理编辑内容 组中,单击 保存 保存编辑内容 。