Skip to main content

配置要素模板

要素模板 包括构造工具、属性字段以及用于在特定图层上创建要素的其他可配置属性。 创建要素模板 后,可以在 模板属性 中配置这些设置。

模板属性设置显示在以下选项卡上:

选项卡

描述

常规

用于记录、组织和搜索的模板名称及可选元数据。

工具

显示在工具选项板上的工具设置。

属性

写入新要素和其他字段设置的属性值。

注记

注记要素的设置,包括默认文本字符串、文本符号系统、格式选项以及注记类子类型。

此选项卡仅适用于创建注记要素的模板。

尺寸

尺寸注记要素的设置,包括尺寸注记文本值、角度方向,并覆盖尺寸注记线和其他符号属性的显示设置。

此选项卡仅适用于创建尺寸注记要素的模板。

关系

用于添加表模板以及插入到独立表中的行数的控件和设置。

仅当模板创建的要素作为原点参与具有地图中的目标独立表的关系类时,此选项卡才可用。

包含

用于添加包含模板和非空间要素数量的控件和设置。

仅当模板创建参与包含关联的公共设施网络要素时,此选项卡才可用。

选择模板

在 管理模板 窗格中,选择一个模板并单击 属性 属性 。

  1. 单击功能区上的 编辑 选项卡。 在 管理编辑内容 组中,单击 管理模板 。 管理模板

    或者,在 创建要素 窗格中,单击 管理模板 管理模板 。

  2. 在图层视图中,展开 地图 地图视图 并单击图层以在模板视图中显示模板。

  3. 在模板视图中,单击模板。

  4. 在模板视图工具条中,单击 属性 属性 。

    • 或者,右键单击模板,然后单击 属性 属性 。
    提示:

    如果您目前位于 创建要素 窗格中,请右键单击模板并单击 属性 属性 。 如果 活动模板 视图处于活动状态,请单击 活动模板选项 菜单 ,然后单击 属性 属性 。

显示或隐藏构造工具

单击 工具 选项卡以设置默认工具,然后显示或隐藏出现在工具选项板上的构造工具。 适用于模板的工具取决于模板类型及其创建的要素类型。

  1. 单击 工具 。

  2. 选择一个在单击模板时自动运行的工具。

    1. 将鼠标悬停在默认按钮上以显示屏幕提示 单击以设置为默认工具 。

    2. 单击该按钮,直到其显示为已填充为止。

  3. 选中您想在工具选项板中显示的构造工具。

    1. 将鼠标悬停在工具复选框上以显示屏幕提示 切换工具可见性 。

    2. 选中或取消选中该工具。

指定属性值

单击 属性 选项卡以键入要应用于模板创建的每个要素的属性值。 字段值将随模板一起保存。

注:

此选项卡不适用于创建注记或尺寸注记要素的要素模板。 注记和尺寸要素的自定义字段和属性特性将在其各自的模板选项卡中显示。

  1. 单击 属性 。

  2. 选中或取消选中以下可选字段设置:

    显示不可见字段

    选中此复选框以显示 模板属性 对话框中的所有隐藏字段。

    提示属性值

    选中属性行末尾的复选框以在工具选项板旁边的 创建要素 窗格中显示该字段。

    提示属性值

    提示:

    如果您在创建要素时频繁输入不同的属性值,请启用此选项。 由此即可覆盖模板属性值,而无需单击 活动模板 按钮 前向 。

  3. 单击字段并键入属性值。

    • 如果向字段分配编码属性域,单击下拉箭头,然后选择值。

    • 如果字段用于符号化图层(以紫色高亮显示),单击 选择符号类 添加所有值 ,然后选择值。

    提示:

    将光标悬停在字段名称上查看数据类型、默认地理数据库值和其他字段属性。

    1. 右键单击字段将值设置为 Null 或在源地理数据库中存储的值。 下表介绍了这些命令。

      命令

      描述

      设置为 <空> NULL

      如果字段接受空值,将值设置为 Null。

      恢复 撤消

      将值恢复为上次存储的值。

      获取唯一值

      选择当前在此字段中存储的值。

      清除 重置

      清除值并使用当前地理数据库默认值。

      存储 应用

      将值设置为当前地理数据库默认值。

      当地理数据库默认值发生变化时,此值不会更新。

  4. 单击 确定 。

字段颜色代码

字段边框或填充颜色的外观可指示属性的功能、可编辑性、有效性或其他状态,如下表所示:

字段颜色

描述

橙色阴影

这是子类型字段。

紫色阴影

这将符号化图层。

黄色阴影

在“字段”视图中,“高亮显示”属性已启用。

灰色边框

该字段为只读字段,无法进行编辑。

绿色边界

字段未在使用地理数据库默认值。

蓝色边框

字段正在使用地理数据库默认值。

黄色边框

对于分配给字段的可选 条件值 ,字段值为无效条目。

红色边框

出于以下可能的原因之一,字段值为无效条目:

  • 属性验证 已打开,字段值对于分配给字段的 属性域 无效。

  • 对于分配给字段的必需 条件值 ,字段值为无效条目。

属性字段颜色代码

添加表模板

在 关系 选项卡上,单击 添加 加 以添加表模板。 表模板 可将指定数量的记录(行)插入到现有表中,并将存储的属性值写入指定字段。

注:

仅当要素模板创建的要素作为原点参与具有地图中的目标独立表的 关系类 时,此选项卡才可用。

  1. 如果关系类尚不存在,请创建一个。

    1. 在 视图 选项卡中,单击 目录窗格 目录窗格 ,然后展开 数据库 数据库 。

    2. 右键单击地理数据库或数据集,单击 新建 ,再单击 关系 。

      要了解有关创建关系类的详细信息,请参阅 准备创建关系类 工具。

  2. 单击 关系 。

  3. 添加表模板。

    1. 单击 添加 加 。

      如果源要素地图中仅存在一个表模板,则此表模板会自动添加到模板中。

    2. 单击 选择模板 下拉箭头,然后选择表模板。

    3. 单击 计数 箭头并指定要为每个新要素创建的记录(行)数。

      计数

    4. 单击 添加 。

  4. 要编辑或删除表模板,请将鼠标悬停在模板名称上并单击适用的按钮。

    编辑 可编辑

    更改所选模板的设置。

    删除 删除

    删除所选模板。

  5. 单击 确定 。

添加包含模板

在 包含 选项卡上,添加 添加 加 以添加包含模板。 包含模板 包含指定数量的与模板创建的每个要素相关联的非空间对象。

注:

仅当要素模板创建参与 包含关联 的公共设施网络要素时,此选项卡才可用。

更改注记属性

单击 注记 选项卡以自定义 注记要素类属性 ,包括默认文本字符串、文本符号系统、格式选项以及注记类子类型。

注:

仅当要素模板创建 注记要素 时,此选项卡才可用。

  1. 单击 注记 。

  2. 在文本框中键入默认文本字符串。 默认文本字符串将应用于新注记要素。

  3. 要更改字体类型、样式或文本大小,请单击指定的工具。

  4. 设置注记要素类和符号。

    当注记要素类中包含多个注记类时,这些注记类将显示为子类型。

    1. 单击 AnnotationClassID 字段并设置注记类子类型。

    2. 单击 SymbolID 字段并设置符号编号。

    3. 要在 创建要素 窗格的工具选项板下方显示字段,请选中 提示属性值 。

  5. 单击 确定 。

更改尺寸注记属性

单击 尺寸注记 选项卡以自定义要素模板创建的尺寸注记要素的尺寸注记样式。 可以自定义文本值、角度方向以及尺寸注记线和其他符号属性的显示设置。

注:

仅当要素模板创建 尺寸注记要素 时,此选项卡才可用。

  1. 在 模板属性 对话框中,单击 尺寸注记 。

  2. 请执行以下一项或多项操作来自定义尺寸注记:

    • 展开 文本 以修改或恢复文本值、方位角或放置。

    • 展开 尺寸注记线 以绘制或隐藏尺寸注记线,或更改箭头符号系统。

    • 展开 延伸线 以更改尺寸注记线,并绘制或隐藏延伸线。

  3. 要保存设置并关闭 模板属性 ,请单击 确定 。