Skip to main content

修改网格图层

网格场景图层或 3D 切片图层是连续的网格化表面,用于捕获区域的纹理表面。 您可以将其他 GIS 内容与网格配合使用,而无需重新创建网格。 Google 逼真 3D 底图是一个显示在 Ground 中的网格图层,它在单一全球数据集中同时提供逼真的纹理和高程值。 您可以应用“替换”修改,例如,将建筑物展平并用您自己的 3D 建筑替换它。 网格场景图层和 3D 切片图层支持裁剪、掩膜和替换修改。 对于 Google 逼真 3D 底图等底图,仅支持替换修改。 您可以在整个 ArcGIS 系统中,通过 Web 场景来共享您的修改。

Yosemite 集成网格图层

约塞米蒂国家公园的此网格图层由 Vantor 创建。

对操作网格图层应用修改

可以通过内容窗格中的图层属性或者通过单击数据选项卡修改组中的添加按钮 将修改添加到网格图层。 添加后,修改将显示为内容窗格中网格图层下的子项目。 此修改包含一个具有编码值属性域的名为 Modifier 的面要素,该编码值属性域将定义面是集成网格图层的裁剪、掩膜或替换部分。 在添加修改时,并非直接更改网格图层;而是基于添加的修改中的面进行修改。

可以从现有要素类中导入面。 例如,您可以导入某区域的建筑轮廓多边形,以创建一个场景,比如渲染一个拟建建筑的 BIM 数据集。 在添加修改对话框中选择要素图层之后,可以设置默认的修改运算符,或者如果导入的要素图层具有现有的修改程序字段,则可以选择与导入相同。

您可以通过在属性表中手动编辑 Modifier 字段或者使用计算字段工具来批量更新多个面,以将修改程序应用于现有面。 有关详细步骤,请参阅下方的在属性表中更改修改运算符部分。 您还可以使用数据选项卡上的裁剪操作 、掩膜操作 或替换操作 来创建修改所基于的面。 有关详细步骤,请参阅下方的编辑修改面部分。

对 Google 逼真底图

对 Google 网格图层应用的修改操作,与对操作图层进行修改的操作方式类似。 您可以从内容窗格中的图层快捷菜单中添加修改。 创建图层后,您可以使用编辑选项卡的编辑工具导入面或草绘新面。 此修改包含一个具有编码值属性域字段的名为 Modifier 的面要素图层,该编码值属性域将定义面是否替换 Google 网格图层的一部分。 当您导入一个包含名为 Modifier 的字段的面时,只有编码值为 Replace 的面要素才会应用于 Google 网格图层。 面图层中剩余的所有其他要素将在内容窗格中显示为 all other values。 您可以通过编辑字段或使用计算字段工具来更新多个面,从而更改面属性表中的值。

裁剪

裁剪掉部分网格以查看下方要素,例如,某个区域中关于天然气管线或供水管线的公用事业工作。 规划人员可以创建一个场景,将在该场景中裁剪掉某个位置处的网格,以显示其下方的供水管线或天然气管线。

裁剪修改

掩膜

使用掩膜来定义感兴趣区域。 使用面并仅绘制该面内的网格部分,例如,仅显示城市边界内的网格部分。

掩膜修改

替换

基于 3D 面替换网格区域。 例如,要添加构造的建筑物,请在建筑物覆盖区处展平网格,以便对新建筑物进行可视化。 创建不同的新构造区域方案,并将方案共享为 web 场景以与利益相关者进行讨论。 网格将展平至修改面的最小 z 折点。 该修改适用于 Google 逼真 3D 底图。

替换修改

添加和移除修改

请按照以下步骤在网格中添加或移除修改。

添加修改

请完成以下步骤以添加修改:

  1. 在内容窗格中右键单击网格图层,然后单击修改。

  2. 单击添加修改 。

  3. 在添加修改对话框中,选择新建修改或从现有面要素图层中导入。

    如果您选择导入之前用作修改的要素类,则在选择与导入相同运算符时,场景将重新绘制并应用修改。 对于 Google 网格图层,将仅应用替换修改。

移除修改

请完成以下步骤以移除修改:

  1. 在内容窗格中右键单击网格图层,然后单击修改。

  2. 单击移除修改 。

    随即从集成网格中移除修改并重新绘制该图层。

将面添加到修改

在添加修改对话框上选择新建修改时,将绘制面。 在修改网格图层时,并非直接编辑该网格;而是将修改应用于该网格。 此修改将更改网格的绘制。 要使用面来裁剪、掩膜或替换部分网格,您需要针对特定操作创建面。

  1. 在内容窗格中单击网格图层。

  2. 单击场景图层或 3D 切片图层选项卡集,然后单击数据选项卡。

    注:

    对于 Google 网格图层,请使用编辑选项卡中的创建要素工具。

  3. 在数据选项卡上,选择裁剪按钮 、掩膜按钮 或替换按钮 以打开创建要素窗格。

    借助裁剪工具,您可以基于创建的面的内部来裁剪网格。

  4. 单击裁剪工具以打开裁剪模板。 在指定的高度和位置处创建面。 按下 F2 键或单击完成草图 。

    网格图层将重新绘制并应用修改。

  5. 或者,选择其他工具或编辑模板以向集成网格应用其他操作,例如掩膜或替换。

  6. 单击编辑选项卡上的保存。 关闭内容窗格中的修改以仅查看网格。

编辑修改面

创建面后,可以更改面的形状。 由此可以调整面以拟合新的感兴趣区域。 例如,如果对建筑物进行了平移,则可以将用于替换网格的面移动至建筑物的新位置。 可以按照与编辑任何其他要素图层相同的方式对面进行修改。

  1. 右键单击内容窗格中的修改,然后单击属性 。

  2. 在属性表中,选择要编辑的面所在的行。

  3. 单击编辑选项卡上的修改 。

  4. 在修改要素窗格中选择其中一个编辑工具以更改一个或多个面,例如,编辑折点 。

  5. 按下 F2 键以完成更改。

  6. 单击编辑选项卡上的保存。

  7. 关闭修改图层以仅查看集成网格图层。

在属性表

可以更改应用于网格图层的修改的运算符,例如,要展平区域,而非将其裁剪掉。 运算符保存在修改的属性表中。 要更改运算符,您需要更改属性表中的字段的值。

  1. 在内容窗格中右键单击修改。

  2. 单击属性 。

  3. 在属性表中,选择要更改其运算符的面。

  4. 在 Modifier 字段中,将属性更改为要应用于面的修改,例如,替换或掩膜。

  5. 按 Enter 键以完成更改。

  6. 要完成您的编辑内容,请单击编辑选项卡上的保存。

批量更新修改运算符

您可以使用计算字段工具批量更新多个面的运算符。

  1. 在内容窗格中右键单击修改。

  2. 单击属性 。

  3. 在属性表中,右键单击 Modifier 字段,然后单击计算字段。

  4. 在计算字段工具对话框中,对于字段名称,选择 Modifier 字段。

  5. 对于表达式,使用 0 代表裁剪,1 代表掩膜,2 代表替换。

  6. 单击确定以运行工具。

    使用特定运算符更新 Modifier 字段。

禁用修改

可以在网格图层上启用或禁用修改。 禁用修改仍将显示草绘的面,但不会向网格应用任何修改。

  1. 在内容窗格中右键单击网格图层,然后单击修改。

  2. 单击禁用修改按钮 。

    随即将禁用修改,并且整个网格将进行绘制。

在 web 场景

可以在 web 场景中共享网格图层和修改

无法将修改和网格共享为单独的 3D 图层,它必须共享为 Web 场景。 您共享的修改不能超过 2,000 个。

在 ArcGIS Online 或 ArcGIS Enterprise 中的内容选项卡中,您可以看到新的 Web 场景并在 Scene Viewer 中将其打开。 因为修改是与网格图层共享的,所以只有 3D Web 图层会随 Web 场景一起列出。 可以在 ArcGIS Pro 中通过目录窗格来打开 Web 场景。