Skip to main content

使用符号效果

符号效果是符号的组件,它们仅出于符号目的动态更改要素几何。 效果会添加至符号来生成增强符号描述。 效果可以是全局的,可以作为一个整体应用于符号并影响符号中的所有符号图层,也可以仅应用于单个符号图层。

查看所有可用符号效果的列表

符号效果是符号结构的一部分。 您可以从符号系统窗格格式化符号模式中的结构选项卡 中添加和移除效果以及符号图层。

可以配置效果的属性来自定义符号的外观。 在符号标题下全局添加的效果会成为符号基本属性的一部分。 可以在符号选项卡 上对其进行配置。 添加至各个图层的效果会在图层选项卡 中相应的符号图层中以独立组的形式列出。

当多个几何效果添加到一个符号时,它们会按顺序应用,这样第一种效果的输出几何便能用作下一种效果的输入几何,依此类推。 新效果会始终添加至效果列表的最末端,并且是最后一个应用的效果。 请按照所需的效果应用顺序添加效果,因为它们不能被重新排序。 如有必要,可将效果移除并再次进行添加来保持正确的顺序。

大多数效果仅会改变要素的符号化显示,但有些效果会以其符号化方式切换几何类型。 例如,一个线符号可包含偏移效果,该效果仍将生成使用描边符号系统绘制的线几何。 包含缓冲区效果的线符号具有可使用填充符号图层绘制的动态面几何(缓冲的线)。

为整个符号添加全局效果

完成以下步骤以将全局效果添加到整个符号:

  1. 通过单击地图或场景的内容窗格中的一个符号,或直接以可编辑样式打开一个符号便可访问符号属性。

  2. 在符号系统窗格的属性选项卡上,单击结构选项卡 。

    或者,在目录视图中视图选项卡的选项组中,单击详细信息面板按钮 以查看详细信息窗格中的符号属性。

  3. 单击符号标题下的添加效果可添加将应用于整个符号的全局效果。

  4. 从列表中选择效果。 前面带有警告符号 的效果表示该效果会将符号置于不一致的几何逻辑状态。 如果您正在迭代构建复杂符号,并且将添加更多符号效果或随后调整标记位置,则可能会出现这种情况。 了解有关制图符号几何逻辑的详细信息。

  5. 如有需要,可单击符号选项卡 来调整全局效果的属性。

  6. 单击应用保存更改。

向一个符号图层添加效果

完成以下步骤以仅向符号中的一个符号图层添加符号效果:

  1. 请仅在需要独立地动态更改各符号图层时使用图层效果。 通过单击地图或场景的内容窗格中的一个符号,或直接以可编辑样式打开一个符号便可访问符号属性。

  2. 在符号系统窗格的属性选项卡上,单击结构选项卡 。

    或者,在目录视图中视图选项卡的选项组中,单击详细信息面板按钮 以查看详细信息窗格中的符号属性。

  3. 单击图层标题下任一图层下的添加效果向该图层添加一个效果。 如果您不确定进行哪种操作,可在符号标题下将效果添加为全局效果。 这样产生的符号要比在图层级别产生影响的符号更加简单。 请仅在需要独立地动态更改各符号图层时使用图层效果。

  4. 从列表中选择效果。 前面带有警告符号 的效果表示该效果会将符号置于不一致的几何逻辑状态。 如果您正在迭代构建复杂符号,并且将添加更多符号效果或随后调整标记位置,则可能会出现这种情况。 了解有关制图符号几何逻辑的详细信息。

  5. 如有需要,可单击图层选项卡 来调整效果的属性。

  6. 单击应用保存更改。

移除符号或符号层中的效果

不再需要某符号效果时可将其移除,或对效果进行重新排序。 新效果会始终添加至列表的最底部,所以它们是最后一个应用的效果。

  1. 通过单击地图或场景的内容窗格中的一个符号,或直接以可编辑样式打开一个符号便可访问符号属性。

  2. 在符号系统窗格的属性选项卡上,单击结构选项卡 。

    或者,在目录视图中视图选项卡的选项组中,单击详细信息面板按钮 以查看详细信息窗格中的符号属性。

  3. 找到符号或图层标题下的效果并单击该效果旁边的删除按钮 可将其移除。