Skip to main content

データの管理

通常、ArcGIS Pro では、コンピューターに保存されているプロジェクトで作業を行います。 ただし、プロジェクトを常に保存する必要はありません。 タスクにデータの準備と管理が伴うものの、マップを作成したり解析の問題を解決したりする必要がないこともあります。 このような場合は、プロジェクトを作成せずに ArcGIS Pro を起動できます。 データを処理し、プロジェクトを保存せずにアプリケーションを終了することができます。

概要

  • このビデオは、ArcGIS Pro 3.3 を使用して作成されています。

このチュートリアルでは、ニュージーランドのクライストチャーチ市とその周辺の環境復興プロジェクトに役立つ多数のデータセットを使って作業します。 データを探索し、一般的なファイル形式と空間参照に変換し、分析範囲にクリップして、そのメタデータを更新します。 目標は、ジオデータベースで効率的なデータ コレクションを作成し、同じ地理エリアで関連プロジェクトに取り組んでいる GIS 専門家と共有できるようにすることです。

  • 所要時間: 60 分

  • ソフトウェア要件:

    • ArcGIS Pro Basic
注意:

ソフトウェア リリースごとにクイックスタート チュートリアルが更新されます。 最適なユーザー エクスペリエンスを得るには、お使いのソフトウェアと同じバージョンのオンライン ヘルプを使用します。

データのダウンロード

2011 年 2 月 22 日、マグニチュード 6.2 の地震がニュージーランドのクライストチャーチを襲いました。死者は 185 人に上り、甚大な物的被害が発生しました。 市内でも特に被害が大きかった地域では、住宅やインフラの再建は現実的に考えられないほどでした。

地震による被害

2011 年 2 月 22 日に発生した地震直後の、クライストチャーチの New Brighton 地区の建物を示します。 写真: Martin Luff。 Wikimedia Commons からダウンロードされ、Creative Commons 2.0 ライセンスの下で使用されます。

このような地区には Otakaro Avon River Corridor も含まれており、エイヴォン川から海までを緑歩道やサイクリング ロード、湿原に変える計画が策定されました。 市内および周辺地域でも、生物多様性および復興のプロジェクトが遂行されています。

クライストチャーチ市内および周辺地域での復興プロジェクトに関連するデータをダウンロードします。 データのソースや空間範囲、座標系、ファイル形式はそれぞれ異なります。

  1. ArcGIS Online で、Manage data v330 概要ページに移動します。

  2. ページの右側にある ダウンロード をクリックします。

  3. コンピューターのダウンロード フォルダーで Manage_data_v330.zip を右クリックし、C:\Temp などのわかりやすい場所に展開します。

    注意:

    このチュートリアルは学習用です。 ただし、クライストチャーチ市内および周辺地域で行われている地震復興プロジェクト (Otakaro Avon River Corridor Regeneration Plan など) は実際に行われています。 2011 年の地震に関する情報は、Wikipedia の 2011 Christchurch earthquake 記事など、数多くの情報源から取得できます。

テンプレートなしで ArcGIS Pro を起動する

テンプレートを使用せずに ArcGIS Pro を開始すると、プロジェクトを作成するよう指示されません。 このチュートリアルでは、ジオデータベースでデータを作成および管理するので、作業をプロジェクトとして保存する必要はありません。 必要に応じて、ArcGIS Pro のセッション中にいつでも保存できます。

このチュートリアルでは、デフォルトのアプリケーション設定の一部を使用することを想定しています。 これらの設定を確認し、必要であれば変更します。

  1. ArcGIS Pro を起動して、必要に応じてサイン インします。

  2. 開始ページで 設定 タブ をクリックします。

  3. サイド タブのリストで オプション をクリックします。 オプション ダイアログ ボックスの アプリケーション の下で、一般 をクリックします。

  4. プロジェクトの作成 を展開し、ローカル コンピューターまたはネットワーク コンピューター上 を展開します。 デフォルト データベース の下で、必要であれば プロジェクトごとに新しいデフォルトのジオデータベース をクリックします。

    プロジェクトを作成するためのデフォルトのジオデータベース オプション

  5. オプション ダイアログ ボックスの アプリケーション の下で、メタデータ をクリックします。 必要に応じて、メタデータ スタイル ドロップダウン矢印をクリックし、アイテム説明 をクリックします。

  6. オプション ダイアログ ボックスで、OK をクリックします。

  7. デフォルトのジオデータベース設定を変更した場合は、ArcGIS Pro を一度終了してから再起動します。

  8. 開始ページにある 新規プロジェクト セクションで、テンプレートを使用せずに開始 をクリックします。

    テンプレートを使用せずに開始

    無題で空白のプロジェクトが開きます。 デフォルト テンプレートから作成されたプロジェクトとは異なり、無題のプロジェクトはコンピューターに保存されません。

フォルダー接続の追加

チュートリアル データへのフォルダー接続を追加して、データを参照します。

  1. リボンの 表示 タブをクリックします。 ウィンドウ グループで、ウィンドウ セット をクリックして ジオプロセシング をクリックします。

    これにより、コンテンツ、カタログ、および ジオプロセシング ウィンドウが開き、他のウィンドウが閉じられます。

  2. カタログ ウィンドウをアクティブにし、ウィンドウの上部で プロジェクト タブが選択されていることを確認します。 データベース および フォルダー コンテナーを展開します。

    カタログ ウィンドウ

    テンプレートを使用せずに開始すると、ユーザー プロファイルの一時ディレクトリーにデフォルトのジオデータベースおよびホーム フォルダーが作成されます。

    ヒント:

    一時フォルダーのパスを表示するには、カタログ ウィンドウでデフォルト ジオデータベース (Default.gdb) またはホーム フォルダー (タイトルなし) の上にポインターを置きます。

  3. カタログ ウィンドウで フォルダー コンテナー を右クリックし、フォルダー接続の追加 をクリックします。

  4. フォルダー接続の追加 参照ダイアログ ボックスで、チュートリアル データの場所 (C:\Temp など) を参照します。 Manage_Data フォルダーをクリックして選択します。

    参照ダイアログ ボックスで選択した Manage_Data フォルダー

  5. OK をクリックします。

    カタログ ウィンドウの フォルダー コンテナー の下にフォルダー接続が表示されます。

    注意:

    Supplemental フォルダーへの接続を追加する必要はありません。 アクティブなポータルが ArcGIS Enterprise ポータルの場合、このチュートリアルの後の手順で、このフォルダー内のデータを使用します。それ以外の場合は必要ありません。

  6. カタログ ウィンドウで Manage_Data フォルダーを展開します。

    このフォルダーには、3 つのフォルダー、2 つのジオデータベース、シェープファイルが格納されています。

  7. フォルダーとジオデータベースを展開します。

    カタログ ウィンドウで展開された Manage_Data フォルダー

    このフォルダーには、シェープファイルが格納されています。 各ジオデータベースには、2 つか 3 つのフィーチャクラスが含まれます。

データのプレビュー

このデータのほとんどは、クライストチャーチの復興プロジェクトに関連するものです。 データセットを調べ、さらに詳しく掘り下げていきます。 データとメタデータをプレビューするために、カタログ ビューを開きます。

  1. リボンで、表示 タブが選択されていることを確認します。 ウィンドウ グループで、カタログ ビュー をクリックします。

    カタログ ビューが開きます。 リボン上に カタログ タブが表示されます。 コンテンツ ウィンドウにカタログのコンテンツが表示されます。 これにはプロジェクト内のアイテム、ポータル接続、およびローカルとネットワークのフォルダーが含まれます。

    注意:

    カタログ ビューと カタログ ウィンドウは補完関係にあります。 これらには似た機能がありますが、データのプレビューなどの特定のタスクはカタログ ビューでしか行えません。

  2. コンテンツ ウィンドウ (カタログ ウィンドウではない) の プロジェクト で フォルダー を展開します。 Manage_Data フォルダーを展開して、Planning.gdb をクリックします。

    カタログ ビューのコンテンツ ウィンドウ

    カタログ ビューにジオデータベースのコンテンツが表示されます。 2 つのフィーチャクラス (AvonRiver と PlanArea) があります。

  3. カタログ ビューで PlanArea をクリックします。

    カタログ ビューの詳細パネル

    カタログ ビューの詳細パネルには、選択したフィーチャクラスのメタデータが表示されます。

    ヒント:

    詳細パネルが開いていない場合は、リボンの 表示 タブをクリックします。 オプション グループで、詳細パネル をクリックして選択します。 (このボタンは、カタログ ビューの下部にもあります)。カタログ ビューで、アイテムのリストと詳細パネルの間の垂直区切り線を移動できます。

  4. アイテムのメタデータをスキャンします。

  5. 詳細パネルの上部にある ジオグラフィー タブをクリックします。

    空間データはライト グレーのベースマップ上にプレビューされます。

  6. ジオグラフィー プレビュー上のプラン エリア フィーチャをクリックします。

    フィーチャが点滅し、ポップアップ ウィンドウが表示されます。 ポップアップは、そのフィーチャを Otakaro/Avon River Corridor Regeneration Plan として識別します。 これは、緑歩道、サイクリング ロード、湿原、コミュニティー スペースとなるエリアです。

  7. ポップアップ ウィンドウを閉じます。

    注意:

    ポップアップを閉じると、プレビューが再描画され、フィーチャの色が変更されることがあります。

  8. 詳細パネルの上部にある テーブル タブをクリックし、フィーチャクラスの属性をプレビューします。

    テーブルには、名前とエリア属性を含むレコードがあります。 データセットの詳細を調べるために、そのプロパティを開きます。

  9. カタログ ビューで、PlanArea フィーチャクラスを右クリックして、プロパティ をクリックします。

  10. フィーチャクラス プロパティ ダイアログ ボックスの ソース タブで、空間参照 を展開します。

    フィーチャクラスのプロパティ ダイアログ ボックス

    投影座標系は WGS 1984 Web メルカトル (球体補正) です。 メルカトルなどの世界の投影法は、ローカル データセットにとって理想的ではありません。 後で投影法を変更します。

  11. キャンセル をクリックします。

  12. コンテンツ ウィンドウの Boundaries ジオデータベースをクリックします。 カタログ ビューで CommunityBoards をクリックします。

  13. このフィーチャクラスのメタデータ、ジオグラフィー、テーブルをプレビューします。

  14. CommunityBoards フィーチャクラスのプロパティを開き、空間参照を確認します。

    このフィーチャクラスの投影座標系は、ニュージーランドのマップとデータの標準である NZGD 2000 ニュージーランド横メルカトル図法です。 このチュートリアルの目標の 1 つは、すべてのデータセットをこの座標系にすることです。

  15. キャンセル をクリックします。

  16. 必要であれば、Manage_Data フォルダーのその他のデータセットのいくつかをプレビューします。

マップのデータの探索

マップにデータセットを追加し、さらに探索します。 これは、カタログ ウィンドウで行います。

  1. カタログ ウィンドウで、Manage_Data フォルダーのコンテンツが展開されたままであることを確認します。

  2. Ctrl キーを押しながら、次のデータセットをクリックして選択します。 Parks シェープファイルは選択しないでください。

    • Historic_Places

    • Native_Bird_River_and_Open_Water_Habitat

    • River_Centerlines

    • District_Plan_Zones_Open_Space

    • Flat_Land_Recovery

    • CommunityBoards

    • Districts

    • リージョン

    • AvonRiver

    • PlanArea

  3. 選択したデータセットのいずれかを右クリックし、新しく追加 にポインターを合わせて マップ をクリックします。

    マップという名前のマップ ビューが開きます。 コンテンツ ウィンドウによって、マップ レイヤーが一覧表示されます。

  4. カタログ ウィンドウで、Parks.shp をクリックして選択します。 ドラッグしてマップに追加します。

    データセットを表すレイヤーが含まれているマップ

    レイヤーは別の色でシンボル表示されている場合があります。
  5. コンテンツ ウィンドウの 描画順序 で、マップ をダブルクリックしてマップ プロパティを開きます。

  6. マップ プロパティ ダイアログ ボックスの 一般 タブで、デフォルトのマップ名を Map から Starting Data に変更します。

    マップ プロパティ ダイアログ ボックス

  7. OK をクリックします。

    コンテンツ ウィンドウとマップ ビュー タブにあるマップ名が更新されます。

  8. コンテンツ ウィンドウで、Region レイヤーをクリックして選択します。 コンテンツ ウィンドウの地形図 (World Topographic Map) レイヤーの真上にドラッグします。

    レイヤーをドラッグすると、その位置が水平の細線で示されます。

  9. CommunityBoards レイヤーを Region レイヤーの上にドラッグします。 Districts レイヤーを CommunityBoards レイヤーの上にドラッグします。

    これで、管理区画のレイヤーが他のレイヤーのフィーチャを妨げないようになります。

  10. コンテンツ ウィンドウで、PlanArea レイヤーを右クリックして レイヤーにズーム をクリックします。

    PlanArea レイヤーにズームしたマップ

    復興プロジェクトはプラン エリア外にある場合もありますが、それほど遠くではないでしょう。 対象地域を定義するために役立つデータセットを探します。

  11. コンテンツ ウィンドウで Districts レイヤーを右クリックし、属性テーブル をクリックします。

    Districts レイヤーの各地区は、属性テーブルの行で表されます。

  12. テーブルで、4 番目の行のヘッダー (行の左端にあるグレーの四角形) をクリックして、Christchurch City のレコードを選択します。

    Districts レイヤーの属性テーブル

  13. テーブルの上部にあるツールの行で、ズーム をクリックします。

    マップ上で選択された Christchurch City フィーチャ

    マップ上で Christchurch City フィーチャが選択されています。 この地区は小さいエリアですが、復興地域ではない円形の露出部であるバンクス半島も含まれるため、必要以上に大きく表示されます。

  14. テーブルの上部にあるツールの行で 解除 をクリックします。

  15. Districts テーブルを閉じます。

    他のマップ レイヤーで対象エリアを表すフィーチャを探索することもできますが、ArcGIS Living Atlas of the World を検索します。

ArcGIS Living Atlas of the World からのデータの追加

ArcGIS Living Atlas of the World は、Esri がキュレーションした権威ある地理情報のコレクションです。

注意:

アクティブなポータルが ArcGIS Online ではなく ArcGIS Enterprise である場合、このセクションに追加されたレイヤーは ArcGIS Living Atlas から利用できません。 このメモの手順に従って、ダウンロードしたデータの補足フォルダーから同等のレイヤーを追加してください。

  1. リボンの マップ タブの レイヤー グループで、データの追加 をクリックします。

  2. データの追加 参照ダイアログ ボックスで、コンピューター の下の C:\Temp\Supplemental (またはデータをダウンロードしたディレクトリー) を参照します。

  3. NZ Urban Rural Indicator Areas.lyrx をクリックして選択し、OK をクリックします。

  4. このセクションの手順 6 に進みます。

  1. リボンで、マップ タブがアクティブであることを確認します。 レイヤー グループで、データの追加 をクリックします。

  2. データの追加 参照ダイアログ ボックスで、ポータル の下の Living Atlas をクリックします。

  3. データの追加 参照ダイアログ ボックスの上部にある検索ボックス内をクリックします。 「New Zealand urban areas」と入力して、Enter キーを押します。

  4. 検索結果のリストで、NZ Urban Rural Indicator Areas - Current Web フィーチャ レイヤーをクリックして選択します。

    データの追加参照ダイアログ ボックスの検索結果一覧

    実際の検索結果リストはこれと異なる可能性があります。レイヤーを見つけるため下にスクロールすることが必要な可能性があります。
  5. OK をクリックします。

    Web レイヤーがマップに追加されます。

  6. クライストチャーチの市街地に拡大します。これは、ビュー中心の、大きなオレンジ色の部分です。

    クライストチャーチの市街地

  7. コンテンツ ウィンドウで NZ Urban Rural Indicator Areas レイヤーが選択されていることを確認します。

  8. リボンの マップ タブの ナビゲート グループで、マップ操作 ツール のドロップダウン矢印をクリックして、コンテンツで選択 をクリックします。

    マップ操作ツールと設定のドロップダウン リスト

    ここで、マップ フィーチャをクリックすると、コンテンツ ウィンドウで選択されたレイヤー (1 つまたは複数) の情報が ポップアップ ウィンドウに表示されます。

  9. マップ上で、クライストチャーチ市街地の任意の場所をクリックします。

    マップ上でフィーチャが点滅します。 ポップアップ ウィンドウに、フィーチャがクライストチャーチの市街地を表す旨が表示されます。 このフィーチャを使用して、分析範囲を定義します。

    ポップアップ ウィンドウ

  10. ポップアップ ウィンドウを閉じます。

    チュートリアルではこのレイヤーを操作するので、簡単な名前を付けます。

  11. コンテンツ ウィンドウで NZ Urban Rural Indicator Areas レイヤーをダブルクリックして、プロパティを開きます。

  12. レイヤー プロパティ ダイアログ ボックスの 一般 タブで、既存の名前を Urban Area に変更します。

    レイヤー プロパティ ダイアログ ボックスの一般タブ

  13. OK をクリックします。

    レイヤー名が コンテンツ ウィンドウで変更されます。

  14. マップ操作 ツール のドロップダウン矢印をクリックして、最上位レイヤー をクリックします。

    これがツールのデフォルト設定です。

新しいフォルダーでのジオデータベースの作成

開始データを処理する際、出力データセットを新しいフォルダーの新しいジオデータベースに保存します。 作成するデータのデフォルトの場所として、このジオデータベースを作成します。 最終的には、このジオデータベースとフォルダーを、クライストチャーチの復興プロジェクトに取り組んでいる GIS 専門家と共有する予定です。

  1. カタログ ビュー (カタログ ウィンドウではない) をアクティブにします。

  2. コンテンツ ウィンドウの プロジェクト で、データベース コンテナー を右クリックし、新しいファイル ジオデータベース をクリックします。

  3. 新しいファイル ジオデータベース 参照ダイアログ ボックスで、チュートリアル データを抽出したフォルダー (たとえば、C:\Temp など) を参照します。 フォルダーをダブルクリックして開きます。

    Manage_Data と Supplemental フォルダーがリストに表示されます。 新しいジオデータベースを保存する別のフォルダーを作成します。 この別のフォルダーは、ジオデータベースの作成プロセス中に作成できます。

  4. 参照ダイアログ ボックスで 新しいアイテム ドロップダウン矢印をクリックし、フォルダー をクリックします。

    新しいアイテム ドロップダウン メニューが選択された参照ダイアログ ボックス

    新しいフォルダーが作成されます。 デフォルト名は編集できます。

  5. フォルダーの名前を ChristchurchRenewal に変更し、Enter キーを押します。

    新しいフォルダーが選択されます。

  6. 開く をクリックし、ChristchurchRenewal フォルダーを開きます (フォルダーは空です)。

  7. ダイアログ ボックスの下部にある 名前 テキスト ボックスに、新しいジオデータベースの名前として「ChristchurchData」と入力します。 保存 をクリックします。

    新しいジオデータベースが作成され、プロジェクトに追加されます。

  8. コンテンツ ウィンドウで データベース コンテナー をクリックします。

    カタログ ビュー内で、起動時にテンプレートを使用せずに作成されたデフォルト ジオデータベースの下に、新しいジオデータベースが表示されます。

    デフォルト ジオデータベース (ホーム アイコン のマークが付けられている) には、ジオプロセシングのほとんどの出力が保存されます (他の場所が指定されている場合は除く)。 どのジオデータベースもデフォルト ジオデータベースとして設定できます (現在のデフォルト ジオデータベースの名前が Default.gdb であることは重要ではありません)。

  9. カタログ ビューで ChristchurchData.gdb をクリックして選択します。

  10. リボン上の 管理 タブをクリックします。 プロジェクト グループで、デフォルトに設定 をクリックします。

    これで、ホーム アイコンが ChristchurchData ジオデータベースに表示されます。

データをクリップし、新しいジオデータベースに保存

ペアワイズ クリップ ジオプロセシング ツールを使用し、Manage_Data フォルダーのほとんどのデータをクライストチャーチの市街地にクリップします。 ツールはバッチ ツールとして実行します。これによって、1 回の操作で複数の入力データセットを処理できます。 新しい出力データが ChristchurchData ジオデータベースに保存されます。 入力シェープファイルは、ジオデータベース形式に自動的に変換されます。

フィーチャをクリップすると、そのジオメトリーが変わります。 たとえば、クライストチャーチ市街地の境界をまたぐ川は、境界で分割されます。 境界の内部にあるセグメントだけが保持されます。

前述のように、出力データをニュージーランド横メルカトル図法座標系にしたいとします。 ペアワイズ クリップ ツールを実行する前に、入力データセットを必要に応じてこの座標系に投影するためのツール環境設定を行います。

  1. Starting Data マップ ビューをアクティブにします。

  2. コンテンツ ウィンドウで Urban Area レイヤーを右クリックして 選択 にポインターを合わせ、このレイヤーのみ選択可能にする をクリックします。

  3. リボンの マップ タブの 選択 グループで、選択 をクリックします。 マップ上で、クライストチャーチ市街地のフィーチャをクリックして選択します。

    クライストチャーチ市街地を選択した状態

    ペアワイズ クリップ (Pairwise Clip) ツールを実行する際、Urban Area レイヤーをクリップ レイヤーとして指定します。 ツールは、選択したフィーチャをクリップ範囲として使用します。

  4. ジオプロセシング ウィンドウをアクティブにします。 検索ボックスに「pairwise clip」と入力します。

    検索結果に、ペアワイズ クリップ (Pairwise Clip) が最初の検索結果としてリストされます。

    ペアワイズ クリップ ツール

    ヒント:

    ツールの表示を変更するには、ジオプロセシング ウィンドウの下部にある 説明と詳細付きでツールを表示 または ツールをリストで表示 をクリックします。

  5. 検索結果で ペアワイズ クリップ ツールを右クリックし、バッチ をクリックします。

    バッチ ペアワイズ クリップ (Batch Pairwise Clip) ツールが開きます。 ほとんどのジオプロセシング ツールは、バッチ ツールとして実行できます。 バッチ ツールはデフォルトでは一時的ですが、バッチ ツールを保存して永続的なツールにすることができます。

  6. バッチ パラメーターの選択 で 入力フィーチャ が選択されていることを確認します。 開いているマップに出力データセットを追加 チェックボックスをオフにします。

    バッチ ペアワイズ クリップ ツール

    ツールを実行した後に、出力データセットを新しいマップに追加します。

  7. 次へ をクリックします。

  8. バッチ入力フィーチャ の横にある 複数追加 をクリックします。 検索バーの横の すべてのチェックボックスの切り替え チェックボックスをオンにします。

    すべてのレイヤーが選択されている、バッチ入力フィーチャのドロップダウン リスト

    マップに含まれるすべてのレイヤーが選択されます。 ただし、すべてのレイヤーをクリップするわけではありません。 境界レイヤーの領域を保持しておく必要があるため、個別に処理します。

  9. レイヤーのリストで、次のレイヤーのチェックボックスをオフにします。

    • Districts

    • CommunityBoards

    • リージョン

    一部のレイヤーが選択解除されている、バッチ入力フィーチャのドロップダウン リスト

    Urban Area レイヤーは、クリップされる入力フィーチャに含まれており、選択された独自のフィーチャにクリップされます。

  10. ドロップダウン リストの下部で、追加 をクリックします。

    レイヤー内に選択があるため、Urban Area の下に切り替えボタンが表示されます。 デフォルトでは、選択したレコードのみが処理されます。

  11. クリップ フィーチャ でドロップダウン矢印をクリックし、Urban Area を選択します。

    バッチ ペアワイズ クリップ ツールのクリップ フィーチャ パラメーター

    Urban Area レイヤーの下に、切り替えボタンが再び表示されます。

  12. 出力フィーチャクラス ボックスで、出力フィーチャクラス名の接頭辞 PairwiseClip_OutFeatureClass_ を削除して、%Name% 変数を残しておきます。

    注意:

    出力ジオデータベースへのパス全体を削除しないでください。 削除したパスはバッチ ツールの実行時に正しく再生成されないことがあります。

    出力フィーチャクラス パスが、デフォルト ジオデータベースである ChristchurchData ジオデータベースに移動します。

    バッチ ペアワイズ クリップ ツールのパラメーター

    %Name% 変数は、入力レイヤー名を出力データセットに割り当てます。 出力データは入力データとは異なる場所に保存されるため、命名の競合を回避するためのファイル名の接頭辞 (PairwiseClip_OutFeatureClass_ など) は必要ありません。

    座標系が異なるマップ レイヤーは、リアルタイム投影法によって空間的に配置されますが、出力データは NZGD 2000 ニュージーランド横メルカトル図法座標系で作成します。 必要に応じ、入力データセットをこのシステムに投影する環境設定を行います。

    ジオプロセシング環境設定はツールに組み込まれていないパラメーターですが、ツールの実行時に出力データに適用できます。 この場合、環境設定を使用するほうが、Web メルカトル座標系のデータセットに対して 投影変換 ツールを実行するよりも効率的です。

  13. バッチ ペアワイズ クリップ ツールの上部にある 環境 タブをクリックします。

  14. 出力座標 の下、出力座標系 の横にある 座標系の選択 をクリックします。

  15. 出力座標系 ダイアログ ボックスの 利用可能な座標系 セクションで、レイヤー を展開します。

    マップのレイヤーで使用されている 2 つの座標系がリストされます。

  16. NZGD 2000 New Zealand Transverse Mercator をクリックして選択します。

    座標系ダイアログ ボックス

  17. OK をクリックします。

    Web メルカトル座標系の入力データセット (PlanArea など) をクリップすると、ニュージーランド横メルカトル図法で投影されます。

  18. 地理座標系変換 入力ボックスに、「NZGD_2000_To_WGS_1984_1」と入力するか、コピーして貼り付けます。 Enter キーを押します。

    バッチ ペアワイズ クリップ ツールの出力座標の環境設定

    この地理 (測地基準) 変換によって、データセットは可能な限り正確に投影されます。

  19. ジオプロセシング ウィンドウで 実行 をクリックします。

    ツールの実行が完了すると、ウィンドウの下部に、完了を通知するメッセージが表示されます。

クリップされたデータの表示

ChristchurchData ジオデータベースの出力データセットを調べて、新しいマップに追加します。

  1. カタログ ビューをアクティブにします。

  2. コンテンツ ウィンドウの プロジェクト で、必要であれば データベース を展開します。 ChristchurchData.gdb をクリックします。

    ジオデータベースのコンテンツ

    カタログ ビューで、ジオデータベース内に 9 つのフィーチャクラスがあることがわかります。

  3. カタログ ビューで、PlanArea フィーチャクラスをクリックして選択します。 選択したフィーチャクラスを右クリックし、プロパティ をクリックします。

  4. フィーチャクラス プロパティ ダイアログ ボックスの ソース タブで、空間参照 を展開します。

    フィーチャクラス プロパティ ダイアログ ボックスの空間参照情報

    データセットは、ジオプロセシング環境設定で指定されたニュージーランド横メルカトル図法座標系に投影されています。

  5. キャンセル をクリックします。

  6. AvonRiver フィーチャクラスをクリックして選択します。 Shift キーを押したまま、Urban_Area をクリックして、すべてのフィーチャクラスを選択します。

  7. 選択したフィーチャクラスを右クリックして、新しく追加 > マップ の順にクリックします。

    マップという名前の新しいマップ ビューが表示されます。

  8. コンテンツ ウィンドウで、マップ をダブルクリックしてマップ プロパティを開きます。

  9. マップ プロパティ ダイアログ ボックスの 一般 タブで、名前を Map から Final Data に変更します。 OK をクリックします。

    コンテンツ ウィンドウとマップ ビュー タブにあるマップ名が更新されます。

  10. Final Data マップの コンテンツ ウィンドウで、Urban_Area レイヤーを地形図 (World Topographic Map) ベースマップ レイヤーの真上にドラッグします。

    クリップされたレイヤーを含む新しいマップ

    実際のシンボルの色はこれとは異なる可能性があります。
  11. マップをズーム アウトして、すべてのレイヤーがクライストチャーチ市街地の範囲にクリップされていることを確認します。

マップ レイヤーのコピーと貼り付け

ペアワイズ クリップ (Pairwise Clip) ツールを実行した際、領土保全を維持したかったため境界レイヤーは処理しませんでした。 ただし、これらのレイヤーは、カンタベリー地域の必要以上に大きな領域を網羅しています。

これらのレイヤーを Final Data マップにコピーします。 次のセクションでは、保持するレイヤーからフィーチャを選択し、ChristchurchData ジオデータベースにエクスポートします。

  1. Starting Data マップ ビューをクリックしてアクティブにします。

  2. Ctrl キーを押します。 コンテンツ ウィンドウで、Urban Area レイヤーをクリックして選択解除します。 Ctrl キーを押したまま Districts レイヤーと CommunityBoards レイヤーをクリックして選択します。

    Region レイヤーはそのままにしておきます。 カンタベリー地域を表す単一のフィーチャが含まれますが、必要以上に大きすぎます。

  3. リボンで、マップ タブの クリップボード グループにある コピー をクリックします。

  4. Final Data マップ ビューをアクティブにします。

  5. コンテンツ ウィンドウの描画順序の一番上で、Final Data マップをクリックして選択します。

  6. リボンで、マップ タブの クリップボード グループにある 貼り付け をクリックします。

    描画順序の一番上に 2 つのレイヤーが貼り付けられます。 これ以後、Starting Data マップで作業する必要はありません。

  7. Starting Data マップ ビューをアクティブにします。 ビュー タブの 閉じる をクリックします。

    Final Data マップがアクティブ ビューになりました。

    注意:

    これ以後も、Starting Data マップはプロジェクトの一部です。 カタログ ウィンドウの マップ コンテナー 、またはカタログ ビューの コンテンツ ウィンドウから再度開くことができます。

位置でフィーチャを選択して選択をエクスポートする

復興プロジェクトは地方の政治管轄区の対象となる可能性があるため、これら 2 つの境界レイヤーは最終データに関連しています。

CommunityBoards レイヤーと Districts レイヤーで、クライストチャーチ市街地と共通するエリアを持つフィーチャの空間選択を行います。 選択したフィーチャを、ChristchurchData ジオデータベースにエクスポートします。

  1. リボンの マップ タブの 選択 グループで、空間条件で選択 をクリックします。

    空間条件で選択 ツールが開きます。 選択するフィーチャは、入力フィーチャ パラメーターで指定します。 Districts レイヤーは、すでに入力フィーチャのリストに含まれています。

    注意:

    便宜上、一部のジオプロセシング ツールはフローティング ウィンドウで開きます。 これらのツールは、ジオプロセシング ウィンドウで開くこともできます。

  2. リレーションシップ パラメーターが インターセクト に設定されていることを確認します。

  3. 選択フィーチャ の下でドロップダウン矢印をクリックし、Urban_Area を選択します。

    空間条件で選択パラメーター

  4. 適用 をクリックします。

    地区レイヤーのフィーチャは、市街地と交差している場合、マップ上で選択されます。 マップ ビューの下部にあるステータス バーを見ると、2 つのフィーチャが選択されていることがわかります。

    空間条件で選択 ツールの下部にある 選択のエクスポート ボタンが有効になります。

  5. 空間条件で選択 ツールで、選択のエクスポート をクリックします。

    出力データセット の閲覧ダイアログ ボックスが表示されます。 出力場所は、デフォルト ジオデータベースである ChristchurchData ジオデータベースがデフォルトになります。

  6. 出力データセット の参照ダイアログ ボックスの 名前 入力ボックスに、「Urban_Area_Districts」と入力します。

    出力データセットの参照ダイアログ ボックス

    参照ダイアログ ボックス上部のロケーション バーに出力パスが表示されます。
  7. 保存 をクリックします。

    2 つのフィーチャから構成される、新しい Urban_Area_Districts レイヤーがマップに追加されます。

  8. 空間条件で選択 ツールは開いたままにしてください。 リボンの マップ タブの 選択 グループで、選択解除 をクリックします。

  9. 空間条件で選択 ツールで、現在は Districts に設定されている 入力フィーチャ のドロップダウン矢印をクリックし、CommunityBoards をクリックします。 その他の設定はそのままにしておきます。

    空間条件で選択ダイアログ ボックスの入力フィーチャパラメーター

  10. 適用 をクリックします。

    CommunityBoards レイヤーの 8 つのフィーチャが選択されます。

  11. 空間条件で選択 ツールで、選択のエクスポート をクリックします。

  12. 出力データセット の参照ダイアログ ボックスの 名前 入力ボックスに、「Urban_Area_CommunityBoards」と入力します。 保存 をクリックします。

    Urban_Area_CommunityBoards レイヤーがマップに追加されます。

  13. 空間条件で選択 ツールで 閉じる をクリックします。

  14. リボンの マップ タブの 選択 グループで、選択解除 をクリックします。

  15. コンテンツ ウィンドウで Ctrl キーを押します。 Urban_Area_CommunityBoards レイヤーをクリックして選択を解除します。 元の Districts レイヤーと CommunityBoards レイヤーをクリックして選択します。

  16. 選択したレイヤーのいずれかを右クリックして、削除 をクリックします。

  17. コンテンツ ウィンドウで、Urban_Area_Districts レイヤーを World Topographic Map レイヤーの真上にドラッグします。

  18. Urban_Area_CommunityBoards レイヤーを Districts レイヤーの上にドラッグします。

  19. Urban_Area_Districts レイヤーを右クリックし、レイヤーにズーム をクリックします。

    Districts にズームしたマップ

    どちらのレイヤーもクリップされていないため、クライストチャーチの市街地よりはるか外側に延長されています。 ただし、市街地と交差するフィーチャだけが含まれています。

  20. カタログ ビューをアクティブにします。 ロケーション バーの横で、更新 をクリックします。

    ChristchurchData ジオデータベースのフィーチャクラスが表示されているカタログ ビュー

    これで、ChristchurchData ジオデータベースに、新しい Urban_Area_CommunityBoards および Urban_Area_Districts フィーチャクラスが含まれます。

メタデータの更新

Manage_Data フォルダーの入力データセットのメタデータが、ChristchurchData ジオデータベースの新しいデータセットにコピーされました。 メタデータを見直し、スペル エラーを修正して、アイテム説明を更新します。 また、メタデータに表示されるサムネイル画像も作成します。

  1. カタログ ビューで Native_Bird_River_and_Open_Water_Habitat フィーチャクラスを右クリックし、メタデータの編集 をクリックします。

    メタデータ ビューが開きます。 いくつかの単語の下に赤い波線が表示されます。 これには、スペル エラー、不明な技術用語、珍しい地名などが含まれます。

    注意:

    赤い波線が引かれていない場合は、スペルチェックを有効にする必要があります。

  2. メタデータ ビューをスクロールします。

    説明 フィールドに、スペル ミスが 2 つ並んでいます。

    スペル ミスのあるメタデータ

  3. 1 つ目のミス (acommpany) を右クリックし、修正候補 accompany をクリックします。

    ミスが修正され、赤い下線がなくなります。

  4. 同様に、2 つ目のスペル ミス Emvironment を Environment に修正します。

    説明 フィールドの下部に、元のソース データに対する変更点を説明する箇条書きが表示されます。

  5. 説明 フィールドのテキスト末尾をクリックし、Enter キーを押して、2 つ目の箇条書きを追加します。

  6. 次の文を入力するか、コピーします:「データはジオデータベース形式に変換され、クライストチャーチ市街地にクリップされました。Enter キーを押します。

  7. 3 つ目の箇条書きに、次の文を入力するか、コピーして貼り付けます:「一部のデータセットは Web Mercator からニュージーランド横メルカトル図法に投影されました。」

  8. リボンの メタデータ タブの メタデータの管理 グループで、保存 をクリックします。

  9. メタデータ ビューを閉じます。

  10. カタログ ビューで、必要に応じ、詳細パネルにある メタデータ タブをクリックします。

    説明のスペル エラーは修正されています。 追加したメモが説明の下部に表示されます。

  11. 詳細パネルにある ジオグラフィー タブをクリックします。

    データはライト グレーのベースマップ上にプレビューされます。

  12. リボン上の プレビュー タブをクリックします。 プレビュー グループで、ベースマップ をクリックして 海洋図 をクリックします。

    ジオグラフィー プレビューでベースマップが変更されます。

  13. サムネイル グループで 作成 をクリックします。

  14. 詳細パネルにある メタデータ タブをクリックします。

    メタデータとサムネイル

    アイテム説明にサムネイルが追加されます。

  15. 必要に応じて、アイテム説明を編集して、他のデータセットのサムネイル画像を作成することもできます。

    注意:

    Urban_Area フィーチャクラス以外のすべてのデータセットにはメタデータがあります。 NZ Urban Rural Indicator Areas - Current Web レイヤーからメタデータをインポートするには、次の手順に従います。

    1. カタログ ビューで Urban_Area フィーチャクラスを選択します。 リボンの カタログ タブの メタデータ グループで、インポート をクリックします。

    2. メタデータのインポート ダイアログ ボックスで、メタデータ ソース パスを参照 をクリックします。

    3. 参照ダイアログ ボックスの ポータル で Living Atlas をクリックし、NZ Urban Rural Indicator Areas - Current を検索します。

    4. そのレイヤーをクリックして選択し、OK をクリックします。 レイヤーの URL が メタデータのインポート ダイアログ ボックスに追加されたことを確認します。

    5. OK をクリックして、メタデータをインポートします。

    テンプレートを使用せずに開始したので、プロジェクト ファイルはコンピューターに保存されませんでした (自分でプロジェクトを保存していない限り)。 作業用のマップは、データの探索やツールの入力レイヤーの選択には便利でしたが、保存しておく必要はありません。

  16. リボンの プロジェクト タブをクリックします。 サイド タブのリストで 終了 をクリックします。 変更を保存するよう求められたら いいえ をクリックします。

    これで ChristchurchData ジオデータベースが完成しました。 ジオデータベースが (追加したいドキュメントや README ファイルとともに) 格納された ChristchurchRenewal フォルダーを復興チームと共有する準備が整いました。 フォルダーは、ネットワークに配置したり、標準のファイル共有方式で分配することができます。 また、.zip ファイルとして ArcGIS Online にアップロードすることも可能です。