Skip to main content

编辑要素属性

属性 窗格 属性 的 选择 选项卡用于编辑在选择视图中突出显示的要素的属性值及相关记录。 当右键单击选择视图中的字段或项目时,将在快捷菜单中显示其他命令。 此窗格位于功能区 编辑 选项卡的 选择 组中。

当右键单击选择视图中的字段或项目时,将在快捷菜单中显示其他编辑命令。 单击选择视图中的图层时,将显示图层上所有选定要素的属性并将相同值应用于图层上所有要素的属性字段。

使用“属性”窗格时,注意以下事项:

有关使用 图层 选项卡的步骤,请参阅 逐步浏览图层上的要素 。

编辑属性和相关记录

可以使用 选择 工具 选择 在地图上选择要素,单击并在选择视图中突出显示这些要素,并在 属性 选项卡上编辑属性值。 要追踪存储在字段中的超链接,请按下 Ctrl 键并单击字段中的文本。

  1. 单击功能区的 编辑 选项卡,然后单击 选择 组中的 属性 属性 。

    除此之外,还可以使用以下方法之一:

    • 在 内容 窗格的 按选择列出 选项卡 按选择列出 中,右键单击图层,然后单击 属性 属性 。

    • 在功能区 地图 选项卡的 选择 组中,单击 属性 属性 。

    • 按下 Ctrl+Shift+T 。

    随即出现 属性 窗格。

  2. 单击 属性 窗格中的 选择 选项卡。

  3. 单击 选择一个或多个要素 工具 选择 并选择要素。

    如果要素当前处于选中状态,则选择工具显示 更改选择 。

    要细化选择视图中的已选内容,右键单击要素或图层,然后单击 取消选择 清除已选择 或 仅选择此项 按选择列出 。

    注:

    如果选择被编辑工具过滤,窗格中将显示提示 活动编辑工具正在过滤选择内容。 请停用工具,恢复选择 信息 。 要重置选择内容,请按 Esc 键来禁用活动工具或单击 选择 工具 选择 并进行新的选择。

    所选要素将在选择视图中以可折叠列表的形式显示。

  4. 在选择视图中,单击包含正在编辑的属性的要素或非空间对象。

    如果在相关图层或表旁边出现 警告 图标 警告 ,需单击所选记录,并在窗格中编辑属性字段,或右键单击并选择 添加到地图 添加数据 。

    或者,要编辑多个要素的相同属性字段并应用相同的值,请使用以下方法之一:

    • 按住 Ctrl 键同时单击要素。

    • 要编辑一系列要素的属性,请按下 Shift 并单击所选内容中的第一个和最后一个要素。

    • 要编辑同一图层上所有要素的属性,请单击图层名称。

    “属性”窗格

    在选择视图中突出显示的项目的属性字段将显示在 属性 选项卡的属性视图中。 它们的外观由存储在图层上的字段属性决定,例如可见性、只读性和高亮设置。

  5. 单击 自动应用 切换按钮 自动应用 并将其打开或关闭。

    开

    按 Enter 键或者在字段外单击指针焦点时,自动应用编辑内容。 此设置用于禁用 应用 和 取消 按钮。

    关

    需要手动应用或取消编辑内容。 此设置用于启用 应用 和 取消 按钮。

    如果此按钮已禁用且无法更改,请咨询您的系统管理员。

  6. 单击 属性 选项卡。

    如果所选属性存储在属性关系表中,请单击 属性关系 选项卡。

  7. 单击字段以编辑其值,然后按 Enter 键。

    或者,右键单击字段并选择以下命令之一:

    命令

    描述

    设置为 <空> NULL

    如果字段接受空值,将值设置为 Null。

    恢复 撤消

    将值恢复为上次存储的值。

    获取唯一值

    选择当前在此字段中存储的值。

    清除 重置

    清除值并使用当前地理数据库默认值。

    如果字段为日期字段,单击字段,然后单击 日历 日历 。 要输入当前日期和时间,单击 今天 。

    提示:

    将光标悬停在字段名称上查看数据类型、默认地理数据库值和其他字段属性。

  8. 如果 自动应用 已关闭,请单击 应用 按钮。

    如果出现 属性 对话框,请单击 应用 或 放弃 。

    注:

    如果关闭 自动应用 并且在字段包含未提交的编辑内容时更改选择,则 属性 对话框 要求应用或取消编辑内容。 可以将其配置为始终显示或从不显示,并静默应用或放弃属性编辑内容。

    要更改对话框上的设置,请选中 记住选择,不再显示此消息 复选框,然后单击 应用 或 放弃 。

    未提交的属性编辑内容

    如果某个属性字段被属性规则引用,则在应用编辑时,结果计算将始终在源工作空间进行评估。 此外,您还可以选择是否在当前地图中使用 从应用程序评估中排除 设置进行本地评估。

    要更改此设置,请在 内容 窗格中右键单击图层,单击 数据设计 > 属性规则 。 要了解详细信息,请参阅 评估属性规则 。

    此可选设置在下表中进行了说明:

    选中

    在窗格中进行的编辑在应用到工作空间之前不会触发属性规则。

    未选中

    在窗格中的编辑会立即在地图中触发属性规则,并在编辑被应用到工作空间时生效。

    提示:

    如果属性规则更新了字段值,并且该规则也引用了所更新的字段,请选中此设置,排除该规则在地图中的本地评估。

查找并更正无效值

要查找并更正无效属性值,请在选择视图中右键单击图层,然后单击 仅选择无效对象 仅选择无效对象 。 此命令可用于存在数据规则(包括 属性规则 和其他地理数据库行为,例如属性域)的图层。

仅选择无效对象

注:

默认情况下,如果某个值违反了属性规则,则窗格顶部将会出现一条通知,以显示阻止您的更改的规则。

如果您的工作流需要能够覆盖值(例如属性域值或不允许为空值或空字段值的字段),请 关闭属性验证 。

编辑子类型和属性域值

要编辑 子类型 或 属性域值 ,请单击字段下拉箭头并选择一个值。 如果子类型字段正在对图层进行符号化,请单击 选择符号类 按钮 添加所有值 以更改符号系统。

如果新子类型定义的默认属性值与当前默认值不同,则会出现以下警告:

更改子类型

单击 是 以应用由新子类型定义的默认属性值。 如果字段没有对应新子类型的相关默认值,则该字段的值将保持不变。 单击 否 以保留现有要素属性值。

提示:

如果您的工作流要求您始终应用默认值,您可以 关闭子类型警告 并自动将新子类型定义的默认值应用于所有子类型变更。

字段颜色代码

字段边框或填充颜色的外观可指示属性的功能、可编辑性、有效性或其他状态,如下表所示:

字段颜色

描述

橙色阴影

这是子类型字段。

紫色阴影

这将符号化图层。

黄色阴影

在“字段”视图中,“高亮显示”属性已启用。

灰色边框

该字段为只读字段,无法进行编辑。

绿色边界

字段未在使用地理数据库默认值。

蓝色边框

字段正在使用地理数据库默认值。

黄色边框

对于分配给字段的可选 条件值 ,字段值为无效条目。

红色边框

出于以下可能的原因之一,字段值为无效条目:

  • 属性验证 已打开,字段值对于分配给字段的 属性域 无效。

  • 对于分配给字段的必需 条件值 ,字段值为无效条目。

属性字段颜色代码

编辑条件值

要编辑条件值,请单击该字段并在下拉列表中选择一个值。 如果 在属性表中启用 了 自动更新 ,则在遇到唯一组合时,参与条件字段中的值会自动更新。

条件值将用作 属性域 的不严格约束的查找字段。 参与字段将被定义为一个组,其中在一个字段中指定一个值将确定其他字段的下一组有效选项。

提示:

要 创建和管理条件值 ,请打开源属性表,然后单击功能区上的 数据 选项卡。 在 设计 组中,单击 条件值 条件值 。

  1. 在 编辑 功能区选项卡上,单击 选择 组中的 属性 属性 。

    随即出现 属性 窗格。

  2. 在 属性 窗格中,单击 选择 选项卡然后选择要素。

    1. 单击 选择 工具 选择 并选择使用条件属性值定义的要素。

    2. 在选择视图中,单击该要素。

  3. 单击 属性 选项卡。

  4. 单击并关闭 自动应用 自动应用 。

  5. 单击字段并在下拉列表中选择一个值。

    所指定的值将过滤其他条件字段中的值列表,以显示有效组合。 具有错误值的字段将以垂直黄条高亮显示,并在窗格中显示警告消息。

    建议您从值等级的顶部开始,并选择属于有效选项的后续字段中的值。 此外,可以单击下表中介绍的控件,这些控件将根据可用组合情况显示在下拉列表中。

    显示匹配

    将基于字段的主字段值来显示该字段的所有有效选项。 这是默认设置。 单击 显示全部 时,此控件将显示在下拉列表的顶部。

    部分匹配

    显示根据匹配字段分组的属性域值。 此控件支持您创建部分匹配,而此类匹配仍然是与行的条件字段的子集之间的有效组合。 其他字段可能需要进一步编辑,直到获得有效组合为止。

    显示全部

    显示该字段的所有属性域值,其中包括已停用和无效的组合。 您可通过此控件创建完全不同的值组合。 单击 显示匹配 时,此控件将显示在下拉列表的底部。

    属性窗格条件值

  6. 单击 应用 以应用更改。

使用剪贴板复制和粘贴属性

要使用剪贴板复制粘贴属性值,请右键单击选择视图中的要素,然后单击 复制属性 复制 。

当复制粘贴属性值时,请注意以下事项:

  • 默认情况下,系统会将值粘贴到具有匹配数据类型的匹配字段名称中,或粘贴到由当前 字段映射 设置定义的字段中。

  • 要通过单击地图中的源要素和目标要素 在要素间传递属性 ,请使用 传递属性 工具 传递属性 。

  • 要将属性复制粘贴到除了 ArcGIS Pro 之外的应用程序, 请以交互方式选择表中的记录 ,然后单击属性表工具栏上的 复制 复制 。

注:

要复制坐标值,请单击 几何 选项卡。 选择行并单击工具栏上的 复制 复制 。 可以将其粘贴到 ArcGIS Pro 中的其他元素,例如文本图形,或者将其粘贴到其他应用程序,例如 Microsoft Excel。

  1. 在 编辑 功能区选项卡上,单击 选择 组中的 属性 属性 。

    随即出现 属性 窗格。

  2. 在 属性 窗格中单击 选择 选择 ,选择要素,然后在窗格中展开选择内容。

  3. 右键单击包含要复制的属性的要素,然后单击 复制属性 复制 。

    属性值将复制到剪贴板上。

  4. 右键单击目标要素或图层,然后单击 粘贴属性 粘贴 。

  5. 如果 自动应用 已关闭,请单击 应用 。

查看、编辑或复制几何坐标

在 属性 窗格 属性 中,您可以使用 几何 选项卡工具栏上的命令查看、编辑或将几何坐标值复制到剪贴板。 工具栏包含常用编辑工具的快捷方式,用于编辑当前选定要素的几何。

查看、编辑或复制坐标值时,请注意以下事项:

  • 要 更改显示单位 ,请单击当前地图或场景视图底部的坐标显示箭头。

  • 要将几何属性表中的坐标值复制到剪贴板,请选择行并单击工具栏上的 复制 复制 。 可以将其粘贴到 ArcGIS Pro 中的其他元素,例如文本图形,或者将其粘贴到其他应用程序,例如 Microsoft Excel。

“属性”窗格中的“几何”选项卡