Skip to main content

对流图层进行符号化

流图层 可显示流数据的实时反馈。 您可以像其他要素图层那样显示和符号化流图层。 当流图层为追踪感知型时,您可以独立于当前观测点对之前的观测点进行符号化;对于追踪感知型点流图层,可以选择绘制轨迹线以连接观测点。

流图层符号系统

您可以使用单一符号、唯一值、分级符号或分级色彩符号系统对流图层进行符号化。 和标准要素图层一样,选择哪种方式取决于您的数据类型、分配方式和您想显示的内容。 您甚至可以根据属性或表达式修改符号系统的 颜色 、 大小 、 旋转 或 透明度 。

  1. 在 内容 窗格中选择流图层。

  2. 在 流图层 选项卡的 绘图 组中,单击 符号系统 符号系统 。

  3. 在 符号系统 窗格的 主符号系统 选项卡 主符号系统 中,从 主符号系统 菜单中选择一个符号系统选项。

    • 单一符号 - 对图层中的所有观测点应用同一符号。

    • 唯一值 - 对要素属性定义的定性类别应用不同的符号。

    • 分级符号 - 应用大小不同的符号以显示定量差异。 此选项仅适用于点和折线要素。 无法使用分级符号对流面进行符号化。

    • 分级色彩 - 应用颜色不同的符号以显示定量差异。

注意:

流图层只能放置在场景的 3D 图层类别中。 它们不能作为 2D 类别中的叠加图层。 面和折线流图层在视觉上可能会与场景中的地面冲突,导致其只有部分可见。 要解决此问题,请考虑在此情况下向流图层添加一个小的制图偏移。 制图偏移 可以在流图层的 图层属性 对话框的 高程 选项卡中进行配置。

对追踪感知型流图层进行符号化

追踪感知型流图层 依靠属性将对应于单个对象的观测点分组到一起。 当流图层为追踪感知型图层时,您可以以一种方式对当前(最新)观测点进行符号化,并以另一种方式对之前的(旧的)观测点进行符号化。 追踪感知在源流服务中指定。 如果流图层的源流服务不是追踪感知型,则无法在 ArcGIS Pro 中将流图层设置为追踪感知型。

为当前和之前的观测点设置符号系统的方式与对非追踪感知型流图层中的要素进行符号化的方式相同。 当您使用追踪感知型流图层时, 符号系统 窗格会显示两个选项卡, 当前 和 之前 。 在每个选项卡上单独设置符号系统选项。 您可以打开和关闭之前观测点的显示,无需重置符号系统属性。

注:

如果为追踪感知型仅属性流图层,则无需对之前的观测位置进行符号化,因此 符号系统 窗格中将不会显示 之前 和 轨迹 选项卡。 要使用之前的属性值,在 流图层 选项卡集的 数据 选项卡中的 串流数据 组中管理观测点过期时间。 将保存过期时间窗口内之前的观测值,并且在流停止后,可以通过图层的属性表和图表进行查看和查询。

您可以从其他图层(甚至是其他流图层) 导入符号系统 ,但是符号系统仅应用到当前观测点。

当前观测点

按照以下步骤对当前观测点进行符号化:

  1. 在 内容 窗格中选择流图层。

  2. 在 流图层 选项卡的 绘图 组中,单击 符号系统 符号系统 。

  3. 在 符号系统 窗格中,在 当前 选项卡下的 主符号系统 选项卡 主符号系统 上,从 主符号系统 菜单中选择一个符号系统选项。

之前的观测点

按照以下步骤对之前的观测点进行符号化:

  1. 在 内容 窗格中选择追踪感知型空间流图层。

  2. 在 流图层 选项卡的 绘图 组中,单击 符号系统 符号系统 。

  3. 在 符号系统 窗格中,在 之前 选项卡下的 主符号系统 选项卡 主符号系统 上,从 主符号系统 菜单中选择一个符号系统选项。 根据需要调整符号系统选项。

  4. 在 每个轨迹的数量 属性中,指定之前观测点的数量。 如果将之前的观测点设置为在此数量之前过期,则实际显示的之前观测点的数量可能会更少。 观测点过期时间可以在功能区 流图层 选项卡下的 数据 选项卡的 串流数据 组中进行设置。

  5. (可选)可以单击 显示之前的观测点 切换按钮打开或关闭所有之前观测点的显示,而无需重置符号系统属性。

轨迹线

请按照以下步骤用线将点流图层的观测点连接起来:

  1. 在 内容 窗格中选择追踪感知型空间点流图层。

  2. 在 流图层 选项卡的 绘图 组中,单击 符号系统 符号系统 。

  3. 在 符号系统 窗格 轨迹 选项卡下的 主符号系统 选项卡 主符号系统 上,单击 显示连接观测值的轨迹线 切换按钮以打开或关闭连接每个要素的观测点的线。

  4. 指定 每条轨迹线的之前观测点 的数量。 此数量与 之前 选项卡的 每个轨迹的数量 设置同步。

  5. (可选)单击符号对其进行修改。 单击符号旁边的箭头可更改 内容 窗格或布局图例中显示的图例图面的形状。 轨迹线只能使用 单一符号 符号系统进行绘制。

根据透明度、旋转、大小或颜色改变流图层符号系统。

根据用于绘制图层的符号系统,您可以通过附加属性对流图层观测点进行符号化,从而改变 透明度 、 旋转 、 大小 和 颜色 。 这些选项并非全部适用于每个符号系统选择。

按照以下步骤设置其他符号系统:

  1. 在 符号系统 窗格中(如果流图层为追踪感知型,则位于 当前 或 之前 选项卡下方),单击 按属性变更符号系统 选项卡 按属性变更符号系统 。

  2. 展开 透明度 、 旋转 、 颜色 或 大小 。

  3. 根据需要进行调整。

标注观测点

标注流图层以按属性或表达式标识观测点。 如果流图层为追踪感知型,则只标注当前观测点。

按照以下步骤对流图层进行标注:

  1. 在 内容 窗格中选择流图层。

  2. 在 流图层 选项卡集上,单击 标注 选项卡。

  3. 在 标注 选项卡的 图层 组中,单击 标注 启用标注 。

  4. 如有必要,可在 标注 选项卡中调整其他 标注属性 。