Skip to main content

Пространственное соединение данных

Операция соединения добавляет поля из одной таблицы данных (соединяемая таблица) в другую (целевую таблицу). Целевая таблица обычно представляет собой таблицу атрибутов слоя, а целью соединения может быть назначение символов слою, запрос к нему, получение статистики или выполнение другого анализа с использованием информации из соединяемой таблицы. Соединение может быть временным и удалено, когда оно вам больше не понадобится, или оно может быть постоянным.

Существует два типа соединений: атрибутивные и пространственные. Атрибутивное соединение основано на общем поле значений, которое существует в обеих таблицах. Общее поле гарантирует, что записи в соединяемой таблице правильно сопоставляются с записями в целевой таблице. Пространственное соединение основано на пространственных отношениях, таких как содержание или пересечение, между объектами в двух слоях. Записи в соединяемой и целевой таблицах сопоставляются в соответствии с пространственным отношением их объектов.

При соединении атрибутов соединяемая таблица может быть отдельной (не пространственной) таблицей или таблицей атрибутов слоя. При пространственном соединении обе таблицы должны быть таблицами атрибутов слоев.

Соединения — это один из многих способов объединения данных в ArcGIS Pro. Вы можете добавлять объекты из одного набора данных в другой с помощью инструмента Присоединить, объединять наборы данных с помощью инструмента Слияние и создавать новые данные путем пространственного сравнения наборов данных с помощью инструментов наложения, таких как Пересечение и Объединение.

Обзор

  • Это видео было создано с помощью ArcGIS Pro 3.6.

Землетрясение, произошедшее в Крайстчерче в Новой Зеландии 22 февраля 2011 года, нанесло огромный ущерб инфраструктуре города. После землетрясения была проведена инженерная оценка территории для определения потребностей в ремонте и восстановлении.

В этом уроке вы рассмотрите исторические места в городской зоне Крайстчерча в сопоставлении со слоем риска разжижения грунта. Разжижение — это процесс, при котором осадочные породы теряют прочность и устойчивость при сотрясении грунта, что значительно увеличивает вероятность повреждения зданий. Вы пространственно присоедините слой риска разжижения к слою исторических мест, чтобы присвоить соответствующее значение риска каждому историческому месту.

После пространственного соединения слоев вы добавите новые объекты к слою исторических мест и обновите их значения риска разжижения.

  • Предполагаемое время: 60 минут

  • Требования к программному обеспечению:

    • ArcGIS Pro Basic
Примечание:

Обучающие краткие руководства обновляются при каждом выпуске программного обеспечения. Для получения наилучших результатов используйте версию онлайн-справки, соответствующую версии вашего программного обеспечения.

Открытие проекта

Вы откроете проект из пакета проекта в ArcGIS Online.

  1. Запустите ArcGIS Pro и выполните вход, если необходимо.

  2. Откройте диалоговое окно обзора, чтобы выполнить поиск проекта одним из следующих способов:

    • На начальной странице щелкните Открыть другой проект .

    • В открытом проекте щелкните вкладку Проект на ленте. В списке боковых вкладок щелкните Открыть. На странице Открыть щелкните Открыть другой проект .

      Команда Открыть другой проект

  3. В диалоговом окне Открыть проект на панели навигации в разделе Портал щелкните ArcGIS Online .

    Примечание:

    Если вы вошли в ArcGIS Enterprise , вы должны установить активный портал на ArcGIS Online для доступа к данным руководства. Если вы не можете этого сделать, можете загрузить данные из браузера.

  4. Вверху диалогового окна в поле Поиск наберите Join data spatially и нажмите клавишу Enter.

  5. В списке результатов поиска нажмите Join data spatially, чтобы выбрать пакет проекта.

    Примечание:

    Если существует несколько пакетов проектов с этим именем, выберите пакет со значком Достоверный . В столбце Владелец имя владельца - ArcGISProTutorials. Если вы не получаете никаких результатов, см. Нет результатов поиска.

  6. Нажмите OK.

    Проект открывается с картой, показывающей городскую территорию Крайстчерча, Новая Зеландия.

    Карта городской территории Крайстчерча

  7. Щелкните вкладку Вид на ленте. В группе Окна щелкните Наборы панелей и щелкните Картография .

    При этом открываются панели Содержание и Каталог, остальные панели остаются закрытыми.

Просмотр данных

Вы изучите атрибуты слоев Historic Places (Historic Places) и Liquefaction Risk (Риск разжижения).Liquefaction Risk

  1. На панели Содержание щелкните правой кнопкой мыши на слой Historic Places и выберите Таблица атрибутов .

    Атрибуты включают имя, адрес и исторический регистрационный номер каждого объекта в поле RegID. В нижней части представления таблицы можно увидеть, что в слое 322 записи.

  2. На панели Содержание щелкните правой кнопкой мыши слой Liquefaction Risk и выберите Таблица атрибутов .

    Атрибуты этого слоя включают категорию риска и даты проведения оценки риска и даты последнего изменения.

    В поле Category значения трех технических категорий представляют собой возрастающий риск повреждения зданий в результате разжижения при будущем землетрясении.

    • Техническая категория 1 представляет минимальный риск повреждения.

    • Техническая категория 2 представляет риск повреждения от незначительного до умеренного.

    • Техническая категория 3 представляет риск повреждения от умеренного до значительного.

    В зависимости от риска могут применяться различные требования к строительству. В красной зоне, где риск крайне высок, строительство запрещено. Риск не оценивался на нежилых территориях или в зонах, обозначенных как нуждающиеся в оценке.

  3. Закройте обе открытые таблицы.

  4. На панели Содержание убедитесь, что выбран слой Liquefaction Risk. Нажмите Ctrl и щелкните слой Historic Places.

    Оба слоя выбраны.

  5. На ленте щелкните вкладку Карта. В группе Навигация щелкните стрелку ниспадающего списка инструмента Исследовать и щелкните Выбранные на панели Содержания.

    Когда вы щелкаете местоположение на карте, во всплывающем окне будут отображены значения атрибутов объектов в выбранных слоях.

  6. В нижней части вида карты щелкните стрелку раскрывающегося списка масштаба карты и выберите 1:10 000, чтобы исторические места было легче различить.

  7. На карте щелкните историческое место.

    Всплывающее окно, показывающее атрибуты объектов для обоих выбранных слоев

    Во всплывающем окне отображаются атрибуты исторического места и содержащего его полигона риска.

    Подсказка:

    В верхней части всплывающего окна вы увидите отображаемое значение или основной атрибут для объектов в обоих слоях. В этом примере выбран объект с именем Коттедж, и его атрибуты показаны в нижней части панели. Чтобы просмотреть атрибуты объекта риска разжижения, щелкните значение в разделе Liquefaction Risk в верхней части всплывающего окна.

  8. Нажмите еще несколько объектов исторических мест, затем закройте панель всплывающего окна.

    Во всплывающем окне отображается интересующая информация: категория риска, связанная с каждым историческим местом. Однако выбор объектов по одному — не самый эффективный способ получить эту информацию. С помощью пространственного соединения вы можете добавить атрибуты риска разжижения к слою Historic Places.

  9. На панели Содержание щелкните слой Historic Places, чтобы сделать его единственным выбранным слоем. Щелкните слой правой кнопкой мыши и выберите Приблизить к слою .

Пространственное соединение слоев

Вы соедините атрибуты слоя Liquefaction Risk со слоем Historic Places в соответствии с зоной риска, в которой находится каждое историческое место.

  1. На панели Содержание щелкните правой кнопкой мыши слой Historic Places, выберите Соединения и связи и выберите Добавить пространственное соединение .

    Инструмент Добавить пространственное соединение откроется во всплывающем окне. Параметр Целевые объекты правильно установлен для слоя Historic Places.

  2. Щелкните стрелку раскрывающегося списка Соединить объекты и выберите Liquefaction Risk.

    Атрибуты этого слоя будут добавлены в таблицу Historic Places.

  3. Щелкните стрелку раскрывающегося списка Опции сопоставления и выберите Внутри.

    Каждое историческое место получит атрибуты полигона риска разжижения, в пределах которого оно находится. (В этом случае опция пересечения по умолчанию также будет работать, поскольку объект, находящийся внутри другого объекта, также пересекает его.)

  4. Включите опцию Окончательно присоединить поля.

    Если опция не включена (настройка по умолчанию), пространственное соединение существует только на текущей карте и может быть удалено в любой момент. Исходные данные целевой таблицы не изменяются. Если опция включена, соединенные атрибуты изменяют исходные данные целевой таблицы.

    Вы сделаете соединение постоянным, потому что позже в этом уроке вы присоедините дополнительные объекты к слою Historic Places. Это невозможно сделать, если в слое есть временное соединение.

    Подсказка:

    Для этого рабочего процесса также можно использовать инструмент геообработки Пространственное соединение. Инструмент Пространственное соединение создает новый класс пространственных объектов с атрибутами целевых и соединяемых объектов. Входные наборы данных не изменяются. В этом руководстве вместо этого используется Добавить пространственное соединение, чтобы можно было выполнить соединение без создания нового выходного набора данных.

  5. Разверните заголовок Поля.

    Параметр сопоставления полей отображает список полей слоя Liquefaction Risk. Поле CATEGORY – единственное из тех полей, которое вам нужно добавить в слой Historic Places. Вы удалите остальные.

  6. В списке полей щелкните поле CREATEDDATE, чтобы выбрать его. Нажмите клавишу Shift и щелкните поле Shape_Area.

    Выбраны четыре поля.

  7. Щелкните Удалить .

    Раздел сопоставление полей диалогового окна Добавить пространственное соединение

    Выбранные поля удалятся, останется только поле CATEGORY.

    В слое Liquefaction Risk значение поля CATEGORY понятно. Однако в контексте исторических мест его значение не очевидно. Вы переименуете поле перед запуском инструмента. (Исходное название останется в таблице Liquefaction Risk.)

  8. В параметре сопоставление полей нажмите Редактировать .

    Откроется диалоговое окно Свойства поля. Вверху в разделе Свойства вы увидите свойства поля CATEGORY, такие как его имя, псевдоним и тип.

  9. В ячейке Имя поля выделите существующее значение (CATEGORY) и замените его на LIQUEFACTION_RISK.

  10. В ячейке Псевдоним выделите существующее значение и замените его на Liquefaction Risk.

    Диалоговое окно Свойства поля показывает новое имя поля и псевдоним

    Псевдоним — это отображаемое имя, которое по умолчанию отображается в таблице атрибутов и в большинстве контекстов геообработки. Псевдоним может включать пробелы; имя поля не может.

  11. Щелкните ОК в диалоговом окне Свойств поля.

    Диалоговое окно Добавить пространственное соединение

  12. Нажмите ОК, чтобы запустить инструмент Добавить пространственное соединение.

  13. После завершения операции на панели Содержание щелкните правой кнопкой мыши слой Historic Places и щелкните Таблица атрибутов .

    Переименованное поле Category из слоя Liquefaction Risk добавилось в таблицу и отображает его псевдоним Liquefaction Risk. Каждое историческое место теперь связано с категорией риска полигона, в котором оно находится. Также добавлено поле Join_Count. Значение в этом поле равно 1 для каждой записи, поскольку каждое историческое место связано ровно с одним полигоном риска.

    Вы удалите поле Join_Count, которое вам не нужно.

  14. В таблице Historic Places щелкните заголовок поля Join_Count, чтобы выбрать поле.

    Таблица атрибутов с выбранным полем

  15. Щелкните правой кнопкой мыши выбранный заголовок поля и выберите Удалить .

  16. В строке Удалить поле выберите Да.

    Не закрывайте таблицу Historic Places.

    Подсказка:

    Вы также можете скрыть поля в таблице, чтобы сделать их невидимыми, не удаляя их.

    Подсказка:

    При желании вы можете перетащить таблицу за вкладку просмотра в новое место, чтобы было больше места для просмотра карты. Например, если у вас два монитора, вы можете перенести таблицу за рамки окна ArcGIS Pro.

  17. На Панели быстрого доступа щелкните Сохранить проект .

Оценка результатов

Вы откроете вид Data Engineering таблицы Historic Places, чтобы просмотреть статистику объединенной таблицы и создать диаграмму.

  1. В таблице Historic Places щелкните заголовок поля Liquefaction Risk, чтобы выбрать поле.

  2. Щелкните правой кнопкой мыши выбранный заголовок и выберите Просмотреть статистику .

    Вид Data Engineering таблицы атрибутов исторических мест

    Откроется вид Data Engineering таблицы и отобразится статистика для поля LIQUEFACTION_RISK:

    • Значение Количества — 322 (100%). Это подтверждает, что для каждого исторического места существует значение риска разжижения.

    • Существует шесть уникальных значений. Таблица Liquefaction Risk фактически содержит семь уникальных значений. Это означает, что исторических мест ни в одной из категорий риска нет. (К счастью, это красная зона.)

    • Режим или наиболее распространенное значение — Nonresidential area (Нежилая территория).

    • Наименее распространенное значение — Technical Category 1 (техническая категория 1).

  3. В виде Data Engineering наведите указатель мыши на столбец Предварительный просмотр диаграммы.

    Столбец Предварительный просмотр диаграммы и всплывающая подсказка

    Экранная подсказка дает процентную разбивку значений. Около половины исторических мест находятся в нежилых районах, около четверти во второй технической категории и так далее.

  4. Щелкните правой кнопкой мыши заголовок строки (квадрат у левого края строки), выберите Создать диаграмму и выберите Линейчатая диаграмма .

    Вид Data Engineering, показывает раскрывающиеся параметры для поля LIQUEFACTION_RISK

    Откроется вид диаграммы и панель Свойства диаграммы. На графике отображается количество исторических мест в каждой категории риска. Вы измените его свойства, чтобы диаграмму было легче интерпретировать.

    Вид диаграммы с настройками по умолчанию

    Значения оси Y и ориентация меток категорий могут различаться в зависимости от размера вида диаграммы.
  5. Выше панели Свойства диаграммы щелкните при необходимости вкладку Данные.

  6. В разделе Надписать данные отметьте пункт Надписать столбцы.

    На графике над каждой полосой отображается количество исторических мест в каждой категории риска.

  7. В верхней части панели щелкните вкладку Оси.

  8. В поле Ограничение количества символов в надписи измените значение с 11 на 20. (Вы можете использовать клавишу со стрелкой или ввести значение и нажать клавишу Enter.)

    На оси X значения категорий отображают свои полные имена. По умолчанию ориентация надписи настраивается так, чтобы наилучшим образом соответствовать доступному пространству. Однако вы можете захотеть изменить ориентацию.

  9. При необходимости щелкните стрелку раскрывающегося списка Ориентация подписи и выберите необходимый параметр.

  10. В верхней части панели щелкните вкладку Общие. (Если вы ее не видите, нажмите кнопку параметров и щелкните Общие в ниспадающем списке.)

    1. В поле Заголовка диаграммы удалите заголовок по умолчанию и введите Historic Places by Liquefaction Risk Category. Нажмите клавишу Enter.

    2. Отключите Название оси X.

    3. В поле Заголовка оси Y удалите заголовок по умолчанию и введите Number of Sites. Нажмите клавишу Enter.

    Возможно, вы захотите изменить цвет столбцов, который в настоящее время установлен на светло-зеленый.

  11. При необходимости щелкните вкладку Серии.

    1. В столбце Символ щелкните квадрат светло-зеленого цвета.

    2. В появившейся цветовой палитре выберите любой понравившийся цвет.

    3. Щелкните за пределами цветовой палитры, чтобы закрыть ее.

    График исторических мест по категориям риска разжижения

  12. Щелкните полосу на диаграмме, чтобы выбрать ее.

    На карте выбраны соответствующие объекты слоя Historic Places.

  13. Щелкните другую полосу, чтобы изменить выбор. Нажмите клавишу Ctrl и щелкните другую полосу, чтобы добавить ее к выделению.

  14. На панели инструментов вида диаграммы нажмите Очистить выборку .

  15. Закройте вид диаграммы и закройте панель Свойства диаграммы. Не закрывайте вид Data Engineering.

    На панели Содержание появится диаграмма под слоем Historic Places. Диаграмма не существует независимо от слоя: если вы удалите слой с карты или карту из проекта, диаграмма исчезнет. Вы можете экспортировать диаграмму и сохранить ее в виде графического файла.

  16. На Панели быстрого доступа щелкните Сохранить проект .

Создание слоя из таблицы

Могут появиться дополнительные данные, относящиеся к вашему проекту. Предположим, что вы обнаружили файл .csv с информацией о паре исторических мест Крайстчерча. Если эти места еще не включены в слой Historic Places, вы хотите их добавить.

Вы добавите на карту файл .csv в виде таблицы. Поскольку файл содержит пространственные координаты достопримечательностей, вы можете создать слой из таблицы с объектами в координатах местоположений.

  1. Сделайте панель Каталог активной. Убедитесь, что в верхней части панели выбрана вкладка Проект.

  2. Разверните контейнер Папки . Разверните Join_data_spatially > commondata userdata.

    В папке userdata находится файл с именем Christchurch Heritage Sites.csv.

  3. Щелкните правой кнопкой мыши файл Christchurch Heritage Sites.csv и выберите Добавить на текущую карту .

    На панели Содержание файл добавлен в виде таблицы под заголовком Автономные таблицы.

  4. На панели Содержание щелкните правой кнопкой мыши файл Christchurch Heritage Sites.csv и выберите Открыть .

    Таблица Christchurch Heritage Sites

    Таблица содержит информацию о двух объектах наследия, включая имя, адрес, регистрационный номер и другие поля.

  5. Сделайте таблицу Historic Places активной, щелкнув вкладку ее вида.

    Эта таблица также содержит поля имени и адреса. Поле RegID соответствует полю RegisterNumber в таблице Christchurch Heritage Sites (Объекты наследия Крайстчерча). Хотя имена полей разные, они хранят одну и ту же информацию.

  6. Снова сделайте активной таблицу Christchurch Heritage Sites.csv.

    В таблицу входят поля X и Y с координатами широты-долготы в десятичных градусах. Вы будете использовать эти координаты для создания слоя из таблицы. Как только вы это сделаете, вы сможете увидеть, существуют ли уже эти объекты в слое Historic Places.

  7. На панели Содержание в разделе Автономные таблицы щелкните правой кнопкой мыши файл Christchurch Heritage Sites.csv, выберите Создать точки из таблицы и выберите Таблица XY в точку .

    В плавающем окне откроется инструмент XY Таблица в точку.

    Параметр Входная таблица по умолчанию содержит правильный параметр Christchurch Heritage Sites.csv. Параметры Поле X и Поле Y по умолчанию корректно установлены как поля таблицы X и Y. Параметр Системы координат по умолчанию имеет значение GCS_WGS_1984. Большинство значений широты и долготы хранятся в этой системе.

    Подсказка:

    Вы можете убедиться, что настройка в этом случае верна, щелкнув правой кнопкой мыши файл на панели Каталог и выбрав Просмотреть метаданные .

  8. Рядом с текстовым полем Выходной класс пространственных объектов щелкните Рабочая область памяти . Измените путь к выходному классу объектов на memory\Sites.

    Диалоговое окно XY Таблица в точки

    Вы создадите точечные объекты во временной рабочей области памяти, поскольку вам не нужно создавать выходные данные. Если окажется, что объекты уже существуют в слое Historic Places, вы можете отказаться от этого нового слоя. Если они еще не существуют, вы хотите добавить их в слой Historic Places. В любом случае вам необходимо сохранить их в новый набор данных.

    Имя пути memory\ указывает, что выходные данные записываются в рабочую область памяти, а не в класс объектов. Когда вы завершаете сеанс ArcGIS Pro, рабочая область памяти очищается. Имя Sites может быть любым по вашему выбору, но не может содержать пробелов.

  9. Нажмите OK.

    По завершении работы инструмента в верхнюю часть панели Содержание добавляется слой Sites (Достопримечательности).

  10. На панели Содержание щелкните правой кнопкой мыши на слое Sites и выберите Приблизить к слою .

    Вы увеличите символы по умолчанию, чтобы их было легче увидеть.

  11. На панели Содержание щелкните символ слоя Sites

    Появится панель Символы с опциями форматирования точечных символов.

  12. На вкладке Галерея в списке символов в ArcGIS 2D щелкните символ Круг 3, чтобы выбрать его.

    Панель Символы с выбранным символом Круг 3

    Символ будет обновлен как на карте, так и на панели Содержание.

  13. На панели Содержание отключите слой Sites, а затем включите его снова.

    Вы можете видеть, что в этих местах в слое Historic Places еще нет объектов.

Присоединение данных

Вы добавите два объекта из слоя Sites в слой Historic Places с помощью инструмента Присоединить. Поскольку таблицы в двух слоях имеют разную схему, некоторые поля необходимо сопоставить вручную. Вы сделаете это с помощью параметра сопоставления полей, который использовали ранее.

Подсказка:

Другой вариант — скопировать объекты из одного слоя в другой с помощью команд Копировать и Специальная вставка на вкладке ленты Редактирование. Для небольшого количества объектов этот подход может быть полезным. Рабочий процесс копирования и вставки также поддерживает сопоставление полей посредством настройки параметров редактирования.

  1. Активируйте вид Data Engineering для Historic Places.

  2. Щелкните правой кнопкой мыши заголовок строки (квадрат у левого края строки), выберите Интегрировать и нажмите Присоединить .

    Инструмент Присоединить откроется во всплывающем окне. Сообщение в верхней части диалогового окна предупреждает вас о том, что инструмент изменяет целевой набор данных (вместо того, чтобы создавать новые выходные данные).

  3. Щелкните стрелку ниспадающего списка для Входные наборы данных и выберите Sites.

    По умолчанию для целевого набора данных правильно установлено значение Historic Places.

  4. Щелкните стрелку раскрывающегося списка Тип сопоставления полей и выберите Использовать список полей для определения различий.

    Параметр сопоставления полей инструмента Присоединить

    Диалоговое окно развернется и отобразит параметр сопоставления полей. Отображаются названия полей в целевом наборе данных (Historic Places).

    Поля RegID и LIQUEFACTION_RISK отмечены значками предупреждения , поскольку они не соответствуют полям с таким же именем во входном наборе данных. (По этой причине инструмент не сработает, если вы запустите его с настройкой по умолчанию, согласно которой входные поля должны соответствовать целевым полям.)

    Однако, как вы видели ранее, поле RegisterNumber в таблице Достопримечательности и поле RegID в таблице Historic Places содержат исторические регистрационные номера. Если имена полей различаются, но значения совместимы, вы можете вручную сопоставить эти поля с помощью сопоставления полей.

  5. В параметре сопоставление полей нажмите Редактировать .

    Откроется диалоговое окно Свойства поля.

  6. В диалоговом окне Свойства поля в списке Поля убедитесь, что поле RegID выбрано (выделено синим цветом). Прокрутите список источников полей и щелкните поле RegisterNumber.

    Диалоговое окно Свойства поля, показывающее поле RegisterNumber, соответствующее полю RegID

    В разделе Действия и исходные поля поле RegisterNumber отображается как тег, указывающий, что оно соответствует полю RegID в качестве исходного поля. Значок предупреждения будет удален с поля RegID.

    Вы оставите поле LIQUEFACTION_RISK без отметки, поскольку у него нет сопоставляемого поля в таблице Sites. Когда инструмент запустится, в таблицу Historic Places будут добавлены две новые записи. Атрибуты будут обрабатываться следующим образом:

    • Для сопоставимых полей значения в таблице Sites будут добавлены в соответствующее поле в таблице Historic Places. Например, адреса будут добавлены в поле Address и регистрационные номера будут добавлены в поле RegID.

    • Поля в таблице Historic Places, у которых нет сопоставимого поля, будут иметь нулевые значения для добавленных записей. Это означает, что поле LIQUEFACTION_RISK будет иметь нулевые значения.

    • Поля в таблице Sites, у которых нет сопоставимого поля, не будут добавлены в таблицу Historic Places. К ним относятся DateRegistered, LocalAuthorityName и ряд других полей.

    Примечание:

    Как вы видели ранее, пространственные координаты двух достопримечательностей наследия указаны в десятичных градусах. Инструмент Присоединить автоматически спроецирует эти координаты в систему координат целевого набора данных, то есть NZGD 2000 New Zealand Transverse Mercator.

  7. Щелкните ОК в диалоговом окне Свойств поля.

    Инструмент Присоединить — это один из нескольких инструментов геообработки, который позволяет вам отменить результаты геообработки. В этом уроке вы оставите кнопку-переключатель Включить отмену отключенной.

  8. Щелкните ОК в инструменте Присоединить.

  9. По завершении работы инструмента сделайте активной таблицу атрибутов слоя Historic Places.

    В нижней части вида таблицы вы видите, что теперь в таблице 324 записи (на две больше, чем раньше).

  10. В нижней части вида таблицы нажмите Переместить в конец , чтобы перейти в конец таблицы.

    Таблица Historic Places с добавленными записями

    В таблицу добавлены две записи из слоя Sites. Как и ожидалось, для этих записей поле Liquefaction Risk имеет нулевые значения.

  11. Сделайте вид карты городского района Крайстчерча активным. На панели Содержание отключите слой Sites.

    Карта с двумя присоединенными объектами

    Присоединенные объекты появились на карте в правильных местах. Вам больше не нужен слой Sites.

  12. На панели Содержание щелкните правой кнопкой мыши слой Sites и выберите Удалить .

    Чтобы завершить работу, вы определите значения риска разжижения для новых объектов и добавите их в таблицу.

  13. На панели инструментов быстрого доступа щелкните Сохранить проект .

Определение зон риска для новых пространственных объектов

Новые объекты были добавлены после пространственного соединения и поэтому имеют в поле Liquefaction Risk нулевые значения. Вы будете использовать инструмент Исследование, чтобы найти значения для этих функций.

  1. На ленте, на вкладке Карта щелкните стрелку раскрывающегося списка инструмента Исследовать и выберите Видимые слои.

  2. На карте щелкните новый объект в слое Historic Places, который представляет собой пещеру Монкс. (Из двух новых объектов этот находится севернее.)

    Всплывающее окно показывает значения для видимых слоев

    Во всплывающем окне вы видите, что пещера Монкс находится в зоне риска разжижения, в которой ущерб маловероятен.

  3. При необходимости переместите всплывающее окно в сторону. На карте щелкните новый объект Rotten Row Baches.

    Этот объект находится в нежилой области.

    Примечание:

    Если слой Liquefaction Risk не отображается во всплывающем окне, увеличьте объект и щелкните его еще раз. Объект находится на границе экстента слоя. Если вы щелкнете за пределами экстента, вы не получите результата.

  4. Закройте панель Всплывающее окно.

  5. На ленте на вкладке Карта щелкните стрелку раскрывающегося списка инструмента Исследовать и выберите Самый верхний слой, чтобы восстановить настройки по умолчанию.

Вычисление значений полей

Вычисления в полях обновляют значения таблицы на основе написанного вами выражения. В этом случае вам нужно обновить только два значения, и вы сможете редактировать ячейки таблицы вручную. Однако в случаях, когда вам необходимо обновить сотни или тысячи значений, необходимы вычисления в полях. Использование вычислений в полях также сводит к минимуму риск ошибок при вводе данных.

  1. Сделайте активной таблицу атрибутов Historic Places. В таблице щелкните заголовок строки номер 323 (серый квадрат у левого края строки), чтобы выбрать запись для пещеры Монкс.

  2. В строке инструментов в верхней части таблицы щелкните Вычислить .

    Панель инструментов Вычислить поле отображается под рядом инструментов.

  3. На панели инструментов Вычислить поле щелкните стрелку раскрывающегося списка Целевое поле и выберите Liquefaction Risk.

    Теперь определите выражение для вычисления. В поле Liquefaction Risk вы хотите заменить текущее пустое значение для Пещеры Монкс на значение Damage unlikely.

  4. На панели инструментов Вычислить поле щелкните Конструктор выражений .

    Откроется диалоговое окно Конструктор выражений.

  5. В диалоговом окне Конструктор выражений в списке полей выберите Liquefaction Risk.

    Поле Liquefaction Risk содержит значение, которое вы хотите использовать. При выборе поля активируется ниспадающий список Вставить значения.

  6. Щелкните ниспадающий список Вставить значения и выберите Damage unlikely.

    Диалоговое окно Конструктор выражений с готовым выражением

    Готовое выражение: LIQUEFACTION_RISK = "Damage unlikely".

  7. Нажмите OK.

  8. На панели инструментов Вычислить поле щелкните Вычислить выбранные .

    Запись пещеры Монкс (единственная выбранная запись) обновлена с учетом значения риска разжижения. Вы можете обновить запись Rotten Row Baches таким же образом, но на этот раз нужно будет ввести нужное значение в поле выражения на панели инструментов.

  9. В таблице щелкните заголовок строки номер 324, чтобы выбрать запись для Rotten Row Baches.

  10. На панели инструментов Вычислить поле в поле выражения удалите выражение "Damage unlikely" и введите "Nonresidential area" (включая кавычки).

    Панель инструментов Вычислить поле с выражением

  11. Щелкните Вычислить выбранные .

    Обновлена запись Rotten Row Baches.

  12. В строке инструментов в верхней части таблицы щелкните Очистить ,чтобы очистить выбранную запись.

    Таблица Historic Places с рассчитанными значениями риска разжижения для двух новых записей

    Вычисления в двух полях являются изменениями таблицы и должны быть сохранены.

  13. На ленте щелкните вкладку Редактирование. В группе Управление изменениями щелкните Сохранить .

  14. При получении запроса Сохранить изменения нажмите Да.

  15. Закройте открытые таблицы и вид Data Engineering.

  16. На панели Содержание щелкните правой кнопкой мыши слой Historic Places и выберите Приблизить к слою .

  17. На панели инструментов быстрого доступа щелкните Сохранить проект .

В этом руководстве вы использовали пространственное соединение, чтобы добавить атрибут риска разжижения при землетрясении из полигонального слоя в точечный слой исторических достопримечательностей. Вы изучили свойства объединенной таблицы в виде Data Engineering. Вы преобразовали файл .csv в слой карты и присоединили объекты из этого слоя к слою исторических достопримечательностей. Наконец, вы рассчитали значения присоединенных записей, чтобы заполнить недостающую информацию.

Чтобы получить больше опыта работы с пространственными соединениями, ознакомьтесь с руководствами по Началу работы с ArcGIS Pro и Заимствованию атрибутов с помощью пространственного соединения. Узнайте больше о Data Engineering в серии статей и руководств по Data Engineering в ArcGIS Pro. Чтобы узнать, как присоединять новые данные в слой при обновлении существующих данных, см. статью Обновление наборов данных с помощью инструмента Присоединить данные в ArcGIS Pro.