Skip to main content

创建布局

要将工作共享为打印地图、海报或 PDF 文件,需要创建布局。 布局是由一个或多个地图以及其他支持元素(如标题、图例和描述性文本)组成的。 某些布局包括多个地图。 例如,布局可能具有一个主地图和一个用于在较大的地理环境中显示主地图的总览图。

概述

  • 本视频使用 ArcGIS Pro 3.1 创建。

在本教程中,您将创建一个布局,并添加地图框、图例、指北针、比例尺和描述性文本。 布局完成后,您将其导出为 PDF 文件。

  • 预计时间:45 分钟

  • 软件要求:ArcGIS Pro Basic

注:

每次发布软件时都会更新快速入门教程。 为了获得最佳体验,请使用与软件版本匹配的在线帮助版本。

打开工程

在此工程中,将创建新西兰惠灵顿中心建筑物的年平均太阳辐射量地图布局。 该布局旨在帮助企业和房主决定是否投资太阳能加热技术。

  1. 启动 ArcGIS Pro 并根据需要进行登录。

  2. 打开浏览对话框,以通过以下方式之一搜索工程:

    • 在开始页面上,单击打开其他工程 。

    • 在打开的工程中,单击功能区上的工程选项卡。 在侧面选项卡的列表中,单击打开。 在打开页面上,单击打开其他工程 。

      “打开其他工程”命令

  3. 在打开工程浏览对话框的导航窗格中,单击门户 下的 ArcGIS Online 。

    注:

    如果已登录 ArcGIS Enterprise ,必须将活动门户设置为 ArcGIS Online 才能访问教程数据。 如果无法执行此操作,则可以从浏览器下载数据。

  4. 在对话框顶部的搜索框中,输入 Make a layout,然后按 Enter 键。

  5. 在搜索结果列表中,单击 Make a layout 以选择工程包。

    注:

    如果存在多个具有此名称的工程包,请选择带有权威标记 的工程包。 在所有者列中,所有者名称为 ArcGISProTutorials。 如果未得到任何结果,请参阅未返回任何搜索结果。

  6. 单击确定。

    工程将打开一张显示新西兰惠灵顿中心的建筑物的活动地图视图。 建筑物按年平均太阳辐射量进行符号化。 深橙色建筑物受到的日照最多;黄色建筑物受到的日照最少。

    惠灵顿建筑物地图

    太阳辐射量的值通过每平方米屋顶可获得的潜在千瓦时电力表示。
  7. 单击功能区上的视图选项卡。 在窗口组中,单击窗格集 ,然后单击制图 。

    此操作可确保内容和目录窗格打开,其他窗格关闭。

  8. 通过单击位于视图正上方的选项卡,激活区域地图视图。

    “区域”地图包含惠灵顿的影像底图及其周边区域。 您稍候将在本教程中使用“区域”地图将总览图添加到布局中。

  9. 通过单击选项卡,激活纵向布局视图。

    纵向地图布局

    随即打开基于惠灵顿中心地图的布局。 布局包括主地图、圆形总览图、标题和其他元素。 ArcGIS Pro 工程可包含多个地图和布局。 将创建第二个布局,该布局与第一个类似,但方向为横向。

创建布局

您将创建一个空白布局,尺寸为标准纸张大小,方向为横向。

  1. 根据需要,单击功能区上的插入选项卡。 在工程组中,单击新建布局 以显示页面大小和方向选项。

  2. 在 ANSI - 横向下方,单击信纸。

    页面大小和方向菜单

    工程中随即打开一个新的空白布局视图。

  3. 在内容窗格中,右键单击绘制顺序下的布局,然后单击属性。

  4. 在布局属性对话框上,单击常规选项卡。 将名称从布局更改为横向布局,然后单击确定。

    更改的名称将反映在内容窗格和标尺上方的视图选项卡上。

  5. 右键单击标尺顶部,然后单击添加多条参考线 。

    参考线为非打印线,可帮助您对齐布局上的元素。

  6. 在添加参考线对话框的方向下,单击两者。

  7. 单击放置下拉箭头,然后单击边缘偏移。

  8. 使用 0.25 英寸替换边距框中的值。 单击确定。

    将参考线以 0.25 英寸的边距添加到布局中。

  9. 右键单击标尺顶部,然后再次单击添加多条参考线 。

  10. 在添加参考线对话框的方向下,单击水平。 单击放置下拉箭头,然后单击边缘偏移。 在边距下,将值更改为 1 英寸。 单击确定。

  11. 再次右键单击标尺顶部,然后单击添加参考线(而非添加多条参考线)。

    将单一垂直参考线添加到您单击的位置。

  12. 在标尺上,将鼠标指针放置在您刚刚添加的参考线上。

    标尺上会出现一个蓝色的倒三角形。

  13. 拖动三角形将参考线移动到 8.00 英寸标记处。

    移动参考线时,屏幕提示将显示标尺标记的十进制等效值。

  14. 再次右键单击标尺顶部,然后单击添加参考线。 将此参考线移动至 8.25 英寸标记处。

    含有参考线的布局

    提示:

    要删除参考线,请将鼠标悬停在标尺上的参考线位置处。 右键单击随即出现的蓝色三角形,然后单击移除参考线。

  15. 在快速访问工具栏上,单击保存工程 。

添加地图框

现在您将惠灵顿中心地图添加到布局中。

  1. 在功能区插入选项卡的地图框组中,单击地图框下拉箭头。 在 Central Wellington 下方,单击 Central Wellington 地图的任一缩略图。

    地图框列表

    第一个缩略图代表在 Central Wellington 地图视图中处于当前比例尺的地图。 第二个缩略图代表该地图在已保存的书签中的比例尺。 (您可以将鼠标悬停在缩略图上查看这两个源。)两个比例尺相似,而且您无论如何都会更改比例尺,因此选择哪个缩略图并不重要。

  2. 使用鼠标在布局上绘制一个大矩形。

    地图框已添加到布局中。 如选择控点所示,该地图框当前已选中。 功能区上随即显示地图框选项卡。

    提示:

    您可以通过单击或绘制矩形的方式将地图框和其他元素添加到布局中。

  3. 在布局上,拖动地图框将其左侧边缘与 0.25 英寸处的垂直参考线对齐。

    提示:

    单击布局视图底部的捕捉 可打开和关闭捕捉功能。 打开捕捉功能(默认)时,可以捕捉参考线和布局上的其他元素。

    了解有关设置布局的详细信息

  4. 使用选择控点调整地图框的大小。 将其顶边和底边分别与 7.5 英寸和 1 英寸处的水平参考线对齐。 拖动地图框的右侧边缘,使其与 8 英寸处的垂直参考线对齐。

    布局上调整大小后的地图框

    调整地图框的大小会更改地图的比例和范围,因此您可能想要进行调整。 要将地图用作地图,而非布局元素,请激活地图框。

  5. 单击功能区上的布局选项卡。 在地图组中,单击激活 。

    布局页面将变灰。 在功能区上,地图选项卡及其工具取代了布局选项卡。

  6. 在地图选项卡的导航组中,确认浏览工具 处于选中状态。 根据您的喜好,将地图平移并缩放至合适的范围。

    激活的地图框中缩放和平移后的地图

    接近 1:15,000 的比例尺是此地图的不错选择。

    提示:

    使用布局视图左下角的地图比例框来设置精确的地图比例。 可以从下拉菜单中选择比例,或直接在比例框中输入值。

  7. 单击功能区上的布局选项卡。 在地图组中,单击关闭激活 。

    提示:

    还可以通过单击关闭激活的地图框按钮( 或 )从布局视图关闭激活的地图框。

添加地图整饰要素

需要将图例、指北针和比例尺添加至布局。 图例将介绍地图的符号系统。 指北针和比例尺提供地理环境。

  1. 根据需要,单击功能区上的插入选项卡。 在地图整饰要素组中,单击图例 下拉箭头,然后单击标题和文本对齐图例。

    显示默认图例样式的图例库

    每个选项都会以不同方式格式化图例元素。

  2. 在 8.25 和 10.75 英寸处的垂直参考线之间绘制一个矩形。

    布局上的图例

    您将更改默认外观,为 Parks 图层提供一个与 Buildings 图层等效的标题。 您还将移除图例标题。

  3. 根据需要,在内容窗格的横向布局下,展开图例元素。 右键单击 Parks 图例元素,然后单击属性 。

    展开了图例元素的内容窗格

    随即出现元素窗格。

    提示:

    可在元素窗格中处理各个图例项目的属性(在内容窗格中通过图例项目符号 图例项目 表示)。 要将图例属性作为整体进行处理,右键单击图例标题(通过图例符号 图例 表示),然后单击属性。 或者,右键单击布局上的所选图例。

  4. 在元素窗格的 显示 下,选中图层名称复选框以将图层名称显示为标题。

  5. 清除**标注(或图层名称)**复选框。

    Parks 图例项目的“元素”窗格

    在布局上,Parks 图层名称现以粗体和更大字号显示在该符号上方。

  6. 在内容窗格中,单击图例 。

    元素窗格将更新以显示属于整个图例的属性。 在窗格顶部,图例选项卡处于选中状态。 在其下方,选项选项卡 处于选中状态。

  7. 在窗格的图例部分,取消选中标题旁边的显示复选框。

    取消选中“显示”复选框以隐藏标题的图例属性

    默认图例标题随即移除。

  8. 关闭元素窗格。

  9. 在布局上,拖动图例,使矩形的顶部捕捉到 7.5 英寸处的水平参考线。

  10. 如有必要,通过向上拖动图例底边来调整图例大小,使矩形紧密贴合图例元素。

    调整大小后的图例

  11. 根据需要,单击功能区上的插入选项卡。 在地图整饰要素组中,单击指北针下拉箭头 ,然后单击 ArcGIS North 1 或任何您喜欢的指北针。

  12. 单击布局的左下角,在布局上放置指北针。

  13. 拖动指北针,直到它同时捕捉到 0.25 英寸处的水平参考线和垂直参考线。

    如果您不小心调整了元素大小,请在快速访问工具栏上单击撤消 。

    提示:

    要在布局页面上缩放和平移,请单击功能区上的布局选项卡。 在导航组中,单击导航工具 。 然后,要重新定位元素,请在元素组中单击选择工具 。 要返回到整个布局页面范围,请在导航组中单击全图范围 。

  14. 在插入选项卡的地图整饰要素组中,单击比例尺下拉箭头 。 在比例尺列表中的公制下,单击公制刻度线 1。

  15. 单击布局底部,在布局上放置比例尺。

  16. 将比例尺拖动到 0.25 英寸处的垂直参考线。 使比例尺相对于地图框居中或将其放置在美观的位置。

    注:

    当您移动或调整布局元素的大小时,可能会看到蓝色的水平和垂直虚线。 这些是智能参考线,可帮助您将所选元素与其他布局元素和布局页面对齐。

  17. 如果需要,调整比例尺的大小,以便最大值为 1 千米。

  18. 单击布局的空白区域以取消选中比例尺。

    含有地图框、图例、指北针和比例尺的布局

  19. 在快速访问工具栏上,单击保存工程 。

添加标题和文本

需要添加地图标题和描述性文本。

  1. 在插入选项卡的图形与文本组中,单击图形与文本库中的矩形文本工具 。

    如果您的应用程序窗口宽度不足以显示库,请单击库按钮的下拉箭头 。 在文本下,单击矩形文本工具 。

  2. 在布局中的地图框上方,为地图标题绘制一个宽矩形。

    释放鼠标按钮后,Text 一词将显示在该框的虚线轮廓内。 文本会高亮显示,以进行编辑。

  3. 输入以下文本:惠灵顿中心建筑物的太阳辐射。

  4. 完成后,单击布局的空白区域。

    文本元素现已在布局中选中。

  5. 在功能区中,单击文本选项卡。 在文本符号组中,将文本符号字体大小更改为 22 磅。 将文本符号字体样式从“常规”更改为粗体。

  6. 将标题与 0.25 英寸处的垂直参考线和 8.25 英寸处的水平参考线对齐。

  7. 如有必要,加宽文本元素以查看完整标题。

    提示:

    如果文本元素包含未显示的文本,则元素旁边将显示溢出图标 。

  8. 单击布局的空白区域以取消选中标题。

    接下来,将添加简短描述以帮助读者了解地图。

  9. 在工具栏的插入选项卡的图形与文本组中,单击图形与文本库中的矩形文本工具 。 在布局上,在图例下方绘制一个框。

  10. 将以下文本输入或复制并粘贴至文本矩形中:每平方米屋顶的千瓦时年平均潜在太阳能值。 深橙色表明适合安装太阳能面板或热水器的位置,这些位置所能接收到的热能较多。 三维屋顶信息用于可用位置,其他屋顶结构假定与估算高度持平。 在分析中忽略树。

  11. 单击布局的空白区域以选择文本元素。

  12. 在功能区中,单击文本选项卡。 在文本符号组中,将文本符号字体大小更改为 8 磅。 将文本颜色更改为灰色 50%。

    指示了 50% 灰色的调色板(第 6 行,第 1 列)。

  13. 将文本元素的左侧与 8.25 英寸处的垂直参考线对齐。 将右侧与 10.75 英寸处的垂直参考线对齐。

  14. 调整文本矩形的大小,使其紧密贴合文本,同时显示所有文本。

  15. 单击布局的空白区域以取消选中文本。

    含有标题和描述的布局

    注:

    如果应用程序中启用了拼写检查,则无法识别的单词将以波浪下划线标出。 当地图打印或导出为文件时,这些线不会显示。

  16. 在快速访问工具栏上,单击保存工程 。

添加动态文本

除了无法更改的静态文本之外,您可以添加动态文本。 动态文本链接到地图的属性或计算机的操作系统,并在属性更改时自动更新。 例如,动态文本可以反映上次保存或打印地图的时间。

  1. 根据需要,单击功能区上的插入选项卡。 在图形与文本组中,单击动态文本下拉箭头 。 在地图框下方,选择制作者名单。

    包含动态文本选择的下拉窗口

  2. 在描述性静态文本下方单击,以添加动态文本。

  3. 将动态文本元素与 8.25 英寸处的垂直参考线对齐。

    在文本元素中,Wellington City Council 这些单词是动态的。 该信息是惠灵顿中心地图的一种地图属性,如果该属性发生更改,它会在布局中自动更新。

    提示:

    要查看制作者名单,请使惠灵顿中心地图视图处于活动状态。 在内容窗格中,右键单击地图名称,然后单击属性 。 在地图属性对话框中,单击元数据选项卡,然后查找制作者名单框。

  4. 在布局视图中,右键单击所选动态文本元素,然后单击属性 。(您可能需要滚动到快捷菜单的底部。)

    随即出现元素窗格。 在文本选项卡选项选项卡 上的文本下,标签视图按钮 将默认处于选中状态。 在此视图中,动态文本显示为标签;其他文本是可编辑的静态文本。

    包含动态文本的元素窗格

    要查看如何格式化动态文本,请将鼠标悬停在标签上或单击文本视图按钮 。

  5. 在文本框中,单击制作者名单(静态文本,而不是标签)一词前面。 输入 Map authored by: 然后输入您的名字。 按 Enter 键以创建换行符。

    带有可编辑文本的文本框

  6. 在元素窗格顶部,单击文本符号选项卡。 根据需要,在常规选项卡 中,展开外观。

  7. 将大小设置更改为 8 磅,并将颜色设置更改为 50% 灰色(调色板上的第 6 行,第 1 列)。 单击应用。

    提示:

    可使用功能区的文本选项卡作出相同的更改。

  8. 关闭元素窗格。

  9. 单击布局的空白区域以取消选中文本。

  10. 在快速访问工具栏上,单击保存工程 。

添加总览图和范围矩形

要在较大的地理环境中显示惠灵顿中心,您将创建总览图。

  1. 在插入选项卡的地图框组中,单击地图框 。 在区域下,单击 Region 地图的第二个缩略图(使用书签作为源的缩略图)。

    Region 地图框列表

  2. 在现有地图框的顶部为地图框绘制一个小矩形。

    地图框已添加到布局中。 在内容窗格中,现在有两个地图框:Map Frame 1(新的地图框)和 Map Frame。 重命名将更易于对它们进行区分。

  3. 在内容窗格中,选中 Map Frame 1,然后单击名称 Map Frame 1 以使其处于可编辑状态。 输入Overview Map 并按 Enter 键。

  4. 在内容窗格中,单击地图框以将其选中,然后再次单击以使其名称可编辑。 输入 Main Map 并按 Enter 键。

    现在,您将修整总览图。

  5. 在内容窗格中,单击鹰眼图以将其选中。

  6. 在功能区上,单击地图框选项卡。 在编辑组中,单击修整下拉箭头,然后单击圆形 。

  7. 在布局的鹰眼图上,将鼠标悬停在惠灵顿市上方。 在地图框上拖动以绘制一个圆形。

    在鹰眼图框架上绘制的圆形

    根据地图框的大小,地图外观可能不同。

    总览图框修整为圆形。

  8. 将鹰眼图地图框拖动到主地图地图框的右上角。 使用选择控点调整总览图的大小,使其尽量美观。

    圆形地图框

    地图显示较大环境中的惠灵顿,但未表明主地图覆盖的特定区域。 将添加范围矩形以显示特定区域。

  9. 在功能区上,单击插入选项卡。 在地图框组中,单击范围指示器 ,然后单击主地图。

    概览地图上出现了一个范围指示器,但它是黑色的,在影像上很难看到。 名为“主地图范围”的项目即会添加至内容窗格并处于选中状态。

  10. 在功能区上,单击地图框选项卡。

  11. 在符号组中,确认填充颜色为 100% 透明。 更新以下设置:

    • 单击描边下拉箭头,选择一个亮黄色,例如太阳黄(调色板上第 3 行第 5 列)。

    • 将线宽更改为 2 磅。

    范围指示器现在可见。 接下来,您将调整概览地图的比例尺和范围。

  12. 单击功能区上的布局选项卡。 在地图组中,单击激活 。 将鹰眼图平移或缩放至您想要的范围。

    提示:

    使用功能区上的固定比例放大 和固定比例缩小 ,或在布局视图底部的比例框中设置一个值。

  13. 单击功能区上的布局选项卡。 在地图组中,单击关闭激活 。

    鹰眼图的边界会变浅,使其与周围的黑色空间相比更为鲜明突出。

  14. 在内容窗格中,单击鹰眼图以将其选中。

  15. 在功能区上,单击地图框选项卡。 在当前选择组中,单击下拉箭头,然后单击边框。

  16. 在边框组中,更新以下设置:

    • 单击描边下拉箭头,将颜色更改为灰色 50%(调色板上第 6 行第 1 列)。

    • 将线宽更改为 1.5 磅。

    鹰眼图上的地图框边框颜色即会更新。

  17. 单击布局中的空白区域可取消选中鹰眼图。

    最后,您将调整布局中元素的对齐方式。

  18. 按住 Shift 键。 在布局上,选择图例及其下方的两个文本元素。

    以上三个元素将与选择控点一同显示。

  19. 右键单击任何已选元素,指向分布 ,然后单击垂直分布 。

    元素间的垂直间距均等。 如果图例和文本矩形底部不包含空白区域,将达到最佳效果。

  20. 单击布局的空白区域以取消选中元素。

    已完成的布局

  21. 在快速访问工具栏上,单击保存工程 。

导出布局

在完成布局后,可将其打印或导出为可方便共享的文件。 您需要将布局导出为 .jpeg 文件。

  1. 单击功能区上的共享选项卡。 在输出组中,单击导出布局下拉箭头 ,然后单击 Web JPEG 。

    将显示导出布局窗格。

  2. 在名称框中,接受默认输出位置(工程的主目录文件夹)和文件名。 或者,单击浏览 并浏览至其他位置。

  3. 接受其他默认 JPEG 设置。 在窗格的底部,单击导出。

    提示:

    如果更改了任意设置并希望将其重用于导出其他布局,单击保存预设。 在保存设置后,它们将在布局导出选项库中显示。

  4. 导出完成后,单击位于窗格底部的查看导出的文件。

    随即默认图像查看应用程序中将打开该文件。 如果要打印布局,在共享选项卡的输出组中,单击打印布局 。 将布局发送到打印机之前,可能需要更改某些打印机设置(如页面方向)。

在本教程中,您使用了多个布局元素。 但仍有许多其他元素,如表、图表以及格网和经纬网,需要您自行了解。 您添加到布局中的每个元素都有其自身的设计和格式化选项。

该布局具有特殊用途 - 显示惠灵顿市中心建筑物的潜在太阳能。 布局还可以用作模板来生成空间地图系列:一组具有一致设计但代表不同地理范围的地图。