Partager un outil web
Vous pouvez partager des outils de géotraitement personnalisés que vous créez à partir de modèles ModelBuilder ou de scripts Python avec votre portail ArcGIS Enterprise. Contrairement à un outil partagé avec un paquetage de géotraitement, un outil web est hébergé sur (et s'exécute dans) votre serveur de portail ou un serveur fédéré avec votre portail. Vous pouvez accéder aux outils Web d’ArcGIS Pro et de Map Viewer, ainsi qu’à des applications Web personnalisées, comme celles créées avec ArcGIS Experience Builder.
Vue d’ensemble
- Cette vidéo a été créée avec ArcGIS Pro 3.6.
Dans ce didacticiel, vous allez partager un modèle de géotraitement existant sous forme d’outil Web et l’exécuter dans votre portail depuis ArcGIS Pro. Ce modèle récapitule la quantité d’une espèce de plante invasive spécifiée à proximité des lieux où les gens risquent d’entrer en contact avec la plante et de la propager accidentellement. Ce modèle est en grande partie le même que celui que vous concevez dans le didacticiel de démarrage rapide Créer un modèle de géotraitement. L’exécution de ce didacticiel au préalable n’est pas obligatoire, mais elle est utile pour vous familiariser avec les modèles de géotraitement ou mieux comprendre le fonctionnement du modèle.
Supposons que votre organisation prévoit de s’associer au gouvernement régional de la région de Marlborough en Nouvelle-Zélande pour accroître la surveillance des plantes invasives, telles que Nassella tussok et Nassella neesiana. Un site Web permet aux résidents concernés d’envoyer une adresse ou des coordonnées spatiales pour analyse. Les membres de votre équipe peuvent alors utiliser l’outil Web pour déterminer la quantité de plantes invasives à proximité.
Durée estimée : 45 minutes
Configuration logicielle requise :
ArcGIS Pro Basic
Appartenance à une organisation ArcGIS Enterprise avec un rôle d’administrateur ou un rôle personnalisé doté du privilège permettant de publier des outils Web
ArcGIS Enterprise 12.1 ou une version ultérieure
Remarque :
Il est recommandé d’utiliser des versions équivalentes d’ArcGIS Enterprise et ArcGIS Pro. Utiliser des versions non équivalentes peut être à l’origine d’avertissements, d’erreurs ou d’un comportement inattendu.
Remarque :
Les didacticiels de démarrage rapide sont mis à jour à chaque nouvelle version logicielle. Vous profiterez d’une expérience optimale si vous utilisez une version de l’aide en ligne correspondant à la version de votre logiciel.
Télécharger les données et ouvrir le projet
Vous devrez accéder à un navigateur web pour télécharger les données de projet. Pour télécharger les données et ouvrir le projet, procédez comme suit :
Accédez à la page de présentation Share a web tool v370 (Partager un outil Web v370) sur ArcGIS Online.
Cliquez sur Télécharger.
Dans le dossier Downloads (Téléchargements) de votre ordinateur, double-cliquez sur
Share_a_web_tool_v370.ppkxpour démarrer ArcGIS Pro et ouvrir le projet.
Le projet s'ouvre sur une vue cartographique de la région de Marlborough en Nouvelle-Zélande. Les couches représentant les plantes invasives et les lieux de contact figurent dans la fenêtre Contents (Contenu).
Exécuter le modèle en tant qu’outil de géotraitement
Avant de partager un outil sur le Web, vous devez l’exécuter dans un projet ArcGIS Pro. Cela garantit que l'outil peut accéder à ses données en entrée et qu'il s'exécute correctement. Pour comprendre la fonction de l’outil, examinez ce dernier dans une vue ModelBuilder.
Sur le ruban, cliquez sur l’onglet View (Vue). Dans le groupe Windows (Fenêtres), cliquez sur Pane Sets (Ensembles de fenêtres)
, puis sur Mapping (Cartographie)
.Ainsi, les fenêtres Contents (Contenu) et Catalog (Catalogue) sont ouvertes, et les autres sont fermées.
Activez la fenêtre Projet. Dans l’onglet Project (Projet), développez Toolboxes (Boîtes à outils)
, puis la boîte à outils Share_a_web_tool. Cliquez avec le bouton droit sur le modèle Summarize Invasive Species (Synthèse des espèces invasives), puis sélectionnez Edit (Mettre à jour).
Le modèle s'ouvre dans une vue.
Conseil :
Si le modèle complet n’apparaît pas dans la vue, cliquez sur Fit to Window (Ajuster à la fenêtre)
dans la barre d’état située en bas de la vue.En entrée, le modèle utilise des lieux de contact, tels que des terrains de camping ou des sentiers de randonnée, où les gens risquent d’entrer en contact avec des plantes invasives. Une distance de zone tampon autour de l'emplacement est spécifiée et une espèce de plante invasive est choisie. Le modèle calcule la quantité de plantes invasives dans la zone tampon (ou les zones, s'il existe plusieurs entités en entrée) et crée une classe d'entités en sortie avec les résultats.
Remarque :
Les outils peuvent être des outils intégrés
, des outils de modèle
ou des outils de script
. Reportez-vous à la rubrique Vocabulaire de géotraitement pour plus d’informations.Dans le modèle, survolez l'élément représentant l'outil Pairwise Buffer (Zone tampon deux par deux) pour en afficher les paramètres.

La sortie de l'outil Pairwise Buffer (Zone tampon deux par deux) est constituée de données intermédiaires utilisées uniquement comme entrée pour l'outil Summarize Within (Synthétiser - À l’intérieur). C'est la raison pour laquelle elle n'est pas écrite sur le disque mais dans un espace de travail en mémoire. Cela améliore les performances de l’outil et s’avère important lorsque vous créez des outils Web avec ModelBuilder.
Fermez la vue Summarize Invasive Species (Synthèse des espèces invasives) en cliquant sur Close (Fermer)
dans son onglet. Si vous avez modifié la vue, cliquez sur Yes (Oui) à l’invite pour enregistrer les modifications.Pour pouvoir partager le modèle en tant qu’outil Web, vous devez l’exécuter comme un outil de géotraitement local afin de vous assurer qu’il ne contient pas d’erreur.
Dans la fenêtre Catalogue, cliquez avec le bouton droit sur Summarize Invasive Species (Récapituler les espèces invasives) et sélectionnez Ouvrir.
L’outil s’ouvre dans la fenêtre Geoprocessing (Géotraitement). En haut de la fenêtre, l’onglet Parameters (Paramètres) est sélectionné.
Cliquez sur la flèche de la liste déroulante des paramètres Human Contact Locations (Lieux de contact humain) et sur Commercial Campgrounds (Terrains de camping privés).
Pour Buffer Distance (Distance de la zone tampon), saisissez 1,5. Changez les unités d'Unknown (Inconnu) en Kilometers (Kilomètres).
Cliquez sur la flèche de la liste déroulante Invasive Species (Espèces invasives), puis sur Nassella Tussock Range (Plage Nassella tussock).
Cliquez sur la flèche de la liste déroulante Area Unit of Measure (Unité de mesure de surface), puis sur HECTARES.
Dans la zone Output (Sortie), saisissez Nassella_Tussock_Near_Campgrounds.

La classe d’entités en sortie sera créée dans la géodatabase par défaut du projet.
Cliquez sur Run (Exécuter)
.Au terme de l’exécution de l’outil, un message s’affiche au bas de la fenêtre Geoprocessing (Géotraitement) et une couche est ajoutée à la fenêtre Contents (Contenu).
La nouvelle couche Nassella_Tussock_Near_Campgrounds est symbolisée par un contour noir et un remplissage vide. À l’échelle de la carte actuelle, les entités peuvent être masquées par les symboles de la couche Commercial Campgrounds (Terrains de camping privés).
Effectuez un zoom avant sur la carte pour voir les entités de zone tampon autour des terrains de camping.
Dans la fenêtre Contents (Contenu), cliquez avec le bouton droit sur la couche Nassella_Tussock_Near_Campgrounds et sélectionnez Attribute Table (Table attributaire)
.La table contient un enregistrement par terrain de camping.
Dans la table, cliquez avec le bouton droit sur l’en-tête du champ
Summarized area in HECTARESet choisissez Sort Descending (Tri décroissant)
.Quatre terrains de camping contiennent des plants de Nassella tussock dans un rayon de 1,5 km.
Fermez la table.
Dans la fenêtre Contents (Contenu), cliquez avec le bouton droit sur la couche Nassella_Tussock_Near_Campgrounds et sélectionnez Remove (Supprimer)
.Activez la fenêtre Projet. Dans l’onglet Project (Projet), développez le conteneur Databases (Bases de données)
, puis model_output.gdb.La géodatabase contient une classe d'entités nommée Nassella_Tussock_Near_Campgrounds. Il s'agit des données en sortie créées par l'outil.
Dans la Quick Access Toolbar (Barre d’outils Accès rapide), cliquez sur Save Project (Enregistrer le projet)
.
Configurer l’outil Web
Une fois que l’outil s’est exécuté correctement, vous pouvez le configurer en tant qu’outil Web. Vous allez le partager avec votre organisation afin que vos collègues puissent y accéder à partir d’ArcGIS Pro et d’autres applications clientes. L’hébergement de l’outil Web dans votre portail le rend accessible dans l’ensemble de votre organisation.
Sur le ruban, cliquez sur l’onglet Share (Partager). Dans le groupe Share As (Partager en tant que), cliquez sur la flèche de la liste déroulante Web Tool (Outil Web), puis sélectionnez Share Web Tool (Partager un outil Web)
.Remarque :
Cette commande n’est pas disponible si vous n’êtes pas connecté à un portail ArcGIS Enterprise. Vous devrez peut-être gérer vos connexions au portail.
Dans la fenêtre Select Tool To Share (Sélectionner l’outil à partager), cochez la case Summarize Invasive Species (Synthèse des espèces invasives).

Remarque :
Il est recommandé d’exécuter votre outil avant la publication afin de s’assurer qu’il fonctionne comme prévu et ne contient aucune erreur. Vous pouvez publier des outils sans les exécuter au préalable, mais cela n’est recommandé que pour les outils qui ne peuvent pas être exécutés en local, comme ceux qui utilisent des chemins de données codés en dur accessibles uniquement avec ArcGIS Server.
Cliquez sur OK.
La fenêtre Share As Web Tool (Partager en tant qu'outil web) s'affiche.
Conseil :
Vous pouvez également ouvrir la fenêtre en procédant de la manière suivante :
Sur le ruban, cliquez sur l’onglet Analysis (Analyse).
Dans le groupe Geoprocessing (Géotraitement), cliquez sur History (Historique)
.Dans la fenêtre History (Historique), cliquez avec le bouton droit sur l’entrée Summarize Invasive Species (Synthèse des espèces invasives), sélectionnez Share As (Partager en tant que), puis cliquez sur Share Web Tool (Partager un outil Web)
.
Si un message d'erreur s'affiche en haut de la fenêtre, il se peut que votre compte ne dispose pas du privilège requis pour partager des outils web. Pour le didacticiel ci-avant, consultez la configuration logicielle requise.
Sur l'onglet General (Général), sous Item Details (Détails de l'élément), les zones Name (Nom), Summary (Résumé) et Tags (Balises) sont renseignées à l'aide des métadonnées qui ont été créées précédemment pour l'outil.
Sous Data (Données), en regard de Non-URL Data (Données non-URL), survolez l’icône d’informations
avec votre souris et lisez le message qui apparaît.Conseil :
Alors que le message d’aide est affiché, vous pouvez appuyer sur la touche F1 pour en savoir plus sur ce paramètre.
Sous Non-URL Data (Données non-URL), cliquez sur Copy all data (Copier toutes les données).
Les jeux de données des plantes invasives sont les données officielles qui doivent être utilisées avec l'outil. Ces données n’étant pas inscrites sur le serveur, elles y sont copiées lors du partage de l’outil Web. Strictement parlant, vous n’avez pas besoin de modifier le paramètre par défaut car les données non inscrites sont copiées avec l’une ou l’autre de ces options. Toutefois, l’option Copy all data (Copier toutes les données) décrit clairement le comportement réel.
Sous Data (Données), en regard d’URL Data (Données URL), survolez l’icône d’informations
avec votre souris et lisez le message qui apparaît.Ce projet n’utilise pas de données URL. Le paramètre par défaut peut rester tel quel.
Sous Location (Emplacement), acceptez les paramètres par défaut.
L’outil Web est enregistré au niveau racine de My Content (Mon contenu)
dans votre portail ArcGIS Enterprise.Sous Sharing Level (Niveau de partage), cliquez sur Organization (Organisation).
Tous les membres de l'organisation qui peuvent créer un contenu pourront également exécuter l'outil web.
[En savoir plus sur les paramètres généraux de l’outil Web](../help/analysis/geoprocessing/share-analysis/web-tool-settings.md#991)En haut de la fenêtre, cliquez sur l'onglet Configuration.
Dans ce didacticiel, vous allez utiliser les paramètres par défaut.
[En savoir plus sur les paramètres de configuration de l’outil Web](../help/analysis/geoprocessing/share-analysis/web-tool-settings.md#201)Cliquez sur l’onglet Contenu.

Dans la partie supérieure de la fenêtre, le dossier dans lequel l’outil Web sera stocké sur votre portail apparaît dans My Content (Mon contenu). Dans la partie inférieure de la fenêtre figurent les propriétés de l’outil que vous pouvez configurer.
Dans la partie inférieure de la fenêtre, dans la zone de texte Description, saisissez (ou copiez et collez) le texte suivant : Finds and summarizes invasive species within a buffer zone of designated locations (Recherche et récapitule les espèces invasives dans une zone tampon d’emplacements désignés).
Sous Parameters (Paramètres), développez Human Contact Locations (Lieux de contact humain).
La description du paramètre vient des métadonnées de l'outil de géotraitement.
Cliquez sur la flèche de la liste déroulante Input Mode (Mode en entrée) et sélectionnez User defined value (Valeur définie par l’utilisateur).
Le plan consistant à ce que les citoyens concernés envoient des localisations à analyser, la valeur doit être définie par l’utilisateur et non provenir d’une liste prédéfinie.
Sous le paramètre de mode en entrée, le type de géométrie par défaut est Point. En effet, vous avez utilisé une couche de points (Commercial Campgrounds) pour les lieux de contact lorsque vous avez exécuté l’outil dans la section précédente. Vous pouvez également afficher la structure de table qui sera utilisée pour les couches ponctuelles créées de façon interactive. Il s’agit de la structure de la couche Commercial Campgrounds (Terrains de camping privés).

Lorsque les utilisateurs d’outils Web ajoutent des localisations à analyser avec le bouton de saisie interactive
, ils créent des entités ponctuelles par défaut. Les autres types de géométries (ligne, polygone et multipatch) sont disponibles dans la liste déroulante. Compte tenu de l’utilisation prévue de cet outil, les utilisateurs créent toujours des points.Conseil :
Vous pouvez restreindre les types de géométrie disponibles comme entrée interactive dans l’outil Web en plaçant un filtre de paramètres sur le paramètre de modèle approprié avant d’exécuter le modèle comme outil. Dans notre cas, vous placez un filtre de type d’entité sur le paramètre Human Contact Location (Lieux de contact humain) et définissez sa valeur sur Point. Pour cela, mettez à jour le modèle et ouvrez ses propriétés. Dans la boîte de dialogue Tool Properties (Propriétés de l’outil), cliquez sur l’onglet Parameters (Paramètres), puis dans la colonne Filter (Filtrer).
Développez le paramètre Buffer Distance (Distance de la zone tampon).
Par défaut, le mode en entrée pour ce paramètre est défini sur User defined value (Valeur définie par l’utilisateur). La valeur par défaut est 1,5 kilomètre. Il s’agit du paramètre que vous avez utilisé lors de l’exécution de l’outil. L’utilisateur de l’outil Web peut modifier cette valeur, mais vous allez conserver la valeur par défaut.
Développez le paramètre Invasive Species (Espèces invasives).
Le mode en entrée par défaut est Choice list (Liste de choix). L’utilisateur de l’outil web doit pouvoir choisir une espèce de plantes invasives à analyser, mais aucune autre couche ne doit être disponible. Les données des couches que vous sélectionnez dans la liste de choix seront copiées sur le serveur.
Dans la liste des couches, désélectionnez les cases à cocher des couches suivantes :
Commercial Campgrounds (terrains de camping privés)
Emplacements de camping
Parcours
Routes
Zones peuplées
Région

Laissez les cases cochées pour les quatre types de plantes invasives. (La case à cocher Nassella Tussock Range [Plage Nassella tussock] ne peut pas être décochée).
Développez le paramètre Area Unit of Measure (Unité de mesure de surface).
Pour assurer la cohérence des rapports, votre organisation utilisera les hectares comme unité de mesure pour l'analyse de toutes les plantes invasives. Vous ne voulez pas que les utilisateurs de l'outil choisissent une autre unité.
Cliquez sur la flèche de la liste déroulante Input Mode (Mode en entrée) et sélectionnez Constant value (Valeur constante).
La valeur constante est automatiquement définie en hectares, l'unté de mesure que vous avez choisie lors de l'exécution de l'outil. Les utilisateurs ne verront pas ce paramètre sur l'outil web.
Développez le paramètre Output (Sortie). Dans la zone Name (Nom), remplacez le nom par défaut par Invasive Grass Summary (Récapitulatif des plantes invasives).
Il s’agit du nom de la couche en sortie créée lors de l’exécution de l’outil Web. (En réalité, il ne s’agit pas du nom de la classe d’entités en sortie stockée dans la géodatabase par défaut du projet.)
Dans la zone de texte Description, saisissez (ou copiez et collez) le texte suivant : The name of the output layer that is created when the web tool runs. (Nom de la couche en sortie créée lors de l’exécution de l’outil Web.)
Sous Parameter Configuration (Configuration des paramètres), acceptez les valeurs par défaut. Laissez la case Add optional Output Feature Service Name parameter (Ajouter le paramètre facultatif Nom du service d’entités en sortie) cochée.
Si elle est cochée, ce paramètre apparaît sur l’outil Web. Il permet à l’utilisateur de l’outil Web d’écrire les résultats de l’analyse dans un service d’entités du portail, ainsi que dans une géodatabase fichier locale.
En savoir plus sur l’utilisation des outils Web avec un service d’entités en sortie
Partager l’outil Web
Vous allez analyser l'outil à la recherche d'avertissements ou d'erreurs et le partager sur votre portail.
Au bas de la fenêtre, sous Finish Sharing (Terminer le partage), cliquez sur Analyze (Analyser).
Un onglet Messages, en haut de la fenêtre, affiche des avertissements et des erreurs. Les avertissements sont regroupés par quatre.
Remarque :
Si vos versions ArcGIS Enterprise et ArcGIS Pro ne sont pas équivalentes, des avertissements supplémentaires peuvent apparaître. Il est recommandé d’utiliser des versions équivalentes dans la mesure du possible. Toutefois, dans le cadre de ce didacticiel, vous pouvez ignorer les avertissements.
Développez le groupe et survolez l'un des avertissements.
L’avertissement vous informe (comme vous le savez déjà) que la source de données n’est pas inscrite et sera copiée sur le serveur. Le même avertissement apparaît pour chaque type de plante invasive. Avec des jeux de données volumineux, la copie de données sur le serveur peut ralentir le partage. Dans notre cas, les jeux de données sont petits et copiés rapidement.
Conseil :
Lorsque vous survolez un avertissement ou un message d’erreur, cliquez sur Options
pour effectuer la mesure corrective ou ouvrir une rubrique d’aide associée.Cliquez sur Publish (Publier).
Lorsque l'outil est partagé sur votre portail, un message s'affiche au bas de la fenêtre.
Remarque :
Si un outil Web de même nom existe déjà dans votre portail, vous obtenez une erreur de publication. Cliquez sur OK dans le message d’erreur. Dans la fenêtre Share As Web Tool (Partager en tant qu'outil web), cliquez sur l’onglet General (Général). Dans la zone Name (Nom), mettez à jour le nom de l'outil (n'incluez pas d'espace). Au bas de la fenêtre, cliquez à nouveau sur Publish (Publier).
Dans le message de réussite, cliquez sur Manage the web tool (Gérer l’outil Web) pour ouvrir un navigateur Web sur votre portail ArcGIS Enterprise. Connectez-vous si vous y êtes invité.
La page des éléments de l'outil web apparaît. Vous pouvez y revenir ultérieurement pour ajouter davantage de métadonnées et une image miniature.
En haut du site, cliquez sur Content (Contenu).

Fermez l’onglet ou la fenêtre du navigateur qui affiche le contenu de votre portail.
Dans la section suivante, vous allez ouvrir l’outil Web d’ArcGIS Pro et créer une entité dont la proximité avec la plante Nassella tussock doit être analysée.
Ouvrir l’outil Web et créer une entité à analyser
Vous allez ouvrir l’outil Web, créer une couche modifiable, puis ajouter une entité ponctuelle à une localisation à analyser. Cela simule votre cas d’utilisation prévu : un résident concerné souhaite s’informer sur une plante invasive à proximité d’une maison ou d’une entreprise.
Dans ArcGIS Pro, activez le volet Catalog (Catalogue). Cliquez sur l'onglet Portal (Portail) en haut de la fenêtre.

L’élément d’outil Web SummarizeInvasiveSpecies s’affiche dans l’onglet My Content (Mon contenu)
.Remarque :
Pour les autres membres de votre organisation, l’outil apparaît dans l’onglet My Organization (Mon organisation)
. Vous pouvez également le trouver dans l’onglet ArcGIS Enterprise
.Double-cliquez sur l'élément d'outil web SummarizeInvasiveSpecies, puis sur l'outil web Synthèse des espèces invasives.

L’outil s’ouvre dans la fenêtre Geoprocessing (Géotraitement). Les paramètres Buffer Distance (Distance de la zone tampon) et Invasive Species (Espèces invasives) sont définis par défaut. Ces paramètres peuvent être modifiés, mais vous allez les accepter pour l’instant. Notez que l’outil n’affiche pas de paramètre pour les unités de mesure ou la classe d’entités en sortie. Vous avez la possibilité de créer un service d'entités en sortie (si vous disposez d'un rôle d'éditeur), mais vous n'effectuerez pas cette opération dans ce didacticiel.
Pour le paramètre Human Contact Locations (Lieux de contact humain), vous pouvez fournir des données en entrée de différentes façons. Vous pouvez choisir une couche dans la carte actuelle, accéder à un jeu de données ou une couche d’entités web, ou créer des entités de façon interactive dans une nouvelle classe d’entités. En ce qui concerne votre outil, l'entrée interactive est la méthode la plus adaptée.
En regard de Human Contact Locations (Lieux de contact humain), cliquez sur le bouton Interactive input (Entrée interactive)
. Cliquez sur le bouton et non sur la flèche de la liste déroulante.Une couche modifiable est ajoutée à la fenêtre Contents (Contenu). Dans la fenêtre Geoprocessing (Géotraitement), un modèle d’entité apparaît et la barre d’outils de construction s’affiche sur la carte. De plus, une classe d’entités ponctuelles est créée dans votre géodatabase par défaut.
Avant d’ajouter un emplacement de façon interactive, vous allez renommer la couche et choisir un autre symbole.
Dans la fenêtre Contents (Contenu), cliquez sur la couche Summarize_Invasive_Species_Human_Contact_Locations_Points pour rendre son nom modifiable. Saisissez Citizen Request (Requête citoyenne) et appuyez sur la touche Entrée.
Sous le nouveau nom de la couche, cliquez sur son symbole par défaut.
La fenêtre Symbology (Symbologie) s’affiche. Elle présente les options de mise en forme des symboles de point.
En haut de la fenêtre, vérifiez que l’onglet Gallery (Bibliothèque) est sélectionné. Dans la zone de recherche, saisissez Esri Pin (Punaise Esri) et appuyez sur la touche Entrée.
Dans la liste des résultats, cliquez sur le symbole Esri Pin 1 (Punaise Esri 1).

Remarque :
Le nombre de résultats peut être moindre si la recherche sémantique n’est pas activée.
Le symbole de couche est actualisé dans la fenêtre Contents (Contenu).
Pour créer une entité sur la carte, vous allez ouvrir le modèle de mise à jour d’entité et choisir un outil de mise à jour.
Activez la fenêtre Geoprocessing (Géotraitement). Dans le paramètre Human Contact Locations (Lieux de contact humain), cliquez sur Citizen Request (Requête citoyenne).

Le modèle de mise à jour d’entité se développe. L’outil Point (Point)
est sélectionné par défaut.
Supposons que vous ayez été contacté par la propriétaire d'un vignoble qui pense avoir vu de la Nassella tussock près de sa propriété.
Sur le ruban, cliquez sur l’onglet Map (Carte). Dans le groupe Inquiry (Requête), cliquez sur Locate (Localiser)
.La fenêtre Locate (Localiser) s’ouvre. Dans la fenêtre, l'onglet Locate (Localiser) est sélectionné.
Dans la fenêtre Locate (Localiser), cliquez sur Options
et vérifiez qu’ArcGIS World Geocoding Service ou un autre fournisseur de localisation est disponible et activé.Si le seul fournisseur est XY Provider (Fournisseur XY), utilisez les coordonnées spatiales au lieu d’une adresse dans l’étape suivante.
Cliquez dans la zone de recherche. Saisissez (ou copiez et collez) New Zealand State Highway 6 and Rapaura Road, Renwick, 7273 et appuyez sur la touche Entrée. Vous pouvez également saisir ces coordonnées dans la zone de recherche : 173.8170288°E 41.4865202°S.
La carte applique un zoom sur l’emplacement et un symbole ponctuel temporaire est positionné à l'intersection de rue.

Survolez la localisation et cliquez pour créer une entité ponctuelle dans la couche Citizen Request (Requête citoyenne).
La nouvelle entité est sauvegardée automatiquement.
Dans la barre d’outils de mise à jour, en bas de la carte, cliquez sur Finish (Terminer)
.Dans la fenêtre Locate (Localiser), dans la zone de recherche, mettez en évidence l’adresse (ou les coordonnées) et appuyez sur Ctrl + C pour copier le texte.
Vous allez ajouter ces informations à l’enregistrement de l’entité dans la table attributaire, dans la section suivante. À présent, vous pouvez éventuellement coller le texte dans le Bloc-notes Microsoft ou un éditeur de texte pratique.
Dans la zone de recherche, cliquez sur Delete (Supprimer)
pour effacer le résultat et retirer le symbole ponctuel temporaire de la carte.En bas de la vue cartographique, cliquez sur la flèche de la liste déroulante d’échelle de carte et cliquez sur 1:10 000.
Si cette échelle n'apparaît pas dans votre liste d'échelles prédéfinies, vous pouvez la saisir dans la case de l'échelle.
Dans la fenêtre Contents (Contenu), activez la couche World Imagery (Imagerie mondiale).

Il y a des bâtiments aux environs et certains correctifs de Nassella Tussock. Vous êtes prêt à utiliser l’outil Web et à analyser la localisation.
Exécuter l’outil Web
Vous allez exécuter l’outil Web pour créer une zone tampon autour de la localisation et y récapituler la quantité de plantes Nassella tussock.
Gardez à l’esprit que les entités de plantes invasives ne représentent pas une surface entièrement recouverte, mais plutôt les limites à l’intérieur desquelles des parcelles de plantes invasives ont été trouvées. Certaines surfaces sont plus infestées que d'autres. Les calculs de quantité de plantes invasives dans une zone tampon sont approximatifs.
Activez la fenêtre Geoprocessing (Géotraitement)
et vérifiez que le paramètre Human Contact Locations (Lieux de contact humain) est défini sur la couche Citizen Request (Requête citoyenne).Cliquez sur Run (Exécuter)
.Au terme de l’opération, un message apparaît au bas de la fenêtre Geoprocessing (Géotraitement). Dans la fenêtre Contents (Contenu), une couche nommée Invasive Grass Summary (Récapitulatif des plantes invasives) est ajoutée à la carte.
Dans la fenêtre Contents (Contenu), cliquez avec le bouton droit sur la couche Invasive Grass Summary (Récapitulatif des plantes invasives) et choisissez Zoom To Layer (Zoom sur la couche)
.La carte effectue un zoom sur l’étendue de la zone tampon de 1,5 kilomètre.

Dans la fenêtre Contents (Contenu), cliquez avec le bouton droit sur la couche Invasive Grass Summary (Récapitulatif des plantes invasives) et choisissez Attribute Table (Table attributaire)
.Dans la table, le champ
Summarized area in HECTARESindique qu'environ 20 hectares de Nassella tussock se trouvent dans la zone tampon.Dans le tableau, dans le champ
Name, double-cliquez sur la cellule de valeur nulle pour la rendre modifiable. Appuyez sur Ctrl + V pour coller l’adresse (ou les coordonnées) de la localisation que vous avez analysée. Appuyez sur la touche Entrée pour valider le changement.
Sur le ruban, cliquez sur l’onglet Edit (Modifier). Dans le groupe Manage Edits (Gérer les mises à jour), cliquez sur Save (Enregistrer)
. À l’invite Save Edits (Enregistrer les modifications), cliquez sur Yes (Oui).Fermez la table attributaire.
Remarque :
Avant d’exécuter l’outil Web, vous pouvez créer plusieurs entités en entrée de manière interactive. Chaque entité sera mise en zone tampon et synthétisée. Vous pouvez également exécuter l'outil plusieurs fois tout en continuant à ajouter des entités de façon interactive. À chaque exécution de l'outil, une nouvelle classe d'entités en sortie est créée.
Une fois que vous avez exécuté l’outil, vous pouvez ajouter d’autres entités en cliquant sur le bouton de saisie interactive
. Toutefois, cette opération remplace la couche existante (Citizen Request (Requête citoyenne)) et son jeu de données source. Pour reprendre la mise à jour sans remplacer la couche, vous pouvez créer des entités dans la fenêtre** Create Features (Créer des entités)**.
Afficher les données en sortie et l’historique de géotraitement
Les jeux de données source des couches Citizen Request (Requête citoyenne) et Invasive Grass Summary (Récapitulatif des plantes invasives) se trouvent dans la géodatabase model_output par défaut. Les résultats d'analyse sont stockés dans l'historique de géotraitement du projet.
Activez la fenêtre Catalog (Catalogue)
. En haut de la fenêtre, cliquez sur l’onglet Project (Projet).Le cas échéant, développez le conteneur Databases (Bases de données)
, puis la géodatabase model_output.La géodatabase contient une classe d’entités nommée
feature_set<number>. Il s'agit de la source de données de la couche Invasive Grass Summary (Récapitulatif des plantes invasives). Elle contient également une classe d’entités nomméeSummarize_Invasive_Species_Human_Contact_Locations_Points. Il s'agit de la source de données de la couche Citizen Request (Requête citoyenne).Sur le ruban, cliquez sur l’onglet Analysis (Analyse). Dans le groupe Geoprocessing (Géotraitement), cliquez sur History (Historique)
.
La fenêtre History (Historique) apparaît. Elle contient des entrées pour vos deux opérations de géotraitement réussies : l’outil Web
et l’outil bureautique
. Survolez les entrées pour voir les détails de chaque opération.Dans la Quick Access Toolbar (Barre d’outils Accès rapide), cliquez sur Save Project (Enregistrer le projet)
.
Les outils web fonctionnent comme les outils de modèle et de script personnalisés sur lesquels ils se fondent et génèrent les mêmes résultats. Ils peuvent être facilement mis à la disposition des utilisateurs dans votre organisation et partagés publiquement. Vous pouvez remplacer un outil Web si vous avez besoin de le modifier.
Lorsque vous exécutez un outil web, le géotraitement est effectué sur le serveur du portail, pas sur votre ordinateur. Les données en sortie sont renvoyées à partir du serveur et écrites dans la géodatabase par défaut du projet.
ArcGIS Pro n’est pas la seule application cliente qui peut exécuter des outils Web. Vous pouvez aussi utiliser des outils Web dans des applications Web, telles que Map Viewer.