データの空間的な結合
結合方法では、1 つのデータ テーブル (結合テーブル) から別のデータ テーブル (ターゲット テーブル) にフィールドを追加します。 ターゲット テーブルは通常はレイヤーの属性テーブルで、結合の目的は、レイヤーのシンボル表示、クエリーの実行、統計の取得、または結合テーブルの情報を使用してその他の解析を実行することなどがあります。 結合は一時的なものとして、必要なくなった時点で削除することができます。永続的な結合にすることもできます。
結合には、属性と空間の 2 種類があります。 属性結合は、両方のテーブルに存在する共通の値のフィールドに基づきます。 共通フィールドによって、結合テーブル内のレコードがターゲット テーブル内のレコードと正確に一致するようになります。 空間結合は、2 つのレイヤーのフィーチャ間の空間リレーションシップ (格納や交差など) に基づきます。 結合テーブルとターゲット テーブル内のレコードは、フィーチャの空間リレーションシップに基づいて照合されます。
属性結合では、結合テーブルはスタンドアロン (非空間) テーブルでも、レイヤーの属性テーブルでもかまいません。 空間結合では、両方のテーブルがレイヤーの属性テーブルでなければなりません。
結合は、ArcGIS Pro でデータを組み合わせる多くの方法の 1 つです。 アペンド ツールで 1 つのデータセットから別のデータセットにフィーチャを追加し、マージ ツールでデータセットを結合して、インターセクト や ユニオン などのオーバーレイ ツールでデータセットを空間的に比較して新しいデータを作成できます。
概要
- この動画は ArcGIS Pro 3.6 で作成されました。
2011 年 2 月 22 日にニュージーランドのクライストチャーチを襲った地震は、都市のインフラストラクチャーに甚大な被害をもたらしました。 地震の直後、このエリアでは、修復や再建の必要性を判断するためのエンジニアリング評価が行われました。
このチュートリアルでは、クライストチャーチ市街地の歴史的な場所を、液状化リスクのレイヤーと関連付けて確認します。 液状化とは、地面の揺れによって堆積物が強度と安定性を失うプロセスで、建物に損害が生じる可能性が大幅に高まります。 液状化リスクのレイヤーと歴史的な場所のレイヤーを空間結合させ、歴史的な場所のそれぞれに適切なリスク値を割り当てます。
レイヤーを空間結合した後、歴史的な場所のレイヤーに新しいフィーチャをアペンドし、液状化リスクの値を更新します。
所要時間: 60 分
ソフトウェア要件:
- ArcGIS Pro Basic
注意:
ソフトウェア リリースごとにクイックスタート チュートリアルが更新されます。 最適なユーザー エクスペリエンスを得るには、お使いのソフトウェアと同じバージョンのオンライン ヘルプを使用します。
プロジェクトを開く
ArcGIS Online のプロジェクト パッケージからプロジェクトを開きます。
ArcGIS Pro を起動して、必要に応じてサイン インします。
参照ダイアログ ボックスを開き、次のいずれかの方法でプロジェクトを探します:
開始ページにある 別のプロジェクトを開く
をクリックします。プロジェクトが開いている状態で、リボン上の プロジェクト タブをクリックします。 サイド タブのリストで 開く をクリックします。 開く ページで 別のプロジェクトを開く
をクリックします。
プロジェクトを開く 参照ダイアログ ボックスのナビゲーション ウィンドウで、ポータル
の下の ArcGIS Online
をクリックします。注意:
ArcGIS Enterprise
にサイン インしている場合は、チュートリアル データにアクセスするため、ArcGIS Online にアクティブなポータルを設定する必要があります。 これを行うことができない場合は、ブラウザーからデータをダウンロードできます。ダイアログ ボックスの上部にある 検索 ボックスに「Join data spatially」と入力して、Enter キーを押します。
検索結果のリストで、データの空間的な結合 をクリックし、プロジェクト パッケージを選択します。
注意:
この名前のプロジェクト パッケージが複数ある場合、信頼済み バッジ
が付いたパッケージを選択します。 所有者 列に、所有者の名前が ArcGISProTutorials と表示されます。 結果が表示されない場合は、「検索結果が返されない」をご参照ください。OK をクリックします。
プロジェクトが開き、ニュージーランドのクライストチャーチ市街地を示すマップが表示されます。

リボンの 表示 タブをクリックします。 ウィンドウ グループで、ウィンドウ セット
をクリックして マッピング
をクリックします。これにより、コンテンツ ウィンドウと カタログ ウィンドウが開き、他のウィンドウが閉じられます。
データの表示
Historic Places (歴史的な場所) レイヤーと Liquefaction Risk (液状化リスク) レイヤーの属性を調べます。
コンテンツ ウィンドウで Historic Places レイヤーを右クリックし、属性テーブル
をクリックします。属性には、各フィーチャの名前、住所、および
RegIDフィールド内の歴史登録番号が含まれます。 テーブル ビューの下部で、レイヤー内に 322 のレコードが存在することを確認できます。コンテンツ ウィンドウで Liquefaction Risk レイヤーを右クリックし、属性テーブル
をクリックします。このレイヤーの属性には、リスク カテゴリーと、リスク評価が行われた日付と最終変更日付が含まれます。
Categoryフィールドでは、3 つの技術カテゴリーの値によって、今後の地震での液状化による建物の損害リスクの高まりを表しています。技術カテゴリー 1 は、最小の損害リスクを表します。
技術カテゴリー 2 は、微量から中程度までの損害リスクを表します。
技術カテゴリー 3 は、中程度から重大までの損害リスクを表します。
リスクに応じて、さまざまな建設要件が適用されます。 赤色ゾーンは、リスクが極度に大きく、建設はまったく許可されません。 非住居エリアや評価が必要だと指定されたエリアでは、リスク評価は行われていません。
開いた両方のテーブルを閉じます。
コンテンツ ウィンドウで、Liquefaction Risk レイヤーが選択されていることを確認します。 Ctrl キーを押しながら Historic Places レイヤーをクリックします。
両方のレイヤーが選択されます。
リボンの マップ タブをクリックします。 ナビゲーション グループで、マップ操作
ツールのドロップダウン矢印をクリックして、コンテンツで選択 をクリックします。マップ上の位置をクリックすると、選択したレイヤー内のフィーチャの属性値がポップアップに表示されます。
マップ ビューの下部で、マップ縮尺ドロップダウン矢印をクリックし、1:10,000 をクリックして、歴史的な場所を識別しやすくします。
マップ上で、歴史的な場所をクリックします。

このポップアップには、歴史的な場所の属性と、それを含むリスクのポリゴンが表示されます。
ヒント:
ポップアップの上部には、両方のレイヤーのフィーチャの表示値、つまりプライマリー属性が表示されます。 この例では、Cottage という名前のフィーチャが選択され、その属性がウィンドウの下部に表示されています。 液状化リスクのフィーチャの属性を表示するには、ポップアップ上部の Liquefaction Risk の下の値をクリックします。
歴史的な場所のフィーチャをいくつか追加でクリックして、ポップアップ ウィンドウを閉じます。
このポップアップには、対象の情報 (歴史的な場所のそれぞれに関連付けられたリスク カテゴリー) が表示されます。 ただし、一度に 1 つずつフィーチャをクリックするのは、この情報を得るための最も効率的な方法ではありません。 空間結合を使用して、液状化リスクの属性を Historic Places レイヤーに追加できます。
コンテンツ ウィンドウで Historic Places レイヤーをクリックして、これを唯一の選択したレイヤーにします。 レイヤーを右クリックし、レイヤーにズーム
をクリックします。
レイヤーの空間的な結合
歴史的な場所のそれぞれが存在するリスク ゾーンに従って、Liquefaction Risk レイヤーから Historic Places レイヤーに属性を結合します。
コンテンツ ウィンドウで Historic Places レイヤーを右クリックし、結合とリレート をポイントして 空間結合の追加
をクリックします。フローティング ウィンドウ内に 空間結合の追加 ツールが開きます。 ターゲット フィーチャ パラメーターが Historic Places レイヤーに正しく設定されています。
フィーチャの結合 ドロップダウン矢印をクリックし、Liquefaction Risk を選択します。
このレイヤーからの属性が Historic Places テーブルに結合されます。
マッチ オプション ドロップダウン矢印をクリックして、含まれる をクリックします。
歴史的な場所のそれぞれが、自らが含まれる液状化リスクのポリゴンの属性を取得します (この場合は、交点のデフォルトのマッチ オプションも機能する可能性があります。別のフィーチャ内にあるフィーチャもそれと交差しているからです)。
永続的にフィールドを結合 チェックボックスをオンにします。
このチェックボックスがオフ (デフォルト設定) の場合、空間結合は現在のマップ内のみに存在し、いつでも削除できます。 ターゲット テーブルのソース データは変更されません。 このチェックボックスをオンにすると、結合された属性によってターゲット テーブルのソース データが変更されます。
チュートリアルの後半で Historic Places レイヤーにさらにフィーチャをアペンドするので、ここでは永続的な結合にします。 レイヤーに一時的な結合が存在する場合、この操作は実行できません。
ヒント:
このワークフローでは 空間結合 ジオプロセシング ツールも使用できます。 空間結合 ツールは、ターゲット フィーチャの属性と結合フィーチャの属性を持つ新しいフィーチャクラスを作成します。 入力データセットは変更されません。 このチュートリアルでは、代わりに 空間結合の追加 を使用することで、新しい出力データセットを作成せずに結合を実行できるようにします。
フィールド 見出しを展開します。
フィールド マップ パラメーターに、Liquefaction Risk レイヤー内のフィールドのリストが表示されます。 これらのフィールドのうち、Historic Places レイヤーに追加する必要があるのは
CATEGORYフィールドのみです。 このフィールド以外は削除します。フィールドのリストで、
CREATEDDATEフィールドをクリックして選択します。 Shift キーを押しながらShape_Areaフィールドをクリックします。4 つのフィールドが選択されます。
削除
をクリックします。
選択したフィールドが削除され、
CATEGORYフィールドのみが残ります。Liquefaction Risk レイヤーで、
CATEGORYフィールドの意味は明確です。 ただし、歴史的な場所のコンテキストでは意味が不明瞭です。 ツールを実行する前にフィールド名を変更します (Liquefaction Risk テーブルには元の名前が残ります)。フィールド マップ パラメーターで、編集
をクリックします。フィールド プロパティ ダイアログ ボックスが表示されます。 上部の プロパティ の下に、
CATEGORYフィールドのプロパティ (名前、エイリアス、タイプなど) が表示されます。フィールド名 セルで、既存の値 (
CATEGORY) をハイライト表示し、「LIQUEFACTION_RISK」に置き換えます。エイリアス セルで、既存の値をハイライト表示し、「Liquefaction Risk」に置き換えます。

エイリアスとは、属性テーブルと大部分のジオプロセシング コンテキストにデフォルトで表示される表示名です。 エイリアスにはスペースを含めることができますが、フィールド名には含めることができません。
フィールド プロパティ ダイアログ ボックスで OK をクリックします。

OK をクリックして、空間結合の追加 ツールを実行します。
操作が完了したら、コンテンツ ウィンドウで Historic Places レイヤーを右クリックし、属性テーブル
をクリックします。名前変更された
Categoryフィールドが Liquefaction Risk レイヤーからテーブルに追加され、そのエイリアスLiquefaction Riskが表示されます。 これで、歴史的な場所のそれぞれが、自らが含まれるポリゴンのリスク カテゴリーと関連付けられました。Join_Countフィールドも追加されました。 このフィールドの値はすべてのレコードで 1 です。歴史的な場所のそれぞれが 1 つのリスク ポリゴンと正確に関連付けられているからです。Join_Countフィールドは削除します。必要ないからです。Historic Places テーブルで、Join_Count フィールド見出しをクリックしてフィールドを選択します。

選択したフィールド見出しを右クリックして、削除
をクリックします。フィールドの削除 プロンプトで、はい をクリックします。
Historic Places テーブルは開いたままにしておきます。
ヒント:
テーブル内のフィールドを非表示にして、削除せずに見えなくすることもできます。
ヒント:
必要に応じて、さらに大きなマップの表示空間が提供される新しい位置まで、テーブルをビュー タブでドラッグできます。 たとえば、2 つのモニターがある場合、ArcGIS Pro ウィンドウの外にテーブルをフローティングできます。
クイック アクセス ツールバー で プロジェクトの保存
をクリックします。
結果の評価
Historic Places テーブルのデータ エンジニアリング ビューを開いて、結合テーブルの統計情報を表示し、チャートを作成します。
Historic Places テーブルで、
Liquefaction Riskフィールド見出しをクリックしてフィールドを選択します。選択した見出しを右クリックして、統計の探索
をクリックします。
テーブルのデータ エンジニアリング ビューが開き、
LIQUEFACTION_RISKフィールドの統計が表示されます。カウント値は 322 (100%) です。 これにより、歴史的な場所のそれぞれに液状化リスクの値が存在することを確認できます。
6 つの個別値が存在します。 Liquefaction Risk テーブルには、実際には 7 つの個別値が含まれています。 つまり、リスク カテゴリーの 1 つに歴史的な場所が存在していません (幸いなことに、それは赤色ゾーンです)。
最頻値 (最も一般的な値) は、非住居エリアです。
最も一般的でない値は、技術カテゴリー 1 です。
データ エンジニアリング ビューで、チャートのプレビュー 列にポインターを合わせます。

ヒントは、値の割合の内訳を提供します。 歴史的な場所の約半数は非住居エリアにあり、約 4 分の 1 は技術カテゴリー 2 に属している、などです。
行ヘッダー (行の左端にある四角形) を右クリックして チャートの作成
をポイントし、バー チャート
をクリックします。
チャート ビューと チャート プロパティ ウィンドウが表示されます。 チャートには、リスク カテゴリーごとの歴史的な場所の数が表示されます。 チャートがわかりやすくなるように、プロパティを変更します。

Y 軸の値とカテゴリー ラベルの向きは、チャートの表示サイズによって異なる可能性があります。 チャート プロパティ ウィンドウの上部で、データ タブが選択されていることを確認します。
データ ラベル の下で、バーにラベル付け チェックボックスをオンにします。
チャートには、リスク カテゴリーごとの歴史的な場所の数が、各バーの上に表示されます。
ウィンドウの上部にある 軸 タブをクリックします。
ラベル文字制限 ボックスの値を 11 から 20 に変更します (矢印キーを使用するか、値を入力して Enter キーを押すことができます)。
X 軸では、カテゴリーの値にフルネームが表示されています。 ラベル方向は、使用可能なスペースにベスト フィットするようにデフォルトで調整されます。 しかし、方向を変更した方が良い場合もあります。
必要に応じて、ラベル方向 ドロップダウン矢印をクリックし、目的の設定を選択します。
ウィンドウの上部にある 一般 タブをクリックします。 (表示されない場合は、オプション ボタン
をクリックし、ドロップダウン リストの 一般 をクリックします)。チャートのタイトル ボックスで、デフォルトのタイトルを削除して「Historic Places by Liquefaction Risk Category」と入力します。 Enter キーを押します。
X 軸のタイトル チェックボックスをオフにします。
Y 軸のタイトル ボックスで、デフォルトのタイトルを削除して「Number of Sites」と入力します。 Enter キーを押します。
バーの色は現在黄緑に設定されていますが、この色を変更した方が良い場合もあります。
必要に応じて、シリーズ タブをクリックします。
シンボル 列で、黄緑色の四角形をクリックします。
表示されたカラー パレットで、目的の色をクリックします。
カラーパレットの外側をクリックして、パレットを閉じます。

チャートのバーをクリックして選択します。
マップ上で、Historic Places レイヤー内の対応するフィーチャが選択されます。
別のバーをクリックして選択を変更します。 Ctrl キーを押しながら別のバーをクリックして、選択に追加します。
チャート ビュー ツールバーで、選択解除
をクリックします。チャート ビューを閉じて、チャート プロパティ ウィンドウを閉じます。 データ エンジニアリング ビューは開いたままにします。
コンテンツ ウィンドウの Historic Places レイヤーの下にチャートが表示されます。 このチャートはレイヤーから独立して存在するものではありません。マップからレイヤーを削除するか、プロジェクトからマップを削除すると、チャートも消滅します。 チャートをエクスポートして、グラフィックス ファイルとして保存することができます。
クイック アクセス ツールバー で プロジェクトの保存
をクリックします。
テーブルからレイヤーを作成
プロジェクトに関連する追加のデータが使用できるようになります。 クライストチャーチのいくつかの歴史的な場所に関する情報を含む .csv ファイルを見つけたとします。 これらの場所が Historic Places レイヤーにまだ含まれていない場合、追加する必要があると思われます。
.csv ファイルはテーブルとしてマップに追加します。 このファイルには場所の空間座標が含まれているので、その座標位置のフィーチャを含むテーブルからレイヤーを作成できます。
カタログ ウィンドウをアクティブにします。 ウィンドウの上部で プロジェクト タブが選択されていることを確認します。
フォルダー コンテナー
を展開します。 Join_data_spatially > commondata > userdata の順に展開します。userdata フォルダーには
Christchurch Heritage Sites.csvという名前のファイルが格納されています。Christchurch Heritage Sites.csv を右クリックし、現在のマップに追加
をクリックします。コンテンツ ウィンドウでは、このファイルが スタンドアロン テーブル 見出しの下にテーブルとして追加されます。
コンテンツ ウィンドウで、Christchurch Heritage Sites.csv を右クリックし、開く
をクリックします。
このテーブルには 2 つの歴史的な場所に関する情報が含まれています (名前、住所、登録番号などのフィールドを含む)。
ビュー タブをクリックして Historic Places テーブルをアクティブにします。
このテーブルには名前と住所のフィールドも含まれています。
RegIDフィールドは、Christchurch Heritage Sites テーブルのRegisterNumberフィールドに対応しています。 フィールド名は異なりますが、同じ情報が格納されています。Christchurch Heritage Sites.csv テーブルをもう一度アクティブにします。
このテーブルには、度 (10 進) 単位の緯度と経度の座標を含む
XフィールドとYフィールドが含まれています。 これらの座標を使用して、テーブルからレイヤーを作成します。 それを行うと、Historic Places レイヤーにフィーチャがすでに存在しているかどうか確認できるようになります。コンテンツ ウィンドウの スタンドアロン テーブル の下で、Christchurch Heritage Sites.csv を右クリックして テーブルからポイントを作成
をポイントし、XY テーブル → ポイント
をクリックします。フローティング ウィンドウに XY テーブル → ポイント ツールが開きます。
入力テーブル パラメーターのデフォルト値が
Christchurch Heritage Sites.csvに正しく設定されています。 X フィールド および Y フィールド パラメーターのデフォルト値が、テーブルのXおよびYフィールドに正しく設定されています。 座標系 パラメーターのデフォルトは GCS_WGS_1984 です。 ほとんどの経度-緯度の値はこの座標系で保存されています。ヒント:
このケースの設定が正しいことを確認するために、カタログ ウィンドウでファイルを右クリックし、メタデータの表示
をクリックする方法もあります。出力フィーチャクラス テキスト ボックスの横の メモリー ワークスペース
をクリックします。 出力フィーチャクラスのパスを memory\Sites に変更します。
出力データを作成する必要がないので、ポイント フィーチャを一時的なメモリー ワークスペースに作成します。 Historic Places レイヤーにフィーチャがすでに存在していることがわかったら、この新しいレイヤーは破棄できます。 まだ存在していない場合は、Historic Places レイヤーにフィーチャをアペンドする必要があります。 いずれの場合も、これらを新しいデータセットに保存する必要はありません。
パス名
memory\は、出力がフィーチャクラスではなくメモリー ワークスペースに書き込まれることを示します。 ArcGIS Pro セッションを終了すると、メモリー ワークスペースが消去されます。 名前Sitesには任意の名前を指定できますが、スペースを含めることはできません。OK をクリックします。
ツールが終了すると、Sites というレイヤーが コンテンツ ウィンドウの上部に追加されます。
コンテンツ ウィンドウで、Sites レイヤーを右クリックして レイヤーにズーム
をクリックします。見やすくなるように、デフォルトのシンボルを大きくします。
コンテンツ ウィンドウで Sites レイヤーのシンボルをクリックします。
シンボル ウィンドウが開き、ポイント シンボルの書式設定のオプションが表示されます。
ギャラリー タブのシンボルのリストで、ArcGIS 2D にある 円 3 シンボルをクリックして選択します。

マップと コンテンツ ウィンドウで、シンボルが更新されます。
コンテンツ ウィンドウで、Sites レイヤーをオフにして再度オンにします。
Historic Places レイヤーでこれらの位置にフィーチャがまだ存在していないことを確認できます。
データのアペンド
アペンド ツールを使用して、Sites レイヤーから Historic Places レイヤーに 2 つのフィーチャをアペンドします。 2 つのレイヤー内のテーブルのスキーマは異なっているので、いくつかのフィールドを手動で一致させる必要があります。 この操作は、以前に使用したフィールド マップ パラメーターを使用して行います。
ヒント:
もう 1 つの方法は、リボンの 編集 タブの コピー
コマンドと 形式を選択して貼り付け
コマンドを使用して、あるレイヤーから別のレイヤーにフィーチャをコピーすることです。 このアプローチは、フィーチャの数が少ない場合に便利です。 コピーと貼り付けのワークフローでは、編集設定の構成によるフィールド マッピングもサポートされます。
Historic Places データ エンジニアリング ビューをアクティブにします。
行ヘッダー (行の左端にある四角形) を右クリックして、インテグレート
をポイントし、アペンド
をクリックします。フローティング ウィンドウ内に アペンド ツールが開きます。 ダイアログ ボックス上部のメッセージにより、ツールが (新しい出力データを作成するのではなく) ターゲット データセットを変更することが警告されます。
入力データセット ドロップダウン矢印をクリックして、Sites をクリックします。
デフォルトでターゲット データセットが Historic Places に正しく設定されます。
フィールド マッチング タイプ ドロップダウン矢印をクリックして、フィールド マップを使用してフィールドの違いをリコンサイル をクリックします。

ダイアログ ボックスが展開され、フィールド マップ パラメーターが表示されます。 ターゲット データセット (Historic Places) のフィールドの名前が表示されます。
RegIDフィールドとLIQUEFACTION_RISKフィールドは警告アイコン
でマークされます。入力データセット内の同じ名前のフィールドに対応しないためです。 (このため、入力フィールドがターゲット フィールドと一致する必要があるデフォルト設定でツールを実行すると、失敗します)。ただし、前に確認したように、Sites テーブルの
RegisterNumberフィールドと Historic Places テーブルのRegIDフィールドは、どちらも歴史登録番号を含んでいます。 フィールド名は異なるが、値に互換性がある場合、フィールド マップを使用してこれらのフィールドを手動で一致させることができます。フィールド マップ パラメーターで、編集
をクリックします。フィールド プロパティ ダイアログ ボックスが表示されます。
フィールド プロパティ ダイアログ ボックスの フィールド リストで、
RegIDフィールドが選択されている (青色でハイライト表示されている) ことを確認します。 ソース フィールドのリストをスクロールして RegisterNumber フィールドをクリックします。
アクションとソース フィールド に
RegisterNumberフィールドがタグとして表示され、これがソース フィールドとしてRegIDフィールドと一致していることが示されます。 警告アイコンがRegIDフィールドから削除されます。LIQUEFACTION_RISKフィールドは一致しない状態のまま残しておきます。Sites テーブル内に一致可能なフィールドがないためです。 ツールを実行すると、2 つの新しいレコードが Historic Places テーブルに追加されます。 属性は次のように処理されます。フィールドを一致させるため、Sites テーブル内の値が Historic Places テーブル内の対応するフィールドに追加されます。 たとえば、
Addressフィールドに住所が追加され、RegIDフィールドには登録番号が追加されます。一致するフィールドがない Historic Places テーブル内のフィールドは、アペンドされたレコードに NULL 値が設定されます。 つまり、
LIQUEFACTION_RISKフィールドには NULL 値が設定されるようになります。一致するフィールドがない Sites テーブル内のフィールドは、Historic Places テーブルに追加されません。 ここには
DateRegisteredフィールドやLocalAuthorityNameフィールド、その他いくつものフィールドが含まれます。
注意:
前に説明したように、2 つの Heritage Sites の空間座標は度 (10 進) で表されます。 アペンド ツールがこれらの座標を、ターゲット データセットの座標系に自動的に投影します。これが NZGD 2000 New Zealand Transverse Mercator です。
フィールド プロパティ ダイアログ ボックスで OK をクリックします。
アペンド ツールはジオプロセシング ツールの 1 つで、ジオプロセシング結果を元に戻すことができるものです。 このチュートリアルでは、元に戻すの有効化 切り替えボタンはオフにしたままです。
アペンド ツールで OK をクリックします。
ツールが完了したら、Historic Places 属性テーブルをアクティブにします。
テーブル ビューの下部で、テーブルに現在 324 のレコードが存在することを確認できます (前より 2 つ増えています)。
テーブル ビューの下部で 末尾に移動
をクリックして、テーブルの末尾まで移動します。
Sites レイヤーから 2 つのレコードがテーブルに追加されました。 予想どおり、これらのレコードの
Liquefaction Riskフィールドは NULL 値になっています。クライストチャーチの市街地のマップ ビューをアクティブにします。 コンテンツ ウィンドウで、Sites レイヤーをオフにします。

アペンドされたフィーチャは、マップ上の正しい位置に表示されます。 これで、Sites レイヤーは不要になりました。
コンテンツ ウィンドウで、Sites レイヤーを右クリックして 削除
をクリックします。作業を終了するには、新しいフィーチャの液状化リスクの値を特定して、テーブルに追加します。
クイック アクセス ツールバー で プロジェクトの保存
をクリックします。
新しいフィーチャのリスク ゾーンの特定
新しいフィーチャは空間結合の後に追加されたので、Liquefaction Risk フィールドには NULL 値が設定されています。 マップ操作 ツールを使用して、これらのフィーチャの値を見つけます。
リボンの マップ タブで、マップ操作 ツール
のドロップダウン矢印をクリックし、表示レイヤー をクリックします。マップ上で、Moncks Cave を表す、Historic Places レイヤー内の新しいフィーチャをクリックします (2 つの新しいフィーチャのうち、かなり北側にある方)。

ポップアップでは、Moncks Cave が液状化リスク ゾーンにあるものの、損害の可能性が低い部分に含まれることを確認できます。
必要に応じて、ポップアップを邪魔にならない場所に移動します。 マップ上で、Rotten Row Baches の新しいフィーチャをクリックします。
このフィーチャは非住居エリアにあります。
注意:
Liquefaction Risk レイヤーがポップアップに表示されない場合は、フィーチャを拡大してもう一度クリックします。 このフィーチャはレイヤー範囲のエッジにあります。 範囲外をクリックすると、結果は得られません。
ポップアップ ウィンドウを閉じます。
リボンの マップ タブで、マップ操作 ツール
のドロップダウン矢印をクリックし、最上位レイヤー をクリックして、デフォルト設定に戻します。
フィールド値の計算
フィールド演算では、ユーザーが記述した式に基づいてテーブルの値を更新します。 今回は、更新する必要があるのは 2 つの値のみで、テーブル セルを手動で編集する可能性もあります。 しかし、数百または数千個の値を更新する必要がある場合には、フィールド演算が不可欠です。 フィールド演算を使用すると、データ入力ミスのリスクも最小限に抑えられます。
Historic Places 属性テーブルをアクティブにします。 テーブルで、323 番の行ヘッダー (行の左端にあるグレーの四角形) をクリックして、Moncks Cave のレコードを選択します。
テーブルの上部にあるツールの行で 計算
をクリックします。フィールド演算ツールバーがツールの行の下に表示されます。
フィールド演算ツールバーで ターゲット フィールド のドロップダウン矢印をクリックし、Liquefaction Risk をクリックします。
計算する式を定義します。
Liquefaction Riskフィールドで、Moncks Cave の現在の NULL 値を、Damage unlikely 値に置き換える必要があります。フィールド演算ツールバーで 式の設定
をクリックします。式の設定 ダイアログ ボックスが表示されます。
式の設定 ダイアログ ボックスのフィールド リストで、Liquefaction Riskをクリックします。
Liquefaction Riskフィールドには、使用したい値が含まれています。 フィールドを選択すると、値の挿入 ドロップダウン リストが有効になります。値の挿入 ドロップダウン リストをクリックして、Damage unlikely をクリックします。

完成した式は
LIQUEFACTION_RISK = "Damage unlikely"です。OK をクリックします。
フィールド演算ツールバーで 選択済みを計算
をクリックします。Moncks Cave レコード (選択された唯一のレコード) が、液状化リスクの値を使って更新されます。 同じ方法で Rotten Row Baches レコードを更新できますが、今回はツールバーの式ボックスに必要な値をタイプ入力します。
テーブルで、324 番の行ヘッダーをクリックして、Rotten Row Baches のレコードを選択します。
フィールド演算ツールバーの式ボックスで 「"Damage unlikely"」という式を削除し、「"Nonresidential area"」(引用符も含む) と入力します。

選択済みを計算
をクリックします。Rotten Row Baches レコードが更新されます。
テーブルの上部にあるツールの行で 解除
をクリックして、選択したレコードを解除します。
2 つのフィールド計算はテーブルで編集されたものであり、保存する必要があります。
リボンの 編集 タブをクリックします。 編集の管理 グループの 保存
をクリックします。編集の保存 プロンプトで、はい をクリックします。
開いているテーブルとデータ エンジニアリング ビューを閉じます。
コンテンツ ウィンドウで Historic Places レイヤーを右クリックし、レイヤーにズーム
をクリックします。クイック アクセス ツールバー で プロジェクトの保存
をクリックします。
このチュートリアルでは、空間結合を使用して、ポリゴン レイヤーにある地震の液状化リスクの属性を、歴史的な場所のポイント レイヤーに追加しました。 データ エンジニアリング ビューで、結合テーブルのプロパティを探索しました。 .csv ファイルをマップ レイヤーに変換し、このレイヤーのフィーチャを歴史的な場所のレイヤーにアペンドしました。 最後に、アペンドしたレコードの値を計算して、欠落した情報を埋めました。
空間結合についてさらに学習する場合は、「ArcGIS Pro の基本操作」および「空間結合を使用した属性の借用」のチュートリアルをご参照ください。 データ エンジニアリングの詳細については、「ArcGIS Pro におけるデータ エンジニアリング」シリーズの記事とチュートリアルをご参照ください。 既存のデータの更新中に新しいデータをレイヤーにアペンドする方法については、「ArcGIS Pro のアペンド ツールを使用したデータセットのアップサート」をご参照ください。