Skip to main content

Управление данными

В ArcGIS Pro вы обычно работаете в проекте, который сохранен на вашем компьютере. Однако не всегда требуется сохранять проект. Иногда в ваши задачи входит подготовка и управление данными, и нет необходимости создавать карты и решать аналитические задачи. В этих ситуациях вы можете запустить ArcGIS Pro, не создавая проект. Так вы сможете обработать ваши данные и закрыть приложение без сохранения проекта.

Обзор

  • Это видео было создано в ArcGIS Pro 3.3.

В этом руководстве вы будете работать с рядом наборов данных, полезных для проектов восстановления окружающей среды в городе Крайстчерч, Новая Зеландия, и его окрестностях. Вы изучите данные, преобразуете их в общий формат файла и пространственную привязку, обрежете по исследуемой области и обновите их метаданные. Основная цель - создать упорядоченный сбор данных в базу геоданных, которая может публиковаться ГИС-профессионалами, работающими над связанными проектами в одной и той же географической области.

  • Предполагаемое время: 60 минут

  • Требования к программному обеспечению:

    • ArcGIS Pro Basic
Примечание:

Обучающие краткие руководства обновляются при каждом выпуске программного обеспечения. Для получения наилучших результатов используйте версию онлайн-справки, соответствующую версии вашего программного обеспечения.

Загрузка данных

Землетрясение магнитудой 6.2 балла, ударившее по городу Крайстчерч в Новой Зеландии 22 февраля 2011 года, унесло жизни 185 человек и причинило огромный материальный ущерб. В некоторых наиболее разрушенных районах города восстановление домов и объектов инфраструктуры было невозможно.

Ущерб от землетрясения

Показано здание в окрестности Нью-Брайтон города Крайстчерч после землетрясения 22 февраля 2011 года. Фотограф Мартин Лаф. Загружена из Wikimedia Commons и использована с лицензией Creative Commons 2.0.

Для одного из таких районов, в долине реки Отакаро-Эйвон, был разработан план создания так называемого зеленого каркаса пешеходных дорожек, велосипедных маршрутов и заболоченных территорий, ведущих от реки Эйвон к морю. В остальных районах города и окрестностях реализовываются многочисленные проекты в области сохранения биологического разнообразия и восстановления.

Вы загрузите данные, имеющие отношение к проектам восстановления в Крайстчерче и его окрестностях. Данные поступают из разных источников, имеют разные пространственные экстенты и системы координат, а также находятся в разных форматах файлов.

  1. Перейдите на страницу обзора Управление данными v330 в ArcGIS Online.

  2. Щелкните Скачать в правой части страницы.

  3. В папке Загрузки на вашем компьютере щелкните правой кнопкой мыши Manage_data_v330.zip и извлеките его в удобное местоположение, например C:\Temp.

    Примечание:

    Это руководство является учебным упражнением. Тем не менее проекты восстановления после землетрясения в Крайстчерче и его окрестностях, включая План регенерации долины реки Отакаро-Эйвон, являются реальными и работа по ним продолжается. Информация о землетрясении 2011 года доступна из многих источников, включая статью в Википедии Землетрясение в Крайстчерче (февраль 2011).

Запуск ArcGIS Pro без шаблона

Когда вы запускаете ArcGIS Pro без шаблона, вам не предлагается создать проект. В этом руководстве вы будете создавать данные и управлять ими в базе геоданных, поэтому нет необходимости сохранять работу как проект. При необходимости вы можете сделать это в любое время во время сеанса ArcGIS Pro.

В этом руководстве предполагается, что используются некоторые настройки приложения по умолчанию. Вы проверите эти настройки и при необходимости измените их.

  1. Запустите ArcGIS Pro и войдите в систему, если это необходимо.

  2. На начальной странице щелкните вкладку Настройки .

  3. В списке боковых вкладок щелкните Опции. В диалоговом окне Опции под пунктом Приложение, щелкните Общие.

  4. Разверните Создать проекты и разверните На локальном или сетевом компьютере. В разделе База геоданных по умолчанию при необходимости щелкните Новая база геоданных по умолчанию для каждого проекта.

    Опции базы геоданных по умолчанию для создания проектов

  5. В диалоговом окне Опции в разделе Приложение щелкните Метаданные. Если необходимо, щелкните стрелку ниспадающего списка Стиль метаданных и выберите Описание элемента.

  6. Щелкните OK в диалоговом окне Опции.

  7. Если вы изменили настройку базы геоданных по умолчанию, закройте и перезапустите ArcGIS Pro.

  8. На начальной странице в разделе Новый проект нажмите Запуск без шаблона.

    Запуск без шаблона

    Открывается пустой проект без названия. В отличие от проекта, созданного на основе шаблона по умолчанию, проект без названия не сохраняется на вашем компьютере.

Добавить подключение к папке

Вы добавите подключение к папке с учебными данными и просмотрите их.

  1. Щелкните вкладку Вид на ленте. В группе Окна щелкните Наборы панелей и щелкните Геообработка .

    Это гарантирует, что панели Содержание, Каталог и Геообработка открыты, тогда как остальные панели закрыты.

  2. Сделайте панель Каталог активной и подтвердите, что вкладка Проект выбрана в верхней части панели. Разверните контейнеры Базы данных и Папки.

    Панель Каталог

    Когда вы запускаете без шаблона, база геоданных по умолчанию и домашняя папка создаются во временной папке в вашем профиле пользователя.

    Подсказка:

    Чтобы увидеть путь к временной папке, наведите курсор на базу геоданных по умолчанию (Default.gdb) или домашнюю папку (Untitled) на панели Каталог.

  3. На панели Каталог щелкните правой кнопкой мыши контейнер Папки и щелкните Добавить подключение к папке .

  4. В диалоговом окне обзора Добавить подключение к папке перейдите к местоположению учебных данных (например, C:\Temp). Нажмите на папке Manage_Data, чтобы выбрать ее.

    Папка Manage_Data, выбранная в диалоговом окне обзора

  5. Нажмите OK.

    На панели Каталог в контейнере Папки появится подключение к папке .

    Примечание:

    Вам не нужно добавлять подключение к папке Supplemental. Если ваш активный портал является порталом ArcGIS Enterprise, вы будете использовать данные в этой папке позже в этом руководстве; в противном случае они вам не нужны.

  6. На панели Каталог разверните папку Manage_Data.

    Он содержит три папки, две базы геоданных и один шейп-файл.

  7. Разверните папки и базы геоданных.

    На панели Каталог развернута папка Manage_Data

    Папки содержат шейп-файлы. Каждая база геоданных содержит по два или три класса пространственных объектов.

Предварительный просмотр данных

Большая часть этих данных относится к проектам восстановления города Крайстчерч. Вы изучите наборы данных, чтобы узнать о них больше. Чтобы выполнить предварительный просмотр данных и их метаданных, откройте вид каталога.

  1. Убедитесь, что на ленте выбрана вкладка Вид. В группе Окна щелкните Вид каталога .

    Откроется вид каталога. На ленте появится вкладка Каталог. На панели Содержание отображается содержание каталога. Это включает элементы в вашем проекте, подключения к порталу, а также ваши локальные и сетевые папки.

    Примечание:

    Виды каталога и панель Каталог дополняют друг друга. У них есть похожие функции, но некоторые задачи, такие как предварительный просмотр данных, можно выполнить только в виде Каталог.

  2. На панели Содержание (не на панели Каталог), в разделе Проект разверните Папки . Разверните папку Manage_Data и щелкните Planning.gdb.

    Панель Содержание вида Каталог

    Содержание базы геоданных появится в виде Каталог. Здесь есть два класса пространственных объектов: AvonRiver и PlanArea.

  3. В виде каталога щелкните на PlanArea.

    Панель подробной информации вида Каталог

    Панель подробной информации в виде Каталог отображает метаданные выбранного класса объектов.

    Подсказка:

    Если панель подробной информации не отображается, щелкните вкладку Вид на ленте. В группе Опции щелкните Панель Детали , чтобы выбрать ее. (Эта кнопка также доступна в нижней части вида каталога.) В виде каталога можно переместить вертикальный разделитель между списком элементов и панелью деталей.

  4. Сканируйте метаданные элемента.

  5. Вверху панели описания щелкните вкладку География.

    Предварительный просмотр пространственных данных выполняется на базовой карте Светло-серое полотно.

  6. Щелкните объект области планирования в предварительном просмотре географии.

    Объект подсветится и появится панель Всплывающие окна. Во всплывающем окне объект будет описан как Otakaro/Avon River Corridor Regeneration Plan. Эта область определяет зеленый каркас пешеходных дорожек, велосипедных маршрутов, заболоченных участков и общественных территорий.

  7. Закройте панель Всплывающее окно.

    Примечание:

    Закрытие всплывающего окна вызывает обновление предварительного просмотра, и цвет пространственного объекта может измениться.

  8. Вверху панели описания щелкните вкладку Таблица и просмотрите атрибуты класса пространственных объектов.

    В таблице содержится одна запись с атрибутами названия и площади. Чтобы больше узнать о наборе растровых данных, вы откроете его свойства.

  9. В виде каталога нажмите правой кнопкой мыши на классе пространственных объектов PlanArea и щелкните Свойства .

  10. В диалоговом окне Свойства класса пространственных объектов во вкладке Источник разверните раздел Пространственная привязка.

    Диалоговое окно Свойства класса пространственных объектов

    Система координат проекции - WGS 1984 Web Mercator Auxiliary Sphere. Проекция для мира, такая как Меркатор, не идеальна для локального набора данных. Вы измените проекцию позже.

  11. Щелкните Отмена.

  12. На панели Содержание щелкните на базе геоданных Boundaries. В виде каталога щелкните на CommunityBoards.

  13. Просмотрите метаданные, географию и таблицу этого класса пространственных объектов.

  14. Откройте свойства класса пространственных объектов CommunityBoards и проверьте его пространственную привязку.

    Система координат проекции этого класса пространственных объектов - NZGD 2000 New Zealand Transverse Mercator, что является стандартом для данных и карт Новой Зеландии. Одна из задач этого руководства - перенести все наборы данных в эту систему координат.

  15. Щелкните Отмена.

  16. При необходимости просмотрите остальные наборы данных в папке Manage_Data.

Изучение данных на карте

Для дальнейшего изучения вы добавите наборы данных на карту. Вы сделаете это из панели Каталог.

  1. На панели Каталога убедитесь, что содержание папки Manage_Data по-прежнему раскрыто.

  2. Нажмите клавишу Ctrl и щелкните следующие наборы данных, чтобы выбрать их. Не выбирайте шейп-файл Parks.

    • Historic_Places

    • Native_Bird_River_and_Open_Water_Habitat

    • River_Centerlines

    • District_Plan_Zones_Open_Space

    • Flat_Land_Recovery

    • CommunityBoards

    • Districts

    • Region

    • AvonRiver

    • PlanArea

  3. Щелкните правой кнопкой мыши любой из выбранных наборов данных, выберите Добавить к новой и нажмите Карта .

    Открывается вид карты с названием Карта. На панели Содержание показаны слои карты.

  4. На панели Каталог щелкните Parks.shp, чтобы выбрать его. Перетащите его на карту.

    Карта со слоями, представляющими наборы данных

    Ваши слои могут быть отображены символами других цветов.
  5. На панели Содержание, под пунктом По отображению, щелкните правой кнопкой Карта, чтобы открыть ее свойства.

  6. В диалоговом окне Свойства карты, на вкладке Общие, измените имя карты по умолчанию с Map на Starting Data.

    Диалоговое окно Свойства карты

  7. Нажмите OK.

    На панели Содержание и на вкладке вида карты имя карты будет обновлено.

  8. На панели Содержание нажмите на слое Region, чтобы выбрать его. На панели Содержание перетащите его вниз в положение сразу над слоем World Topographic Map.

    При перетаскивании вы увидите пунктирную горизонтальную черту, показывающую местоположение слоя.

  9. Поместите слой CommunityBoards над слоем Region. Переместите слой Districts в положение над слоем CommunityBoards.

    Теперь слои административных границ не скрывают объекты в других слоях.

  10. На панели Содержание щелкните правой кнопкой мыши слой PlanArea и выберите Приблизить к слою .

    Карта, масштабированная до слоя PlanArea

    Проекты реставрации могут располагаться за пределами зоны планирования, но, вероятно, не слишком далеко. Вы найдете набор данных, который поможет определить область интереса.

  11. На панели Содержание щелкните правой кнопкой мыши слой Districts и выберите Таблица атрибутов .

    Каждый район в слое Districts представлен строкой в таблице атрибутов.

  12. В таблице щелкните заголовок строки 4 (серый квадрат у левого края строки), чтобы выбрать запись для города Крайстчерч (Christchurch City).

    Таблица атрибутов слоя Districts

  13. В строке инструментов в верхней части таблицы щелкните Приблизить к .

    Объект Christchurch City выбран на карте

    Пространственный объект Christchurch City выбран на карте. Этот район небольшой, но он все же больше, чем вам нужно, так как в него входит полуостров Бэнкс – скопление скал круглой формы, не являющееся частью территории реставрации.

  14. В строке инструментов в верхней части таблицы щелкните Очистить .

  15. Закройте таблицу Districts.

    Вы можете изучить другие слои карты, чтобы найти пространственный объект, представляющий вашу область интереса, но вместо этого вы выполните поиск в ArcGIS Living Atlas of the World.

Добавить данные из ArcGIS Living Atlas of the World

ArcGIS Living Atlas of the World — это коллекция достоверной географической информации, курируемая Esri.

Примечание:

Если ваш активный портал — ArcGIS Enterprise, а не ArcGIS Online, слой, добавленный в этом разделе, будет вам недоступен из ArcGIS Living Atlas. Выполните шаги, описанные в этом примечании, чтобы добавить эквивалентный слой из папки Supplemental в загруженных вами данных.

  1. На вкладке Карта ленты, в группе Слой, щелкните Добавить данные .

  2. В диалоговом окне Добавить данные, в разделе Компьютер , перейдите к C:\Temp\Supplemental (или к папке, в которую вы загрузили данные).

  3. Щелкните NZ Urban Rural Indicator Areas.lyrx, чтобы выбрать его, и нажмите OK.

  4. Продолжите с шага 6 в этом разделе.

  1. Убедитесь, что на ленте активна вкладка Карта. В группе Слой щелкните Добавить данные .

  2. В диалоговом окне обзора Добавить данные, в разделе Портал, щелкните Living Atlas .

  3. Щелкните в поле поиска в верхней части диалогового окна Добавить данные. Введите New Zealand urban areas и нажмите клавишу Enter.

  4. В списке результатов поиска щелкните векторный веб-слой NZ Urban Rural Indicator Areas - Current, чтобы выделить его.

    Список результатов поиска в диалоговом окне Добавить данные

    Ваш список результатов поиска может отличаться, и вам, возможно, придется прокрутить вниз, чтобы найти слой.
  5. Нажмите OK.

    Веб-слой добавлен на карту.

  6. Приблизьтесь к городской территории Крайстчерч - большое оранжевое пятно в центре вида.

    Городская территория Крайстчерч

  7. Убедитесь, что на панели Содержание выбран слой NZ Urban Rural Indicator Areas.

  8. На ленте, на вкладке Карта, в группе Навигация, щелкните стрелку ниспадающего меню инструмента Исследовать и выберите Выбранные на панели Содержание.

    Инструмент Исследовать с ниспадающим списком настроек

    Когда вы щелкаете пространственный объект на карте, на панели Всплывающее окно отображается информация для слоя (или слоев), выбранного на панели Содержание.

  9. На карте щелкните в любом месте внутри городской территории Крайстчерч.

    Объект подсвечивается на карте. Панель Всплывающие окна подтверждает, что объект представляет основную городскую территорию Крайстчерча. Вы будете использовать этот объект для задания области исследования.

    Панель Всплывающие окна

  10. Закройте панель Всплывающее окно.

    Вы будете работать с этим слоем на протяжении всего урока, поэтому дадите ему более короткое имя.

  11. На панели Содержание дважды щелкните слой NZ Urban Rural Indicator Areas, чтобы открыть его свойства.

  12. В диалоговом окне Свойства слоя, на вкладке Общие, замените текущее имя на Urban Area.

    Вкладка Общие в диалоговом окне Свойства слоя

  13. Нажмите OK.

    Слой переименован на панели Содержание.

  14. Щелкните стрелку ниспадающего меню инструмента Исследовать и выберите Верхний слой.

    Для этого инструмента это настройка по умолчанию.

Создание базы геоданных в новой папке

По мере обработки начальных данных вы будете сохранять свои выходные наборы данных в новую базу геоданных в новой папке. Вы сделаете эту базу геоданных местоположением по умолчанию для создаваемых вами данных. В конечном итоге вы планируете предоставить общий доступ к этой базе геоданных и папке специалистам ГИС, работающим над проектами восстановления Крайстчерч.

  1. Сделайте вид Каталог активной (не панель Каталог).

  2. На панели Содержание, в разделе Проект, щелкните правой кнопкой мыши контейнер Базы данных и выберите Новая файловая база геоданных .

  3. В диалоговом окне Новая файловая база геоданных перейдите к папке, в которую вы извлекли данные учебного пособия (например, C:\Temp). Дважды щелкните на папке, чтобы открыть ее.

    Вы видите папки Manage_Data и Supplemental. Вы создадите другую папку для хранения новой базы геоданных. Вы можете сделать это в процессе создания базы геоданных.

  4. В диалоговом окне обзора щелкните стрелку ниспадающего меню Новый элемент и щелкните Папка .

    Диалоговое окно обзора с выбранным ниспадающим меню Новый элемент

    Создана новая папка. Ее имя по умолчанию можно изменить.

  5. Переименуйте папку ChristchurchRenewal и нажмите клавишу Enter.

    Новая папка выбрана.

  6. Щелкните Открыть, чтобы открыть папку ChristchurchRenewal (она пуста).

  7. В текстовом окне Имя в нижней части диалогового окна введите ChristchurchData в качестве имени новой базы геоданных. Щелкните Сохранить.

    Новая база геоданных создается и добавляется в проект.

  8. На панели Содержание щелкните контейнер Базы данных .

    Новая база геоданных появляется в виде каталога под базой геоданных по умолчанию, которая была создана при запуске без шаблона.

    База геоданных по умолчанию, отмеченная значком домика , — это база, в которую сохраняется большинство выходных данных геообработки, если не указано иное. В качестве базы геоданных по умолчанию можно задать любую базу геоданных. (Тот факт, что текущая база геоданных по умолчанию называется Default.gdb, не имеет значения.)

  9. В виде каталога щелкните ChristchurchData.gdb, чтобы выбрать ее.

  10. На ленте щелкните вкладку Управлять. В группе Проект щелкните По умолчанию .

    У базы геоданных ChristchurchData появится значок домика.

Вырезать данные и сохранить их в новую базу геоданных

Вы вырежете большую часть данных в папке Manage_Data для городской территории Крайстчерч с помощью инструмента геообработки Попарное вырезание. Вы запустите инструмент как пакетный инструмент, что позволит вам обрабатывать несколько входных наборов данных за одну операцию. Новые выходные данные будут сохранены в базе геоданных ChristchurchData. Любые входные шейп-файлы будут автоматически преобразованы в формат базы геоданных.

Вырезание объектов меняет их геометрию. Например, река, которая пересекает границу городской территории Крайстчерча, будет разбита на границе. Сохранен будет только тот сегмент, который находится внутри границ.

Как упоминалось ранее, вы хотите, чтобы ваши выходные данные были в системе координат New Zealand Transverse Mercator. Перед запуском инструмента Попарное вырезание вы зададите параметр среды инструмента, который при необходимости спроецирует входные наборы данных в эту систему координат.

  1. Сделайте вид карты Начальные данные активным.

  2. На панели Содержание щелкните правой кнопкой мыши на слое Urban Area, перейдите к пункту Выборка и щелкните Сделать только этот слой доступным для выборки .

  3. На ленте во вкладке Карта в группе Выборка щелкните Выбрать . На карте щелкните на объекте территории города Крайстчерч, чтобы выбрать его.

    Городская территория Крайстчерч выбрана

    При запуске инструмента Попарное вырезание вы зададите слой Urban Area в качестве вырезающего слоя. Инструмент будет использовать выбранный объект в качестве экстента вырезания.

  4. Станет активной панель Геообработка. В окне поиска введите попарное вырезание.

    В результатах поиска Попарное вырезание будет на первом месте в списке.

    Инструмент Попарное вырезание

    Подсказка:

    Чтобы изменить отображение инструментов, в нижней части панели Геообработка щелкните Показать инструменты с описаниями и подробной информацией или Показать инструменты в виде списка .

  5. В результатах поиска щелкните правой кнопкой инструмент Попарное вырезание и выберите Пакетно.

    Откроется инструмент Пакетно Попарное вырезание. Большинство инструментов геообработки могут быть запущены в пакетном режиме. Пакетные инструменты по умолчанию являются временными, но вы можете сохранить пакетный инструмент, чтобы сделать его постоянным.

  6. В графе Выбрать пакетный параметр, убедитесь, что выбраны Входные объекты. Снимите отметку с Добавить выходные наборы данных к открытой карте.

    Инструмент Пакетно Попарное вырезание

    Вместо этого, после запуска инструмента вы добавите выходные наборы данных на новую карту.

  7. Щелкните Далее.

  8. Рядом с Пакетно Входные объекты щелкните Добавить несколько . Рядом со строкой поиска установите отметку Переключить все опции.

    Ниспадающий список Пакетно Входные объекты с выбранными всеми слоями

    Выбраны все слои карты. Однако вы не хотите применять вырезание ко всем из них. Слои границ должны сохранить свою территориальную целостность, поэтому вы обработаете их отдельно.

  9. В списке слоев снимите отметки для следующих слоев:

    • Districts

    • CommunityBoards

    • Region

    Ниспадающий список Пакетно Входные объекты с некоторыми отмененными слоями

    Слой Urban Area включен во входные объекты для вырезания и будет вырезан по своему собственному выбранному объекту.

  10. Внизу ниспадающего списка щелкните Добавить.

    Кнопка переключения отображается под Urban Area, поскольку на слое имеется выборка. По умолчанию обрабатываются только выбранные записи.

  11. Для Вырезающих объектов щелкните стрелку ниспадающего списка и выберите Urban Area.

    Параметр Вырезающие объекты инструмента Пакетно Попарное вырезание

    Кнопка-переключатель снова появляется под слоем Urban Area.

  12. В строке Выходной класс объектов удалите префикс PairwiseClip_OutFeatureClass_ из имени выходного класса объектов и оставьте только переменную %Name%.

    Внимание:

    Не удаляйте весь путь к выходной базе геоданных. Удаленные пути могут и не восстановиться корректно при запуске инструментов в пакетном режиме.

    Путь выходного класса объектов указывает на базу геоданных ChristchurchData, поскольку эта база геоданных используется по умолчанию.

    Параметры инструмента Пакетно Попарное вырезание

    Переменная %Name% назначает имя входного слоя выходному набору данных. Так как выходные данные сохраняются не туда, где хранятся входные данные, префикс имен файлов для предотвращения конфликтов названий (например, PairwiseClip_OutFeatureClass_) не требуется.

    Несмотря на то, что слои карты в разных системах координат могут пространственно выравниваться с помощью проецирования на лету, вы хотите, чтобы выходные данные были созданы в системе NZGD 2000 New Zealand Transverse Mercator. Вы создадите настройку среды для проецирования входных наборов данных в эту систему по мере необходимости.

    Параметры среды геообработки - это параметры, которые не встроены в инструмент, но могут применяться к выходным данным при запуске инструмента. В этом случае использование параметра среды более эффективно, чем запуск инструмента Проецировать для наборов данных, которые находятся в системе координат Web Mercator.

  13. В верхней части окна инструмента Пакетно Попарное вырезание щелкните вкладку Параметры среды.

  14. В разделе Выходные координаты, рядом с Выходная система координат, щелкните Выбрать систему координат .

  15. В диалоговом окне Выходная система координат, в разделе Доступные системы координат, разверните Слои.

    Перечислены две системы координат, используемые в слоях карты.

  16. Щелкните NZGD 2000 New Zealand Transverse Mercator, чтобы выбрать ее.

    Диалоговое окно Система координат

  17. Нажмите OK.

    Входные наборы данных, хранящиеся в системе координат Web Mercator, например, PlanArea, будут спроецированы в New Zealand Transverse Mercator при вырезании.

  18. В поле ввода Географические преобразования введите (или скопируйте и вставьте) NZGD_2000_To_WGS_1984_1. Нажмите клавишу Enter.

    Параметры среды для выходных координат инструмента Пакетно Попарное вырезание

    Это преобразование географического датума гарантирует, что наборы данных проецируются настолько точно, насколько это возможно.

  19. На панели Геообработка щелкните Запустить .

    По завершении работы инструмента в нижней части панели появится сообщение об успешном выполнении.

Просмотр вырезанных данных

Вы изучите выходные наборы данных в базе геоданных ChristchurchData и добавите их на новую карту.

  1. Сделайте вид каталога активным.

  2. На панели Содержание, под Проект , при необходимости разверните Базы данных . Щелкните ChristchurchData.gdb.

    Содержание базы геоданных

    В виде каталога можно видеть, что в базе геоданных находится девять классов пространственных объектов.

  3. В виде каталога щелкните класс пространственных объектов PlanArea, чтобы выбрать его. Щелкните правой кнопкой мыши выбранный класс объектов и выберите Свойства .

  4. В диалоговом окне Свойства класса пространственных объектов во вкладке Источник разверните раздел Пространственная привязка.

    Информация о пространственной привязке в диалоговом окне Свойства класса пространственных объектов

    Этот набор данных был спроецирован в систему координат New Zealand Transverse Mercator, как указано в настройках среды геообработки.

  5. Щелкните Отмена.

  6. Щелкните на классе объектов AvonRiver, чтобы выбрать его. Нажмите клавишу Shift и щелкните на классе объектов Urban_Area, чтобы выбрать все классы объектов.

  7. Щелкните правой кнопкой мыши любой выбранный класс пространственных объектов и выберите Добавить к новой > Карта .

    Откроется новый вид карты с именем Карта.

  8. На панели Содержание дважды щелкните Карта, чтобы открыть cвойства карты.

  9. В диалоговом окне Свойства карты, на вкладке Общие, измените имя с Карта на Final Data. Нажмите OK.

    На панели Содержание и на вкладке вида карты имя карты будет обновлено.

  10. На панели Содержание карты Final Data перетащите слой Urban_Area в положение непосредственно над слоем базовой карты World Topographic Map.

    Новая карта с вырезанными слоями

    Цвета ваших символов будут отличаться.
  11. Уменьшите масштаб карты, чтобы убедиться, что все слои вырезаны в пределах городской территории Крайстчерча.

Копировать и вставить слои карты

При запуске инструмента Попарное вырезание вы не обрабатывали слои границ, так как хотели сохранить их территориальную целостность. Однако эти слои охватывают гораздо большую часть региона Кентербери, чем вам нужно.

Вы скопируете эти слои на карту Final Data. В следующем разделе вы выберете объекты из этих слоев, которые хотите сохранить, и экспортируете их в базу геоданных ChristchurchData.

  1. Щелкните вид карты Starting Data, чтобы сделать его активным.

  2. Нажмите клавишу Ctrl. На панели Содержание щелкните слой Urban Area, чтобы снять с него выделение. По-прежнему удерживая нажатой клавишу Ctrl, щелкните слои Districts и CommunityBoards, чтобы выбрать их.

    Вы пропустите слой Region. В нем содержится только один объект, представляющий территорию округа Кентербери, и он слишком общий для ваших задач.

  3. На ленте, на вкладке Карта в группе Буфер обмена щелкните Копировать .

  4. Сделайте вид карты Финальные данные активным.

  5. На панели Содержание, вверху списка по отображению, щелкните карту Финальные данные, чтобы выделить ее.

  6. На ленте, на вкладке Карта в группе Буфер обмена щелкните Вставить .

    Два слоя вставляются наверху порядка отображения. Вам больше не нужно работать с картой Starting Data.

  7. Сделайте вид карты Начальные данные активным. Щелкните Закрыть на вкладке ее вида.

    Карта Final Data теперь является активным видом.

    Примечание:

    Карта Starting Data по-прежнему является частью вашего проекта. Ее можно снова открыть из контейнера Карты на панели Каталог или из панели Содержание в виде каталога.

Выбрать объекты по местоположению и экспортировать выборки

Два слоя границ важны для ваших окончательных данных, поскольку на проекты восстановления может распространяться местная политическая юрисдикция.

Вы примените пространственную выборку для объектов слоя CommunityBoards и слоя Districts, которые имеют область, соответствующую территории города Крайстчерч. Вы экспортируете выбранные объекты в базу геоданных ChristchurchData.

  1. На ленте, на вкладке Карта, в группе Выборка, щелкните Выбрать по расположению .

    Откроется инструмент Выбрать по расположению. Параметр Входные объекты используется для указания объектов, которые вы хотите выбрать. Слой Districts уже отображается в списке входных объектов.

    Примечание:

    Для удобства некоторые инструменты геообработки открываются в плавающем окне. Вы также можете открыть эти инструменты на панели Геообработка.

  2. Подтвердите, что параметр Отношения установлен на Пересечение.

  3. Для Выбирающих объектов щелкните стрелку ниспадающего списка и выберите Urban_Area.

    Параметры инструмента Выбрать по расположению

  4. Щелкните Применить.

    Объекты в слое Districts выбираются на карте, если они пересекают городскую территорию. Строка состояния в нижней части вида карты показывает, что выбрано два объекта.

    В нижней части инструмента Выбрать по расположению теперь включена кнопка Экспорт выборки.

  5. В инструменте Выбрать по расположению щелкните Экспорт выборки.

    Появляется диалоговое окно Выходной набор данных. Местоположение выходных данных по умолчанию — база геоданных ChristchurchData, так как она является базой геоданных по умолчанию.

  6. В диалоговом окне Выходной набор данных в поле ввода Имя введите Urban_Area_Districts.

    Диалоговое окно Выходной набор данных

    Панель местоположения в верхней части диалогового окна показывает путь к выходным данным.
  7. Щелкните Сохранить.

    Новый слой Urban_Area_Districts, состоящий из двух объектов, добавляется на карту.

  8. Оставьте инструмент Выбрать по расположению открытым. На ленте, на вкладке Карта, в группе Выборка щелкните Очистить .

  9. В инструменте Выбрать по расположению щелкните стрелку ниспадающего меню Входные объекты, для которой в данный момент установлено значение Districts, и щелкните CommunityBoards. Оставьте остальные настройки без изменений.

    Параметр Входные объекты в диалоговом окне Выбрать по расположению

  10. Щелкните Применить.

    Восемь объектов в слое CommunityBoards выбраны.

  11. В инструменте Выбрать по расположению щелкните Экспорт выборки.

  12. В диалоговом окне Выходной набор данных в поле ввода Имя введите Urban_Area_CommunityBoards. Щелкните Сохранить.

    Слой Urban_Area_CommunityBoards добавляется на карту.

  13. В инструменте Выбрать по расположению щелкните Закрыть .

  14. На ленте, на вкладке Карта, в группе Выборка щелкните Очистить .

  15. На панели Содержание нажмите клавишу Ctrl. Щелкните слой Urban_Area_CommunityBoards, чтобы отменить его выбор. Щелкните исходные слои Districts и CommunityBoards, чтобы выбрать их.

  16. Щелкните правой кнопкой мыши любой выбранный слой и щелкните Удалить .

  17. На панели Содержание перетащите слой Urban_Area_Districts в положение чуть выше слоя World Topographic Map.

  18. Перетащите слой Urban_Area_CommunityBoards над слоем Districts.

  19. Щелкните правой кнопкой мыши слой Urban_Area_Districts и щелкните Приблизить к слою .

    Карта увеличена до района

    Оба слоя выходят далеко за пределы городской территории Крайстчерч, так как они не обрезаны. Однако они включают только те объекты, которые пересекают территорию города.

  20. Сделайте вид каталога активным. Рядом с панелью местоположения щелкните Обновить .

    Вид Каталог, показывающий классы пространственных объектов в базе геоданных ChristchurchData

    База геоданных ChristchurchData теперь включает новые классы пространственных объектов Urban_Area_CommunityBoards и Urban_Area_Districts.

Обновление метаданных

Метаданные из входных наборов данных в папке Manage_Data были скопированы в новые наборы данных в базе геоданных ChristchurchData. Вы просмотрите метаданные, чтобы исправить орфографические ошибки и обновить описания элементов. Вы также создадите образцы, которые появятся в метаданных.

  1. В виде каталога щелкните правой кнопкой мыши класс пространственных объектов Native_Bird_River_and_Open_Water_Habitat и щелкните Редактировать метаданные .

    Откроется вид метаданных. Волнистые красные линии появляются под несколькими словами. К ним относятся орфографические ошибки, нераспознанные технические термины и редкие географические названия.

    Примечание:

    Если вы не видите волнистых красных подчеркиваний, необходимо включить проверку орфографии.

  2. Прокрутите вид метаданных.

    В поле Описание две орфографические ошибки.

    Метаданные с опечатками

  3. Щелкните правой кнопкой мыши на первой ошибке (acommpany) и щелкните на предложенной замене accompany.

    Ошибка исправлена и красное подчеркивание исчезло.

  4. Исправьте ошибку написания Emvironment на Environment тем же способом.

    В нижней части поля Описание маркированный список описывает изменения, внесенные в исходные данные.

  5. В поле Описание щелкните в конце текста и нажмите Enter, чтобы добавить второй пункт.

  6. Введите или скопируйте и вставьте следующее предложение: Данные были преобразованы в формат базы геоданных и обрезаны по городской территории Крайстчерч. Нажмите клавишу Enter.

  7. Для третьего маркированного пункта введите или скопируйте и вставьте следующее предложение: Некоторые наборы данных были спроецированы из Web Mercator в New Zealand Transverse Mercator.

  8. На ленте, на вкладке Метаданные, в группе Управление метаданными, щелкните Сохранить .

  9. Закройте вид метаданных.

  10. В виде каталога, если необходимо, нажмите вкладку Метаданные.

    Орфографические ошибки в описании исправлены. Добавленные вами примечания отображаются в нижней части описания.

  11. На панели Детали нажмите вкладку География.

    Данные предварительно просматриваются на светло-серой базовой карте.

  12. На ленте щелкните Предварительный просмотр. В группе Предварительный просмотр щелкните Базовая карта и щелкните Океаны.

    Базовая карта изменится при предварительном просмотре географии.

  13. В группе Образец щелкните Создать .

  14. На панели дополнительной информации нажмите вкладку Метаданные.

    Метаданные с образцом

    Образец добавляется в описание элемента.

  15. При необходимости отредактируйте описания элементов и создайте миниатюры для некоторых других наборов данных.

    Примечание:

    Все наборы данных имеют метаданные, за исключением класса пространственных объектов Urban_Area. Вы можете импортировать метаданные из веб-слоя NZ Urban Rural Indicator Areas - Current, выполнив следующие шаги:

    1. В виде каталога выберите класс объектов Urban_Area. На ленте, на вкладке Каталог, в группе Метаданные, щелкните Импорт .

    2. В диалоговом окне Импорт метаданных щелкните Перейти к пути источника метаданных .

    3. В диалоговом окне обзора, в разделе Портал, щелкните Living Atlas и выполните поиск NZ Urban Rural Indicator Areas — Current.

    4. Щелкните слой, чтобы его выбрать, и щёлкните OK. Убедитесь, что URL-адрес слоя добавлен в диалоговое окно Импорт метаданных.

    5. Щелкните OK, чтобы импортировать метаданные.

    Поскольку вы начали работу без шаблона, файл проекта не был сохранен на вашем компьютере (если только вы не сохранили проект самостоятельно). Созданные вами рабочие карты использовались для изучения данных и выбора входных слоев для инструментов, но у вас нет необходимости их сохранять.

  16. Щелкните вкладку Проект на ленте. В списке боковых вкладок щелкните Выход. Когда появится запрос о сохранении изменений, щелкните Нет.

    База геоданных ChristchurchData завершена. Папка ChristchurchRenewal, содержащая базу геоданных (вместе с любыми файлами документации или README, которые вы хотите добавить), готова к публикации для команд по восстановлению. Теперь эту папку можно поместить в сеть или распространить с помощью стандартных методов общего доступа к файлам. Его также можно загрузить в ArcGIS Online как файл .zip.